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1. GstarCAD 2017 Introduction and Installation 

1.1. GstarCAD 2017 Introduction 

Users can visit www.gstarcad.net to download GstarCAD 2017 to your computer or server.  

Design, share and visualize your CAD drawing is better with GstarCAD 2017. Best-ever core performance, best-ever 

functionalities implementation and best-ever innovations are what this CAD platform offers. 

This section helps you get started using GstarCAD 2017 software by explaining how to install it and providing basic information 

about how to use it. 

1.2. System Requirement 
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1.3. GstarCAD 2017 Installation 

GstarCAD 2017 Install Wizard will guide the user to install the software in the operating system completely and successfully.  

Please follow the steps below to install GstarCAD 2017: 

1.- Double-click the executable file downloaded and the "GstarCAD Install Wizard" dialog box will pop up. Click òBrowseó and 

choose the destination path where setup will install the files and then click the "Options" button. See Figure 1-1.  

 

2.- In the òGstarCAD Install Wizard->Optionó dialog box , Users can select or deselect the features according to your need. 

Click the "Next" button. See Figure 1-2. 

 

 

 

 

 

Figure 1-1                                    Figure 1-2 

3.- Confirm the path and click the "Install" button to continue. See Figure 1-3. 

 

4.- The òGstarCAD Install Wizard->Licenseó dialog box is displayed. If you agree with the license agreement, check òAccept 

the terms of the license agreementó and click the "Next" button. See Figure 1-4. 

 

 

 

 

 

Figure 1-3                                 Figure 1-4 

 

 

 

 



Chapter 1_GstaCAD 2017 Introduction and Installation 

3 

 

5.- Then the wizard is ready to begin the program installation. If you want to review or change any of your installation settings 

just click the "Back" button. Click the "Install" button to continue the installation. See Figure 1-5. 

6.- Then you will see the workspace selection window. Select your favourite workspace and click the "Finish" button to exit the 

wizard, The GstarCAD wizard has successfully installed GstarCAD 2017. See Figure 1-6. 

 

 

 

 

 

Figure 1-5                              Figure 1-6 

Remark: In GstarCAD 2017, AutoXlsTable has a separate installation package, you need to install it if your Microsoft Office is 

2007(32 bit) or 2010(32 /64-bit) when you meet with problem in AutoXlsTable in Express tools tab. 

 

Please follow the steps below to install AutoXlsTable: 

1.- Double-click the executable file downloaded and the "AutoXlsTable_InstallShield Wizard" dialog box will pop up. Click òNextó 

to continue. See Figure 2-1.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2-1 
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2.- Select the version of your Microsoft Office and click "Next". See Figure 2-2. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2-2 

 

3.- Click Install to start the AutoXlsTable installation, if you would like to review or modify your Microsoft office version, click 

back button to return to the previous step. See Figure 2-3. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2-3 
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4.- Then the InstallShield Wizard prompts you successfully finish installing AutoXlsTable, Click 'Finish' button to exit the wizard. 

See Figure 2-4. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2-4 
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2. Starting up GstarCAD 2017 

2.1. The User Interface 

You can enjoy working at GstarCAD 2017 environment in different ways. You can display and rearrange elements like the 

toolbars, display the command bar, switch between workspaces, change the interface themes and enable the status bar. The 

toolbars and command bar can also be floated anywhere on the screen or docked as well.  

 

 

 

 

 

 

 

 

 

 

 

2.1.1. Quick Access Toolbar:  

Display the frequently used tools like: 

New, Open, Save, Undo, Redo, Save 

As, Plot, Plot Preview and Help. Moreover you can customize it (adding more commands from the 

drop-down button) or showing it bellow/above the ribbon.   

                                     

2.1.2. Workspace Switching: Switch between two workspaces (2D Drafting and GstarCAD Classic).  
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2.1.3. Menu Bar: The menu bar is used for selecting commands by mouse instead of inputting commands by keyboard. In it 

you can find the follow menu tabs: File, Edit, View, Insert, Format, Tools, Draw, Text, Dimension, Modify, Window, Help and 

Express. 

 

                                     

 

2.1.3.1. Menus and Shortcut Menus 

You can use any of the option on the Menus from the menu bar at the top of the drawing 

area. Choose one of the following methods to use a menu:                      

- On the menu bar, click a menu name to choose the menu or to expand a list of options.                                                            

- Press Alt and the key for the underlined letter in the menu name to open the 

corresponding menu item list, and then choose menu items from it. For example, to edit 

the drawing file, press <Alt+E> to open the Edit menu.  

Shortcut menus provide quick access to specific commands. A shortcut menu displays 

when you right click an object, status bar, the Model tab name, or a Layout tab name. The selections presented in the shortcut 

menu depend on what you clicked. 

 

 

 

 

 

 

 2.1.3.2. Shortcuts Customize 

A faster way to invoke a command is customize its shortcut. The CUSTACC 

command allows you to customize, delete or modify existing command 

shortcuts. To access this command go through the menu bar, under tools, 

select customize and choose Shortcuts Customize. After that, the shortcut 

customize window will pop up. As you can see, there is a list of shortcuts 

command that you can easily modify, delete or even make a new one over an 

existing one.  
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If you want to create a new one, just click the New button and 

the customize command window will pop up. Then you can 

search the command or select one from the command list. For 

example, you can input òcommand lineó and then select the 

requested command. Notice that by selecting the requested 

command, at the right side of the window, will display the 

command properties. After selecting the command, press the 

OK button.  

Then the set shortcut window will pop up. You 

can input the desire keyword(s). For example, 

you can set the shortcuts SHIFT+D. If you want 

to delete a created shortcut command, invoke 

the command CUSTACC and then select the 

delete button from the Shortcut Customize 

window.  

2.1.4. The Ribbon: The ribbon consists of several panels, which are organized into each tab according to their task label. The 

tools and controls in each panel are also available in toolbars and dialog boxes. 

     

 

Panel                      Tab           Expandable panel     Expandable tools button 

Tab: The ribbon is structure by tabs. Every tab displays a 

series of panels with its own tools (commands or thumbnails) 

easier to select or pick. 

Panel: The panel shows the most used tools. Some 

thumbnails has an expandable tools button that can be 

expanded in a drop-down method. In addition, most of panels at home tab have an expandable 

panel that show up more commands related. 

Expandable Panel: The expandable panel is located at the bottom of the panel. If you click at the 

bottom of the panel, more commands related will be displayed.  

 

Expandable Tools Button: Some thumbnails (tools or commands at the panel) have an 

expandable tools button that can be expanded in a drop-down method. If you click this 

button, all related tools will be displayed. 
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2.1.5. Appearance: You can manage the interfaceõs theme plus show/display toolbars, menu bar, file tabs and status bar.    

   

 

 

  

  

2.1.6. Drawing Area: Your drawings are displayed in the drawing window.   

 

 

 

  

 

  

 

 

2.1.7. Toolbars: Toolbars partially contain buttons that start commands. When you move your mouse or pointing device over a 

toolbar button, the tooltip displays the name of the button.  
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The Standard toolbar at the top of the drawing area contains commonly used commands such as Copy Pan and Zoom, as well 

as Microsoft Office standard commands such as New, Open, and Save. GstarCAD 2017 classic workspace initially displays 

several toolbars by default: 

- Draw toolbar 

- Draw order toolbar 

- Change toolbar  

- Properties toolbar 

- Layer toolbar 

- Style toolbar 

- Standard toolbar 

2.1.7.1. Displaying and Hiding Toolbars 

GstarCAD 2017 provides many toolbars, which you can show or hide in both classic and ribbon interfaces. You can also move 

and dock toolbars. To choose which toolbars to display: 

1.- Execute TOOLBAR command or select the option TOOLBARS from the drop-down list under Appearance button (at top right 

of the interface) to open the Toolbar dialog box. 

2.- Choose the toolbars you want to hide or display by checking/unchecking the small boxes in the dialog box, then click OK. 

 

 

 

 

 

To make floated a horizontal docked toolbar, just click and hold the 

left side of it and drag around the place you need.  

To make floated a vertical docked toolbar, just click and hold the top 

of it and drag around. To dock any toolbar, just double-click at the left 

side of it.   

2.1.7.2. Starting Commands Using Toolbars 

To start a command from a toolbar, click a command button and 

respond to the prompts. 
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2.1.8. User Coordinate System (UCS): The icon indicates the orientation of the drawing in two dimensional space.  

  

 

           

 

 

2.1.9. Model Space and Layout Space tabs: Click a tab to switch between the drawing of your model and a printed layout.            

   

 

 

 

 

 

 

 

2.1.10. Command Window: The command bar is a dockable window in which you can type commands and view prompts and 

other program messages. You can move the command bar by dragging it. 

When the command bar is floating, you can drag the top or bottom of the window to change the number of lines of text it 

displays. You can dock the command bar at the top or bottom of the drawing. 
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2.1.10.1. Enter Commands on the Command Line 

Type the full command on the command line and press ENTER or 

SPACEBAR, or right-click your pointing device to start the command. 

Some commands also have abbreviated names (aliases). 

 

2.1.10.2. Specify Command Options 

Once you have entered a command on the command line, 

it displays a set of options or a dialog box. To choose a 

different option, enter one of the options in the brackets 

(either uppercase or lowercase letter is OK), and then 

press ENTER or SPACEBAR

2.1.10.3. Execute, Repeat and Cancel Commands 

To execute commands, press SPACEBAR or ENTER, or right-click your pointing device when the command names has been 

entered or responsive to prompts. If you want to repeat a command that you have just used, press ENTER or SPACEBAR. To 

cancel a command in progress, press ESC. 

 

2.1.10.4. Nesting a Command 

To use a command inside an active command, type an apostrophe before you type the command. For example, you turn on the 

object snap while you are drawing a circle, thus you can setup Object snap mode before continuing drawing. 

Command: circle > Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 'osnap 

(Setup object snap mode as Center in Draft Settings dialog, and then close the dialog to go on performing CIRCLE command) 
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2.1.10.5. Enter System Variables on the Command 

Line  

System variables are available for controlling how 

certain commands work. For example, GRIDMODE is 

used to control the grid status ON or OFF. 

 

2.1.10.6. Using the Prompt History Window 

The Prompt History window displays a history of the 

commands and prompts issued since you started the 

current session of GstarCAD.  

To display or close the Prompt History window press F2. 

To view entries in the Prompt History window, just drag the 

scroll bars or use the Up (ŷ) and Down (Ź) arrows to 

display previously used commands.  

2.1.10.7. Switch Dialog Boxes and Command Line 

If you enter LINETYPE on the command line, the Linetype Manager dialog box will pop up. Entering -LINETYPE on the 

command line displays the equivalent command line options. The system variables below affect the display of dialog boxes as 

well: 

-ATTDIA controls whether INSERT uses a dialog box for attribute value entry.                               

-EXPERT controls whether certain warning dialog boxes are displayed.                                        

-FILEDIA controls the display of dialog boxes used with commands that read and write files. For example, if FILEDIA is set to 1, 

OPEN displays the Open Drawing As dialog box. If FILEDIA is set to 0, OPEN displays prompts on the command line. Even 

when you set FILEDIA to 0, you can get a file dialog box displayed through entering a tilde (~) at the first prompt.  

2.1.10.8. Dynamic Input 

"Dynamic input" box is a floating window which appears near the cross cursor. 

It provides a convenient method for users to input commands or system 

variables dynamically and display the index information. When the DYN mode 

is turned on, a drop-down box will appear near the 

cross cursor. Type a command using the dynamic input, 

it displays a list of all the commands whose prefix 

matches what you've typed plus it will displays all their 

icons making easier to recognize them at glance. 

What's more, the dynamic input displays all options of a command and could select them in different methods.  
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2.1.11. Status Bar: Display information such as the current cursor coordinates, Snap, Grid, Ortho, Polar, Osnap, Otrack and 

other settings. In addition to displaying information, the status bar is a quick way to access many features. You can click status 

bar items to make changes, and right click items to display short cut menus that allow you more choices. By default, the status 

bar is shown as the picture below: 

 

The status bar icon also can be show as text button, right click on one of the icon 

of the status bar, uncheck the "Use Icon" option, you will get another method to 

show the status bar. 

  

2.1.12. Properties Palette: You can modify the value or properties of object(s) you wanted in each column. The Properties 

palette shows all properties of the specified object. When selecting multiple objects, the Properties palette shows the 

command properties of the selected objects. If none of the object is selected, the Properties palette displays the general 

properties of the current layer, View properties as well as the UCS information. By default, double-click an object opens 

Properties palette if the Properties palette is hidden. This operation is not available when the objects are block, hatch pattern, 

text, multiline, external reference or gradient fill. 
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2.2. Customize the Drawing Environment 

In GstarCAD 2017 there are different elements of the working environment that can be customized to fit your needs. 

2.2.1. Set Interface Options 

In the Options dialog box, you can change many of the settings that affect the interface and drawing environment. 

 

 

 

 

 

 

 

 

 

2.2.2. Settings of Modifying Interface: 

Automatic Save (Open and Save tab): Save your drawing at specified time intervals. To use this option, in the Options dialog 

box, Open and Save tab, select Automatic Save and enter the interval in minutes. 
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Color (Display tab): Specify the background colors used in 

the layout and Model tabs and the color used for prompts 

and crosshair.                                                                                 

Font (Display tab): Change the fonts used in the window 

and in the text window. This setting does not affect the text 

in your drawings. 

 

Search Path (Files tab): Set the search path to find drawing 

support files such as text fonts, drawings, linetypes, and 

hatch patterns. 

 

2.2.3. Save and Restore Profiles 

Creating profiles for different users or projects and sharing profiles by importing and exporting profile files are enabled. By 

default, your current options are stored in a profile named Default. The current profile name, as well as the current drawing 

name, is displayed in the Options dialog box. 

 

 

 

 

 

 

 

GstarCAD 2017 stores the profile information in the system registry and saves it as a text file (an ARG file) and also organizes 

essential data and maintains changes in the registry as required. 

If you make changes to your current profile during a session and you want to save those changes in the ARG file, you must 

export the profile. When you export the profile with the current profile name, GstarCAD updates the ARG file with the new 

settings. You can re-import the profile to update your profile settings. 
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2.3. Customize User Interface 

Drag & Drop Customization: An innovative way to customize user interface must be easy and quickly according to user needs, 

so this is possible by drag and drop action, that means users can drag any command from the command list and drop it into 

workspaces elements like ribbon panels and toolbars that are visible at top right corner of the CUI dialog box. Users will not 

have restrictions to place anywhere or even arrange a preferred command on a panel or toolbar. UI customization has never 

been easier and flexible through Drag & Drop action. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Brief introduction of CUI dialog box: 

1. CUI dialog box: Now the CUI dialog box is divided into three tabs: Elements Customization, Workspace Customization and 

Transfer tab in which the main attraction is the Elements Customization tab through its new way of customization (Drag & Drop).  
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2. Right click menu: Context menu is available for different interface element as shown below:  

 

 

 

 

 

 

 

 

 

 

 

 

3.  Find command: There are several methods to quickly find out the command you want, with these methods, you never need 

to browse the command from the top of the list until the end which greatly enhance your work efficiency. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1- Filter the command by Category: Click the button right side and select the category the 

command belongs which will reduce the command search scope  

 

2-Filter a command by entry relevant keywords: For example, input òdimensionó in the filter, all 

the commands contains the word òdimensionó will be shown, reducing the number of 

commands to browse. 
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3- Command cleaner: If you input the keywords in the filter, the icon will automatically change to   which is used 

to clean the content in the filter, meanwhile, the following command list will return to the default state. 

4- Find and replace: In Find tab input the command you want to find out and click Find Next, the command you searched will 

be positioned accurately. In replace tab, you can replace one command with another command, but we suggest not change the 

standard command name and description. 

 

 

 

 

 

 

 

 

 

5- Create a new command: If it is necessary to add secondary development program command to the command list, you can 

set the items follow the current command settings as shown below. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Restore and reset: 

If all the customization operation has been finished, but you made 

some mistakes when customizing CUI or you are not satisfied with 

the effect, restore and reset can help you recover to the 

original settings. 

Restore̔ Restore the backup Settings, click "Apply" button, the data 

before modifying will be saved as backup files which are used for 

recovery. 

Reset̔ Recover to the initial setting when first installing GstarCAD.  
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2.4. Tool Palettes 

Tool palettes are tabbed areas within the Tool Palettes window. The items you add to a tool palette are 

called tools. You can create a tool by dragging an object onto the tool palette. In GstarCAD, blocks and 

external references (xrefs) can be dragged onto the tool palette. The new tool inserted will has the same 

properties into your drawing. Also you can create, delete, rename and customize panels by doing right 

click on it. To open the tool palettes just press CTRL+3 or Type TOOLPALETTES command. 

 

 

 

2.5. Design Center 

With Design Center, you can organize access to drawings, blocks, text styles and other drawing contents: 

-Browse for drawing content on your computer or a networked drive.                                                   

-View definition tables for named objects and then insert, attach, copy and paste the definitions into the current drawing.                                                               

-Create shortcuts to drawings and folders that you access frequently.                                                    

-Add content such as xrefs, blocks to a drawing.                                                        

-Drag drawings, blocks to a tool palette for convenient access 

Folders Tab: The following icons are displayed in this tab: networks and computers, computer drives, folders, drawings and 

related support files, Xrefs, layouts and named objects, including blocks, layers, linetypes, text styles and dimension styles 

within a drawing. 

Open Drawings: A list of currently opened 

drawings is displayed. If you click a drawing 

file and then click one of the definition tables, 

you can load the content into the content area.                                                    

History: A list of previously opened files is 

displayed. If you double-click a drawing file 

from the list, you can load the content into the 

content area. 

Favorites: If you have contents need to access quickly on a regular basis, the Design Center provides a solution to finding those. 

When you select any type of content, you can right-click and choose to add it to Favorites. In favorite folder you can save 

shortcuts to content on local drives, a network drives. The original file or folder doesn't move; but all shortcuts you create are 

stored in the Favorites folder. 
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2.6. Clean Screen 

Now, if users want to maximize drawing space, they can press the keywords Ctrl+0 or select the icon (Clean Screen) located in 

the right corner of the status bar. After executing this command, Toolbars and dockable windows (excluding the main menu bar, 

command line and status bar) will automatically be cleaned. This function can provides better visibility as large as possible to 

make it easier to fully understand every details of the drawing 

 

 

 

 

 

 

 

 

 

 

 

 

 

2.7. Lock UI 

Lock UI locks the position and size of toolbars and dockable windows such as Design Center, Properties palette, etc. To 

unlock them temporarily, hold down CTRL key. LockUI setting is stored as a bitcode using the sun of the following 

values: 

0 Toolbars and windows not locked 

1 Docked toolbars locked 

2 Docked or anchored windows locked 

4 Floating toolbars locked 

8 Floating windows locked 
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3. Create, Open, Save, Recover a Drawing and Manage Drawings 

3.1. Create a Drawing 

3.1.1. Create a New Drawing Using Default Settings 

When the system variables FILEDIA and STARTUP are set to 1, 

typing NEW at the command bar, it opens Startup dialog box, from 

which you can use Default Setting, Template or Wizard to create a 

new drawing.  

You can select either imperial or metric units for the new drawing. 

Imperial measurement system: The drawing uses internal default 

values with default boundary is 12 ×  9 inches. 

Metric measurement system: The drawing uses internal default 

values with default boundary is 429 ×  297 millimeters. 

 

3.1.2. Create a New Drawing Using a Setup Wizard  

From the Startup dialog box, you can select "Use a Wizard" tab to 

create a new drawing by the wizard. There are two wizard options 

illuminated as follows: 

Advanced Setup Wizard:  

From this option, you can set units of measurement, precision of displayed units, and grid limits. Also specify angle settings 

such as units of measurement style, precision, direction, and orientation based on template gcadiso.dwt. 
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Quick Setup Wizard: From this option, you can specify units of measurement, 

precision of displayed units, and grid limits based on template gcadiso.dwt.  

 

3.1.3. Create a New Drawing Using Template 

When you need to create several drawings with the default 

settings, you can save time by creating a template file 

designed to create the same drawing files so that you does 

not need to specify default settings each time you start. 

Conventions and settings commonly stored in template 

files include: unit type and precision, title blocks, borders, 

and logos, layer names, snap, grid, and ortho settings, grid 

limits, dimension styles, text styles and Linetypes.  

Also when the system variables FILEDIA and STARTUP are set to 1 and 0 separately, typing NEW opens Select Template dialog 

box, from which you can select the desired one or use the default template by clicking the arrowhead button next to the Open 

button. 

 

 3.2. Open a Drawing 

3.2.1. Open a Drawing 

You can open drawing (.dwg) files, Drawing 

Exchange Format (.dxf) files and drawing template 

(.dwt) files. You can also open and check drawings 

that you suspect are damaged.  

 

To open an existing drawing:  File > Open     

Command line> OPEN     Using shortcut> 

CTRL+O 

-In the dialog box, choose the type of file you want to 

open.                                               

-Choose the folder containing the desired file.                                                           

-Choose the drawing you want to open, and then 

click the Open button or Double click on the drawing 

you want to open. 
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3.2.2. Multiple Open Drawings 

You can open multiple drawings at one time. There are several methods for switching a drawing to another. 

- Acting the drawing by clicking it or using shortcut keys of <Ctrl+Tab>.                                                   

-You can change the display styles to Cascade, Title Vertically or Title Horizontally from the Window menu. You can also use 

Arrange Icons to align icons if there are several minimum drawings. 

 

  

  

 

 

 

 

3.3. Save a Drawing 

3.3.1. Save a Drawing 

You save drawing files for later use. You can also set up automatic saving and backup files and save only selected objects. In 

addition, you can also save a drawing in a Drawing Exchange Format (.dxf) file or a drawing template (.dwt) file. If you created 

your drawing using a template, saving the drawing does not alter the original template. 

To save a drawing:  File > Save     Command line> SAVE     Using shortcut> CTRL+S 

 

  

 

 

 

 

Remark: When you save a drawing the first time, the program displays the Save Drawing As dialog box so that you can choose a 

directory and type a name for the drawing. 
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3.3.2. Save Your Drawing Automatically 

You can specify to save drawing files automatically in order to minimize the lost 

data once a problem occurs. 

If you start the automatic save option, your drawing is saved at specified time 

intervals. By default, system assigned the name filename. sv$ for temporarily saved 

files, filename here refers to current drawing name.  

 

 

 

3.3.3. Save Part of a Drawing File 

You can use BLOCK command or WBLOCK command to create a new drawing from 

part of an existing drawing. You can select entities or a block definition in your 

current drawing and save them in a new drawing file. The description also can be 

saved in the new drawing.  

 

 

 

 3.3.4. Save to a Different Type of Drawing File 

Choose the format from Save as Type in the Save 

Drawing As dialog box, you can save a drawing to 

an earlier version of the drawing format (DWG) or 

drawing interchange format (DXF), or save a 

drawing as a template file. 

To save a different format:   

File > Save As    Command line> SAVE AS     

Using shortcut> SHIFT+CTRL+S 

3.3.5. Use Backup Files 

GstarCAD creates a backup file with the current drawing name and a ".bak" extension to save the previous version of the current 

drawing when launching "backup automatically" option. 
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3.3.6. Reduce the Time Required to Save a Drawing File  

In order to reduce the time of saving a drawing file, you can specify the 

incremental save percentage on the Open and Save tab of Options dialog 

box or from the ISAVEPERCENT system variable.  

The incremental save updates only the portions of the saved drawing file 

you changed. Drawing files will contain a percentage of potentially wasted 

space when you use incremental saves. This percentage increases after 

each incremental save until it reaches the specified maximum value, and 

then a full save is perform. 

3.4. Recover a Drawing 

3.4.1. Recover a Damaged File  

You can recover some or all of data by reverting to a backup file or using commands 

to find and correct errors if a drawing file is damaged. A drawing file may be damaged 

by a hardware failure, power outage and system crash. You had better create a backup 

file if the drawing is important.  

On the Open and Save tab of Options dialog box, you can specify the backup file are 

created when you save drawings and set the proper interval time for saving. Then a 

backup copy file with a ".bak" extension is created when you save the named drawing 

once again. After that, a backup file is always updated while you executing the 

command SAVE or SAVEAS. 

 

You can use RECOVER command to check and attempt to open a damage file.           

Then uses AUDIT command to find and correct errors. 

To open a damaged file:  File > Drawing Utilities> Recover     

Command line> RECOVER 

 

   

-In the dialog box at Files of Type, choose the type of file you want to 

recover.                                                        

-Choose the directory containing the damaged file.                                                     

-Choose the damaged file you want to recover and Click the Open 

button or Double click on the drawing you want to open. 
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To check errors for a drawing file:  File > Drawing Utilities> Audit     Command line> Audit 

  

1. To choose from the opened drawing, click on File > Drawing Utilities > Audit 

2. Input Y or N to determine whether to recover the errors that are automatically found by GstarCAD, and then press Enter. 

 

3.4.2. Drawing Recovery Manager 

Once terminated by hardware problems, power failure or software problems, the application is capable of backup the opened 

drawing file. At the next startup, the program starts "Drawing Recovery Manager" in which all of the auto-backup drawing files 

that have been closed accidentally will be displayed. You can open the file of your demand by double clicking at the Backup 

File list on the "Drawing Recovery", if there is any damage to the file, system attempts to recover the drawing in process of 

backup. 

When program or system stopped by accident, the drawing files need to recover are sorted into the following types. 

-Recovered drawing file saved when program fails (DWG)                                                  

-Temporary saved file (sv$)                                                                                    

-Backup file (BAK)                                                                           

-Source drawing file (DWG)  
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3.5. Manage Drawings 

In GstarCAD the Sheet Set Manager allows you to manage the entire project 

drawing sheetsets. It can manage all the work flow from sheets creation, 

printing and publishing.etc.  

 

In Sheet Set Manager, a sheet set is an organized collection of sheets from 

several drawing files and each sheet in a sheet set is a layout in a drawing 

file. 

Begin taking advantage of sheet set functionality for your current projects with 

minimal effort by importing your current drawing layouts into a sheet set. You can easily open drawings from a central location 

while you continue edit them using traditional tools.  

 

 

3.5.1. Sheet Set Control 

Lists menu options to create a new sheet set, open an existing 

sheet set, or switch between open sheet sets 

 

 

 

 

 

  

 

Details or Preview: Displays either descriptive information or a 

thumbnail preview of the currently selected item in the tree 

view. 

  

 

 

 

 

 

 

 

 

 

 

 

Tree View: Displays the contents of the sheet list. 
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You can use the following actions in the tree view: 

¶ Right-click to access shortcut menus of the operations that are relevant to the 

currently selected item. 

 

 

 

¶ Double-click items to open them. This is a convenient method for opening drawing files from the Sheet List. You can also 

double-click items in the tree view to expand or collapse them. 

 

 

 

 

 

 

 

 

 

 

¶ Click one or more items to select them for operations such as opening, publishing, or transmitting. 

 

 

 

 

  

 

 

 

¶ Move the cursor over a single item to display descriptive information or a thumbnail preview of a selected sheet, view, or 

drawing file. 

 

 

 

 

 

 

 

 

¶ Drag items within the tree view to reorder them. 



Chapter 3_ Create, Open, Save, Recover a Drawing and Manage Drawings 

 

28 

 

3.5.2. Sheet Set Manager Basic Information  

Opening Sheet Set Manager  

Ribbon: View tab > Palettes > Sheet Set Manager or Type: sheetset  

  

 

 

 

 

 

 

 

 

Creating a Sheet Set  

Once the Sheet Set Manager isopen, select the pull down box at the 

top and then click on New Sheet Set. 

 

A new dialog box will pop up displaying the 4 steps in creating a Sheet 

Set.  

 

Begin 

Under Begin there are two options for creating a sheet set.  

Option one  

Is using òAn example sheet setó that allows the use of a standard 

template to create the sheet set.  

Option two  

Is using Existing drawings to start a new sheet set. We are going to 

select the Existing Drawings option.  

Sheet Set Details 

This is where basic information like sheet set name, description, and file location can be added.  
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Choose Layouts  

Existing layouts can be added to the 

sheet set by browsing for the proper file 

needed in the drawing set. Once the 

layouts are selected, click Next to 

confirm. 

 

 

 

 

Confirm  

The confirm tab will give a summary 

of the layouts to be added to the set. 

After selecting the Next button the new 

layout will be added to the sheet set.  

 

 

 

 

Import layouts to the Sheet Set Manager 

To add a new sheet from an existing drawing layout, right clickthe title of the sheet set 

and selectImport Layout as Sheet. A new pop up box will appear which allows you to 

browse for an existing drawing to add a layout. 

 

 

 

 

 

Tip: If the import box is not checked, the layout is already in the sheet set or the 

layout is unable to be imported into the set. 

 

 

 

 

Managing Sheet Set  

Moving and Removing Sheets from a set  

Once the sheets have been added to the Sheet Set Manger, they can be 

dragged and dropped to the order needed. To remove a sheet from the 

set, right click and select Remove Sheet. 
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Rename and Renumbering Sheets 

To rename and renumber a sheet or a  subset, right click on 

the sheet needed to be changed and select Rename & 

Renumber.  

 

A pop up box will show up that will allow the number, sheet title 

and layout name to be changed.  

 

Adding project information to a sheet set 

To add project information to the sheet set, like 

project name, project number, and project 

description, right click on the sheet set title and 

scroll down to the sheet set Properties. A new pop 

up box will display that allows the update of project 

information.  

Tips: Project information in the sheet set can be 

used in object such as fields 

 

 

 

 

Creating Subsets in Sheet Set Manager  

Creating subsets in Sheet Set Manager is a fast way to organize and find what is 

needed in a big drawing set. To create a subset, right click on the sheet set 

and then to New Subset. 

 

 

 

 

 

 

The Subset Properties box will pop up. 

Most of the properties are basic. 

Select OK.  

A new subset is added to the sheet set 

manager.  

Tip: To move a sheet to the new subset, 

simply click and drag to the desired 

subset. 

 

 

 

Publishing Sheet Sets 

Sheet Set Manager makes it simple to publish a full set or only select sheets of the construction documents. There are two 
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ways to plot: Publish directly to the plotter/file or use the Publish dialog box. 

 

Publish and Plot directly to the plotter/file 

Right click on the sheet set, scroll to Publish, 

and then Publish to Plotter. 

 

This method is used to plot and publish

 when the page setup is set per layout.

 The drawback to using this option is if

 someone plots one of the sheets using

 the plot command and saved the setup

 to the layout, the layout will not publis

h properly.Sheetset can also be package

d and shared through e-transmit. 

 

Publishing using Publish dialog box may not be as fast as Publishing directly to the plotter/file, but there is less 

of a chance the document will come out wrong.  

 

You are also able to use Page Setups saved in the

 drawing to particular sheets or the full set.  

To pull up the dialog box, right click the Sheet Set

 title, scroll to Publish, and then to Publish Dialog 

Box. The Publish Dialog Box will display.  

 

Now with page setups, Publish Dialog Box can chan

ge the way the document is published. Now we hav

e the options to publish to Plotter named in Page 

Setup, DWF, DWFx, and PDF. 

Selecting the Sheet Set Publish Options allows the 

options to change information like default output location 

and naming.  

 

 

 

 

        

Tip: One of the major options I change the most is type. 

Multi-sheet file will place the full set in one file and the 

Single-sheet file will place each sheet per file. 
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4. Control the Drawing Views 

4.1. Redraw and Regenerate a Drawing 

As you work on a drawing, visual elements may remain after the completion of a command. You can remove these elements by 

refreshing, or redrawing, the display. 

To redraw (refresh) the current window display:  View > Redraw     Command line> REDRAW 

To regenerate the current window:  View > Regen     Command line> REGEN 

 

 

 

 

 

 

 

Information about drawing entities is stored in a database as floating point values, ensuring a high level of precision. 

Sometimes a drawing must be recalculated, or regenerated, from the floating point database to convert those values to the 

appropriate screen coordinates. 

 

 

 

4.2. Magnify a View (Zoom) 

You can use ZOOM command to zoom in or zoom out the 

drawing view to meet your need. You can change the 

magnification of your drawing at any time. The cursor 

changes to a magnifying glass when a zoom tool is active. 

Zoom out to reduce the magnification so you can see more 

of the drawing, or zoom in to increase the magnification so 

you can see a portion of the drawing in greater detail. 

Remark: If you are working in a layout viewport and cannot zoom, the layout viewport may be locked. The scale and view do not 

change in model space while panning or zooming in a locked layout viewport. 
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4.2.1. Zooming Methods 

To zoom, you can use any of the following methods: 

-To define the portion of the drawing to zoom, create a window.                                                          

-To zoom in real time, use the Zoom Realtime tool on the Standard toolbar.                                                 

-If you have a mouse with a wheel, rotate the wheel to zoom in and out. 

4.2.2. Zoom to Magnify a Specified Rectangular Area 

You can specify a rectangular area defined by two corners to display the objects within that area as large as possibly.        

The lower-left corner of the specified area becomes the lower-left corner of the new view. 

To zoom in to an area using a window:  View > Zoom> Window     Command line> ZOOM 

-Choose View > Zoom > Window                                                                

-Select one corner of the window around the area you want to magnify.                                                   

-Specify the opposite corner of the window around the area you want to magnify. 

 

 

 

  

 

 

 

 

4.2.3. Zoom in Real Time 

Realtime option zooms dynamically by moving your pointing device up or 

down. By right-clicking, you can display a shortcut menu with additional 

viewing options. 

To zoom in real time:  View > Zoom>Realtime             

Command line> RTZOOM  

-Choose View > Zoom > Realtime from the main menu.                                                               

-Hold the left mouse button, then drag the cursor forward to zoom in and move back to zoom out.                                              
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4.2.4. Displaying the Previous View of a Drawing 

After you zoom in or pan to view a portion of your drawing in greater detail, you may want to zoom back out to see the entire 

drawing. On the View > Zoom menu, the Previous tool lets you restore the previous view. Selecting this tool repeatedly steps 

back through up to 25 successive zoomed or panned views. 

4.2.5. Zooming to a Specific Scale 

You can increase or decrease the magnification of your view by a precise scale factor measured relative to the overall size of 

the drawing or in relation to the current display. When you change the magnification factor, the portion of the drawing located at 

the center of the current viewport remains centered on the screen. 

To zoom to a specific scale relative to the current display:  View > Zoom>Scale        Command line> ZOOM 

-Choose View > Zoom > Scale from the main menu.                                                                      

-On the Zoom toolbar, click the Zoom Scale.                                                                         

-Type ZOOM in the command line, choose the Scale option, and then press Enter.                                        

-Type the scale factor, followed by an x (such as 2x).                                                           

-Press Enter. 

 

 

 

 

 

 

 

 

 

4.2.6. Displaying the Entire Drawing 

ZOOM Extents option, displays a view that includes all of the objects in the drawing as large as possible. The view can display 

the objects on layers that are turned off but do not include objects on frozen layers. 

ZOOM All option, displays all of objects within either the user-defined limits or the drawing extents, whichever view is larger. 

You can use the Zoom All tool on the zoom toolbar to display an entire drawing. The Zoom Extents tool on the zoom toolbar 

displays the drawing to its extents, making the image fill the display to the greatest possible magnification. 
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4.3. Pan and View 

You can move the drawing in any direction using the pan command. Panning shifts or slides the view of the drawing 

horizontally, vertically, or diagonally. The magnification of the drawing remains the same, as does its orientation in space.   

The only change is the portion of the drawing displayed. To pan, you can use any of the following methods: 

-For precise panning, specify two points defining the magnitude and direction of the pan. The first point indicates the starting 

point of the pan. The second point indicates the amount of pan displacement relative to the first point.                 

-To pan in real time, use the Pan Realtime tool on the Standard toolbar.                                           

-If you have a mouse with a wheel, press and hold the wheel, and then move the mouse. 

To pan in real time:  View > Pan> Realtime     Command line> PAN 

-Choose View > Zoom > Realtime from the main menu.                                                     

-Move the cursor in the direction you want to pan.                                                                  

-To stop panning, press Enter, ESC or choose Exit from the shortcut menu. 

To pan using a mouse with a wheel:  

-Press and hold the wheel, and then move the mouse in the direction you 

want to pan (The MBUTTONPAN system variable controls this feature.) 

 

4.4. Display Multiple Views on Model Space 

When you begin a new drawing, it is displayed in a single window. You can view the drawing in a second window, or you can 

divide one window into multiple windows. You can also open and display multiple drawings. 

4.4.1. Set Model Space Viewports 

The viewports created on the Model tab completely fill the drawing area and do not overlap. As you make changes in one 

viewport, the others are updated simultaneously. You can do the following operations at the model space viewport: 

-Set Snap, Grid, and UCS icon modes; Pan; Zoom; and restore named views.                                                 

-Save orientations of UCS with individual 

viewports.                                                    

-When executing a command, you can draw 

from one viewport to another.                                                

-Name a viewport arrangement in order to you 

can reuse it on the Model tab or insert it on a 

layout tab.                        

-When you work on 3D models, is helpful 

setting up different UCS in individual viewports. 
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4.4.2. Working with Multiple Views of a Single Drawing 

You can open and work with several views of the same drawing simultaneously. After you divide a single window into multiple 

windows, you can control each window separately. For example, you can zoom or pan in one window without affecting the 

display in any of the other windows. As you draw, any changes you make in one window are immediately visible in the others. 

And also you can switch from one window to another at any time. 

To create multiple views:  View > Viewports     Command line> VPORTS 

-Choose View > Viewports                                                                      

-In viewports menu, choose 1, 2, 3, or 4 viewports.                                                    

-Type h if you want the horizontal orientation, or type v if you want the vertical orientation. 

To join two views:  View > Viewports> Join     Command line> VPORTS 

-Choose View > Viewports > Join                                                                  

-Click anywhere inside the window you want to keep.                                                                     

-Click anywhere inside the adjacent window you want to join to the first window. 

To restore a named window configuration: 

  -Type -VPORTS system variable at the command line and press ENTER.                                                                                

-Then type Restore.                                                                                

-Then type the name of the window configuration you want to restore. 
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4.4.3. Working with Multiple Drawings 

With the multiple document interface, you can open and work on several drawings at one time, you can copy, cut, or paste an 

entity from one drawing to another. Each drawing appears in a drawing window, which has the following advantages: You can 

see two or more drawings side by side, and you can easily copy entities from one drawing to another. Under the Window menu, 

the following three methods that determine how drawings are arranged are provided for user's choice. 

 

-Cascade                                                                                      

-Tile Horizontally                                                                                            

-Tile Vertically 

 

 

 

 

 

 

 

 

4.4.4. View Manager 

With the view manager, you can create, set current, update 

layers, edit boundaries, and deletes named views, and switch 

quickly between each views, it is helpful to reduce many 

unnecessary view adjust operation.  

 

4.5. Specify a 3D View 

You can set a 3D view to facilitate verifying the 3D effects of the drawing, constructing and visualizing 3D models. You can 

specify a new viewpoint to create new objects or modify the existing objects.  

4.5.1. Set the Viewing Direction 

You view three dimensional drawings by setting the viewing direction. The 

viewing direction establishes the viewing position, When you view a drawing from 

the default viewpoint (0,0,1), you see a plan view of the drawing. You can change 

the viewing direction to look at the drawing from a different vantage point or to 

work on a three dimensional model from a different orientation. 



Chapter 4_ Control the Drawing Views 

38 

 

To set a new viewing direction:                                                                 

View > 3D Views> Viewpoint Presets    Command line> DDVPOINT  

-Choose View > 3D Views > Viewpoint Presets                                                                   

-Set viewing angles at absolute to WCS and relative to UCS by moving the position of the                            

needle according to your preference. Then click OK button. 

 

To display a plan view of the current drawing: View > 3D Views> Plan View     Command line> PLAN 

-Choose View > 3D Views > Plan View from the main menu.                                                        

-It concludes three plan views: Current UCS, World UCS and Named UCS. Choose one what you want. 
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4.5.2. Isometric View 

You can define perspective views of a 

model to create realistic effects. Select 

predefined standard orthographic and 

isometric views by name or description. 

These views represent commonly used 

options: Top, Bottom, Front, Left, Right, 

and Back. In addition, you can set views 

from isometric options: SW (southwest) 

Isometric, SE (southeast) Isometric, NE 

(northeast) Isometric, and NW (northwest) 

Isometric. 

 

4.5.3. Draw 2D Isometric Views 

With Isometric Snap, you can create 2D objects that appear to be 3D solids.  

By setting Isometric Snap on the Draft Settings dialog box and turning on Snap and Grid, you can easily align objects along one 

of three isometric planes. However, although the isometric drawing looks like 3D, it is actually a 2D representation.  
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4.5.4. Set Isometric Grid and Snap 

By aligning along three major axes, isometric drawing simulates a 3D drawing from specified viewpoint. When the snap angle 

is set to 0, the axes of the isometric plane are 30 degrees, 90 degrees and 150 degrees. With Isometric Snap on, you can work 

on any of three isometric planes, each with a pair of associated axes. 

-Left. The left isometric plane defined by a pair of 90- and 150-degrees axes. The snap and grips align along the 90- and 

150-degree axes.                                                                                    

-Top. The top isometric plane defined by a pair of 30- and 150-degrees axes. The snap and grips align along the 30- and 

150-degrees axes.                                                                                  

-Right. The right isometric plane defined by a pair of 90- and 30-degrees axes. The snap and grips align along the 90- and 

30-degrees axes. 

 

 

 

  

 

 

 

 

In addition to using ISOPLANE command to switch isometric planes, you can also use shortcut key F5 or CTRL+E. specifying 

one of the three isometric planes results in Ortho and crosshairs to be aligned along the corresponding isometric axes. 

For example, when Ortho is on, the points you specified align along the simulated plane you are working on. Therefore, you can 

draw the top plane first, and switch to the left plane to draw another side, and then switch to the right plane to complete the 

drawing. 

 

 

 

 

 

 

 

Top plane           Left plane         Right plane 
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4.5.5. Change a 3D View Dynamically 

You can view objects from any viewing direction by holding down mouse or other pointing devices and moving dynamically. 

With dynamic viewing, you can display the effects of changing viewpoint while you change the view. You can execute move or 

zoom operations as the 3D Orbit is active. When the 3D Orbit is active, you are not allowed to modify objects. GstarCAD 

supports more orbit options like Free Orbit, 3D Continuous Orbit, Orbit along the X-axis, Orbit along the Y-axis, Orbit along 

Z-orbit and 3D Orbit Center. Additionally users can create two new meshes through DISH and DOME commands. To close 3D 

Orbit, press Enter, ESC or choose Exit from the shortcut menu. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4.5.6. Hide Lines or Shade 3D Objects 

Hides or shapes for 3D objects in the current drawing, suppresses the display of the objects (partly or entirely) that are located 

behind other objects, or generates a simply shaded image displayed in the current view. You can use HIDE command to 

remove the hidden lines to verify the current placement of these surfaces. Hiding background lines makes the display much 

clearer, but you cannot modify hidden-line or render views. 

  

  

  

  

 

 

 




















































































































































































































































