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Express Tools

The GstarCAD Express Tools contain a library of productivity tools designed to help you extend the power of your design. They
are easy to use, easily integrated into your menus and toolbars, and cover a wide range of functions, including dimensioning,
drawing, and selecting and modifying objects. GstarCAD Express Tools are organized on:

Block Tools

DOUBLE BED

Replace Block with Another Block: In the current drawing, you can use one —
block to replace another one, moreover, you can purge the unreferenced
block when the operation is finished.

Menu: Expresstools>Blocks>ReplaceBlock
Command Entry: BLOCKREPLACE

Select a block to replace. Double bed. Then select: OK Select a block to eplace
Select the block to be replaced: Sofa. Then select; OK .

Purge unreferenced items when finished? Yes/No

¥ BLOCKREPLACE

Double bed 1

oK [ cancel

Select the block to be replacedD ouble bed

Double bed 1

See the result below:
DOUBLE BED

SOFA

o S

Copy Nested Objects: Copy objects in a xref or a block.

Menu: Express>Blocks>Copy Nested Objects
Command Entry: NCOPY

Command line prompts as follows:
Select nested objects to copy. Use an object selection method

Base point: Specify a point, or enter M for multiple copies
Specify second point or <use first point as displacement>: Specify a point



Explode Attribute to Text: Explode blocks, converting value of attributes to text objects.

Menu: Express>Blocks >Explode Attributes to Text
Command Entry: BURST

Command line prompts as follows: Select entities: Use an object selection method

For example: Explode attributes and convert them to text objects.

1. Select a block containing two attributes. 2. Block exploded and attribute values converted to text.
\\ J Enter number { J Enter number =
1238668944 1 —=TAuptaty — 1238668944 L

L L L L

Export Attribute Information: Export block attribute to an external file in tab-delimited ASCII format.

Menu: Express>Blocks>Export Attribute Information
Command Entry: ATTOUT

Once performed ATTOUT command, specify file name and save path in "Enter output filename" dialog box, then command line
prompts: Select entities: Specify the blocks whose attributes you want to export.

The block names and attributes are exported to the —
named file. If the file already exists, you are L Enter number

prompted before it is overwritten. You can easily [~ | 1A2980eRe
view attributes in a spreadsheet format and edit

individual attribute values. Then you can enter the ]
new values into the drawing file, using the ATTIN ] L
command. A;

Import Attribute Information: Import block attribute to an external file in tab-delimited ASCII format.

Menu: Express>Blocks>Import Attribute Information
Command Entry: ATTIN

Using ATTIN and ATTOUT together, you can quickly make changes to attribute values for selected block references.



Once this command is performed,
the "Enter input filename" dialog

. Enter number
will pop up for the user to search I
o . 1238668944
file, import the block attributes
along with the same handle and

block name into the drawing, and
make changes to the block

attributes as well. T
T —

Once an attribute value is modified,
it will be integrated into the specified block. It should be noticed that the imported file can't be attribute file exported by
ATTOUT command, whereas the file format should be identical to that of ATTOUT command exporting.

Reads through imported file and processes each line when performing ATTIN command. If the block with the same handle and
name is found in the process of treating lines, the modified attribute value of this block will be applied. If several blocks with
the same handle and name are found, then system prompts whether to interactively assign saving data when processing these
blocks. If "Yes" is selected, the data of each command line will be listed enabling selection of a block to apply this attribute.
Press ENTER to skip to next line, press ESC to exit.

Statistics Blocks Number: You can statistics the quantity of various blocks through this function.

Menu: Express>Blocks> Statistics Blocks Number
Command Entry: TINUM

Stat. Condition:
Block Name iTV ‘ ]
5|

[ Layer [ ‘

e

Once this command is performed, its dialog box will = =
pop up. Under Stat. Condition, you can input a block ®
name, layer or check the options: Ignore the blocks in [
the same insert point and also ignore the scale.

Ignore the blocks in the same
insert point.

Ignore scale<= \11‘ Blocks

o o

Count Blocks: This function is used to count the number of the blocks by list.

Menu: Express>Blocks>Count Blocks
Command Entry: BCOUNT

Operation steps:
1. Start the command, the command line
prompts “Enter to select all blocks or ...". b .
2. You can press enter to select all the ”.;'
blocks within the drawing or by selecting Iﬁb "
blocks.

3. Once pressing “Enter” the system will display the result in the command line.




Change Block Color: Modify the block color quickly.

Menu: Express>Blocks>Change Block Color
Command Entry: bChgCol @

Operation steps:
1. Start the command.
2. Input new color number, here we input 30 for example.

3. Select block objects, for which the color needs to be changed. ‘ ——

4. Finished modifying.

Change Block Linewidth: This function can modify block linewidth quickly.

Menu: Express>Blocks>Change Block Linewidth
Command Entry: bChgWid

Operation steps:

1. Start the command.

2. Input a new line width value.

3. Select block objects, for which the line widths need to be changed.
4. Finish changing the line width.

Change Block Text Angle: This function can change the text rotation angle of the block and it only takes effect on text or mtext,

attribute text can’t be changed.

Menu: Express>Blocks>Change Block Text Angle
Command Entry: bChgAng

/‘(J
Operation steps: ()6

PV

1. Start the command.
2. Input new text angle(comparative with @) <0>. input 0.

3. Select the block to change text angle: then Select objects: G S ‘t A1 [: A D

4. Finish changing the text angle.

Change Block Text High: This function can change the height of the block, it only takes effect on text or mtext, attribute text

can’t be changed.

Menu: Express>Blocks>Change Block Text High
Command Entry: bChgHei

GstorCAD

Operation steps:
1. Start the command.

2. Input a new text height value.
3. Select objects whose text heights need to be changed. G S t Q |/\ [: A D

4. Enter to finish the command.




Change Block Layer: This function can change the block layer.

Menu: Express>Blocks> Change Block Layer
Command Entry: bChgLay

Operation steps: 4,/

1. Start the command.
2. Input target layer name.

3. Select block objects to change layer.

4. Press Enter. If the target layer exists, the selected

block will be moved to the target layer, if a target does \4
not exist, the software will make a new layer \
automatically and move the block object to the new layer.

Convert BLOCK to XREF: Replace all instances of a standard block with an xref. Unbind xrefs that are bound.

Menu: Express>Blocks>Convert Block to Xref
Command Entry: BLOCKTOXREF

Sclect o block o reploce

-BLOCKTOXREF searches the entire drawing for references to a EON By e
specified block name and replaces them with an xref that you specify.
You can have the unreferenced block purged when done. In
BLOCKTOXREF dialog box. Select a block to replace: Table and 4 I
chairs. Then select OK button.

-In Select a Xref file. Select the Xref you want. Then
select Open button.
Purge unreferenced items when finished? Yes/No

List Xref/Block Properties: List the type, block name, layer name, color and linetype of a nested object in a block or an xref.

Menu: Express>Blocks> List Xref/Block Properties
Command Entry: XLIST

Command line prompts as follow: Select nested xref or block object fo list: Use an
object selection method. After selecting an external reference, the "Xref/Block object"
dialog box will display attributes of specified blocks and xref, including object type,
block name, color and linetype.




Trim to Nested Objects: Trims objects with a block as a cutting boundary.

Menu: Express>Blocks>Trim to Nested Objects
Command Entry: BTRIM

Command line prompts as follow: j

-Select objects or <select all>. Select one or

more blocks and press ENTER. r'ﬁ )
-Select the object to Trim or Shift-select to : o). . i
Extend or [Edge/Fence/Crossing/Project]: ﬁ#,

.....
.....

Select object(s) or enter an option and press
ENTER.

Extend to Nested Objects: Extends objects such as line segment, arc, polyline or ray to a block. Objects would be extended to a
block as close as possible if they cannot intersect with each other.

Menu: Express>Blocks>Extend to Nested Objects
Command Entry: BEXTEND

Command line prompts as follow:

-Select objects or <select all>. Select one or
more blocks and press ENTER.

-Select the object to Extend or Shift-select to
Trim or [Edge/Fence/Crossing/Project]: Select
object(s) or enter an option and press ENTER.

v

External Reference Relocate: With this function, our software can recognize the reference in the drawing and give you the
reference state, if you want to select another reference path, click the “Relocate” button and the reference will be displayed in
the drawing again.

Menu: Express>Blocks>External Reference Relocate

Command Entry: CHGXREFPATHa Feferehce name;)

Path state
C:\Documents and Settings\Administrat...  Located

Operation steps:

1. Start the command and a dialog box will pop up.

2. Select the external reference name which you want to modify.

3. If you click the “Relative Path” button, you will get a relative path
of the reference; If you click “Relocate” button, the system will
relocate the external reference.

[FlelalivePath [ Relocate ] [ Exit J




Block Break: Working with block references that represent symbols are essential in some industrial application drawings like

electrical schematics, piping, etc.
But a headache comes when try to place these blocks accurately overlapping or even breaking other objects on your drawing.
Now get rid of this headache with BLOCKBREAK command. This innovative tool is able to wipeout or breaks an object that is

overlapped by a reference block.
For example, insome cases we may need to insert block symbols into a cable line in electrical schematic. And normally the

cable line is required to be broken by the symbols at where the symbols are inserted. Similar request are also exists in other

application designs.

Menu: Express tools>Blocks>Block Break ~ Command Entry; BLOCKBREAK

Block break dialog box: Nare, [0 [Bowse. ] [ Pex
Name: List all available blocks created in the drawing. s Fotston

Browse: Browse to open specific drawing file. o o i Hanes
Pick: You can pick an existing block reference in the current drawing. - AR

Scale: Scales the block reference size according to X, Y and Z coordinates. (9] Unfom Scale L Baok
Uniform Scale option keeps the original size of block reference. ] ] s
Rotation: You can rotate a block reference by inputting an angle value or

keep aligned.

Process Mode. You can use a block reference to break or wipeout objects when overlapping.

Block Break Process Mode Illustration

Break: Breaks background object(s) when a block reference is overlapped.
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Wipeout: Wipeout background object(s) when a block reference is overlapped.
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Text Tools

Text Match: TextMatch is a specific tool to match both text and Miext attributes in the current drawing, avoiding select and edit
text attributes one by one.

Menu; Text > Text Match ~ Command Entry: Textmatch

Text Match Settings ]
g g

After started the command, a message will display in the command line > Select the sample @lcontent [y

lext, Settings (S). It we enter the keyword S (settings) the follow Text Match Settings window | colr Pltarer

Height Width factor
will be display. From this settings window, we can see the text matching options such as: Text 7] angee [Tlstyie
content, Color, Height, Angle, Align, Layer, Width factor and Style. And also you can select

more than one option according to your need.

Content: Match only text or Mtext content from the sample text to the destination object(s).

Color: Match only color from the sample text or Mtext to the destination object(s).

Height: Match only text or Mtext height from the sample text to the destination object(s).

Angle: Match only text or Mtext angle from the sample text to the destination object(s).

Align: Match only Mtext alignment attribute from the sample text to the destination object(s).

Layer: Match only the text or Mtext layer to which the sample text belongs to the destination object(s).
Width factor: Match only the text width factor text frame from the sample text to the destination object(s).
Style: Match only text or Mtext style from the sample text to the destination objects(s).

Change Text: When there are several texts in the drawing which need to be modified, it would be much more tedious and
inefficient if modify one by one. Change text allows users make bulk modification to several texts. For example, this function
can modify the alignment, height, width, position, rotation, style and content of several texts simultaneously. It greatly improves
the efficiency of single text and Mtext modifications.

Menu: Text > Change Text ~ Command Entry: Changetext

For example, in a table or part list created, we can apply change text. After started the command, a message will display in the
command line: Please select object: Then select the text to be modified, immediately a prompt message will display>Height
(H) / Justity (J) / Location (L) / Rotation (R) / Style (S) / Text (T) / Undo (U) / Width (W):

Height: Changes the text height. Within this option PART LIST PART LIST
there are three more. Single (1) / List (L) / New height SMALL BUSHmeS | 3 SMALL BUSHINGS 3
. SHAFT 1 SHAFT ' |

fOf a// Ob/QC[S- SUB - BASE PLATE 1 SUB - BASE PLATE 1
MULTI-HOLE BASE PLATE 1 MULTI-HOLE BASE PLATE 1

Single: This changes the text height one by one. it L THREAFDSNT L

. ) ) ] . BUSHING "8' 27 BUSHING "B" 727

List: This shows the text information such as: Min. and prom—— [ pr——— 1
Max. text height and average. BUSHING "A [ 1 BUSHING "A" 1
New Height for all objects: This changes the height of — : e
all the selected text at once. b 1
ﬁ i Text (T)/Undo (0)/¥idth(¥) : H =

11



Justify: Changes the text justification. Within this option there are several more: Align (4) / Fit (F) / Center (C) / Left (L) /
Middle (M) / Right (R) / TL / TC / ML/ MC / MR / BL / BC / BR:

Align: This aligns text according to a
specific point.

Fit: Adjust the length of a single text
by specifying two points.

Center: Justify the context at center of
the frame area text.

Left: Justify the context at left of the
frame area text.

Right: Justify the context at right of the
frame area text.

TL: Justify the context at top left of the
frame area text.

TC: Justify the context at top center of
the frame area text.

ML: Justify the context at middle left
of the frame area text.

MR: Justify the context at middle right
of the frame area text.

BL: Justify the context at bottom left of
the frame area text.

BC: Justify the context at bottom
center of the frame area text.

BR: Justify the context at bottom right
of the frame area text.

Middle: Justify the context at middle MC: Justify the context at middle

of the frame area text. center of the frame area text.
PART LIST PART LIST
SMALL BUSHINGS 3 STEEL Welded ITEM 1-9 B GS 3 STEEL
SHAFT 1 Q235A 1 Q235A
SUB - BASE PLATE 1 STEEL 16mm. tickness 1 STEEL
MULTI-HOLE BASE PLATE 1 STEEL 16mm. thickness TE 1 STEEL
THREADED SHAFT 1 Q235A Welded ITEM 8 1 Q235A
BUSHING "B" 2 Q235A Welded ITEM 5 2 Q235A
SUPPORT PLATE 1 STEEL 10.5mm. thickness 1 STEEL
BUSHING "A" 1 Q235A Welded ITEM 5§ 1 Q235A
BMW - THREADED PIN "B" 1 Q235A M12x14x104 [ Bl THREADE B 1 Q235A
BMW - THREADED PIN "A" 1 Q235A M10x25x 100 BMW - THREADED PIN "A 1 Q235A
TILT PLATE 1 STEEL 15mm. tickness TILT PLATE 1 STEEL
DESCRIFTION Qry MATERIAL TREATMENT REMARKS DESCRIPTION Qry MATERIAL
PARTS LIST PARTS LIST
Location: Changes the text location by selecting and moving N i
- SHAFT LA Q2354 SHAFT =
the text frame base pom’[ SUB - BASE PLATE 1| sTEEL prempa—" SUB - BASE PLATE
: MULTI-HOLE BASE PLATE 1 STEEL 16 Ihiciness. MULTI-HOLE BASE PLATE
N . H H H H THREADED SHAFT 1 Q23574 Welded ITEM 8 ) THREADED SHAFT
Rotation: Changes the text rotation according with the input e == —
SUPPORT PLATE 1 STEEL 10,5mm. thickness SUPPORT PLATE
Val ue. BUSHING "A" 1| ozsa Viegsd TEU 5 BUSHING "A"
BMW - THREADED PiN *B" 1 Q2354 Mi2x1dx104 [T BMW - THREADED PIN "B"
. H H BMW - THREADED PIN "A" 1 Q2354 M10x25x 100 BMW - THREADED PIN *A"
Style: Changes the text style by typing the style name in the EE——— o) e
. [ ESERPTIR ———— | oty | waremia TReaTUENT REuARKS | L]
command line. PARTS LIST = |l
DDAVALS | NATE ‘ P~ - ~n s~ Plara in nther nnint

Text: Find and replace text. Within this option there are three
more: Single (1) / Re-enter (R) / Global (G):

Single: If you select one or more texts, this will match and
change any context within the text selected in sequence (one
by one).

Re-enter: This retype a new content by typing in the command
line and then replace it.

Global: If you select one or more text, this will match and change any
context within text group selected at once.

SMARTRT BUSHINGS
Bracger —~__
455555 . BASE PLATE
JAULTEHOLE BASE PLA
EHREADED SHAFTRS
BUSHING '8"

SUPPORT PLATE
BUSHING "A"
BMW - THREADED PIN "B"

-, TEXtor
= MTEXT
SELECTED

ONE BY ONE

/ smALL BUSHINGS, "
.

SPRING-341216-ASTM2532ANSI

SHAFTaag___ .
455555 - BASE PLATE ~~~~+

~..  TEXtor MTEXT
=, CONTEXT
-7 ¢

L
THREADED-89/65/123sTM/M10/  ONE BY ONE

IN SEQUENCE

BUSHING “8°

SUPPORT PLATE

BUSHING A"

BMW - THREADED PIN "B"

e

12MALL BUSHING12
S

Undo: Like CTRL+Z, this will undo operation after select any other. / :’:-::_}ﬁ?:wm"’"
Width: Changes the frame area text by entering a new width factor value. v 7 ) | e A
— SELECTED 4 1Z9FPORTFLATE

“BUIZHING A*

12



Text Align: As the name describes, this function is used to align text. You can select several texts in your drawing to align along

Xor'Y coordinates, or along a line of specific direction.

Menu; Text > Text Align ~ Command Entry: Textalign

For example, when we create a table or part list
and some contents are not in the correct location,

1 BMW-C-1 TILT PLATE 1 STEEL TREAT

PARTS LIST

using this tool improves the efficiency of adjusting || APPROVALS

APPROVALS
DATE DATE

text. After started the command, a message will ARP | Alonso Pizzali

display: Please select object: Then select the text(s)

™ BMW CHASSIS

to be aligned. After select the text(s), a message

ASSEMBL

SIZE [CAGECODE | DWG NO._
A2 BWMC

will display > Select the align method: X axis (X)
/Y axis (Y) / Two points (P):

SCALE I Is

In this case, we choose Y axis align method and then specify a point to align the texts in the correct location. The result as

follow:

INIT | BRPPROVALS DATE

BEPROVALS |BIATE

Please select object:1found

Please select object:1found, 2total

Please select object:1 found, 3total

Please select object:1found, 4+total

Please select object

ISelect the align method[X 2xisPQ/Y axis(Y)/ Two poirts(P]<X axis>:Y
(Specify aiign point

EXTALIGN -

- |Command: Speciy opposte comer

Another example, we choose
Xaxis alignment method and
then specify a point to align
the texts in the correct
location (end point of
Leader). The result as follow:

Small pool

Main pool

Tourist Hotel

Long Flume

Landscape sketch

Small pool

Y

And finally, If we choose Two points (P) alignment method for and then specify two points to align the texts in the correct

location (start and end point of Leader). The result as follow:

Tourist Hotel

tong Flume

Landscape sketch

Small pool

13



Texton Line:  Menu: Text > Text on Line

Operation steps:

1. Pick the "text on line" icon.

2. Click one certain point on the line as insert point of the character.
3. Input character, here, we input "GstarCAD".

4. Enter the height of the character, here, we enter "3".

5. Select input mode, here we can choose "Breakline" or "wipeout".

Breakline. It breaks the line automatically according to insert point and
length of the character. Wipeout: Generate one overlay area matched to the
length of the character, cover the line with it and put the character in the
insert point.

Arc-Aligned Text : You can use this function to create Arc-Aligned Text.

Menu: Text > Arc-Aligned Text
Command Entry: ARCTEXT

Operation steps: 2
1. Start the command.
2. Select an Arc or an Arc- Aligned Text, as shown below.

Command Entry: GC_textonline

Insert Point
rd

. GstarCAD

—GstarCAD——

Arc Aligned Text =

=l 3 X 2] F 7

Text

Propetties:

Text Height Offsetaic:
0425 0325

‘Widh Factor Offsetlett
1 0

Char Spacing Offsetight

0

Format

wlrfuf 5

v | | D8yLayer v

3. Input texts in “Arc-Aligned Text” dialog box and set the relevant properties.
4. Click the “OK” button to finish creating Arc-Aligned Text.

Text Mask: Place a mask object behind selected text or mtext. The rectangular mask is offset from the text by a specified value.

Menu: Text > Text Mask
Command Entry: TEXTMASK

Text Mask [TEXCIMESK

-Select text objects to mask or [Masktype/Offset]: Select an

Command line prompts as follows:

-Current settings: Offset factor = 0.500000, Mask type = Solid,
Mask color = 150

option or text or press ENTER to exit.

Text objects are grouped together with the mask objects so that they are moved, copied and erased together. To update the
mask after editing the text, run TEXTMASK again, and select the text item to be updated.

Masktype:

Mask type currently set to Solid

Specify entity type to use for mask [3dface/Solid] <Solid>: Specify a type to use for mask.

3DFACE option: Places a 3D Face behind the text. ~ SOLID option: Masks with a 2D solid in a specified color.
WIPEQUT option: Places the mask in front of the text. ~ Offset: Specify offset distance between shielded entity and text object.
Enter offset factor relative to text height <0.500000> Specify a value, or select points to set the mask size.

14



Unmask Text: Removes mask from text that has been masked with the TEXTMASK command

Menu: Text > Unmask Text Command Entry: TEXTUNMASK

Command line prompts as follow:

-Select text or MText object from which mask is to be removed. - TEX t M aSk
-Select object: Use an object selection method.

Make RText: We can use RText function to display the content of a text file or the calculation results of a DIESEL expression in
the drawing.

Menu: Text > Make RText Command Entry: RTEXT

Operatlon Steps "*}Fﬁw::td:tgiixztyle: Standard Text height: 30.000000 Text rotation: 0
1. Start the Command and Command ||ne prompts Enter an option [Style/Height/Rotation/File/Diesel] <Diesel>:
SNAP GRID ORTHD POLAR OTRACK  LHT

Options: Siyle: Select a text style.  Height: Specify a text height. Rotafion: Specify a rotation value.
File: Use an external text file.  Diesel: Use DIESEL code.

2. Capital letters “S”, “H" or “R” are used to set text style, text height, text

rotation; If you enter “F”, a dialog box will pop up and you can select a text SRS, P IO are
file(™.txt) as RText display object. While the content of text file is changing, the
RText is also changing automatically. If you select “Diesel” and a dialog box will
pop up, the calculation results of a DIESEL expression can be displayed in the

drawing.

3. Input Diesel expression, here for example we input $(getvar,

"dwgprefix")$(getvar, "dwgname") as shown below. The expression means to get —
current path. ¥

I ChDocuments and Settlhgs\AcnministrotaorsMy Documentslrawlingl.dwg

4. Select insertion point to insert RText object.
5. Finish creating RText object.

X

Change RText: Allows you to edit existing remote text (Rtext) objects in the drawing.

Menu: Text > Change RText
Command Entry: RTEDIT

?’Fmand: RIEDIT
s

Operation steps: { L
1. Start the command. AR

2. Select an Rtext object.

3. You can enter the option to be modified, system will prompt several options.
4. Input “S” can specify text style; Input “H” can input text height value directly;
Input “R” can specify text rotation angle; Input “E” will pop up a dialog box.

5. Finish modifying Diesel expression and click “OK”.

[ 0K I [ Cancel
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Text Fit: Stretches or shrinks text object(s) by selecting new start and/or end points.

Menu: Text > Text Fit s ™
Command Entry: TEXTFIT Te' Xf ﬁ/t po Xi' F/t

Command line prompts as follow:

prompts are displayed to specify new points.

-Select Text to stretch/shrink: A
-Specify end point or [Start poini]: Specify a new end point, or enter S to specify a new start point.
Note: The default uses the text's justification as the start point. If a new start point is specified, TeXt F/t

I
\*\ e 3
- .
N

Extended Text Editor: This function is a specific function of GstarCAD, you can input some particular texts, for example,
subscript text, single underline, double underline text and some special symbols and also you can set row spacing, alignment,
text height and other parameters, moreover it can input and output *.txt document. This function improves the CAD text editing
ability greatly.

Menu: Text > Extended Text Editor

Command Entry: MMTEXT prrrooeene
Teut style: ¥ | Row spacing coefficient 04 T Just [ Justleft v
) Wodheght>> |35 |3 0 |

Operation steps:

, , o
1. Start the command and a dialog box will pop up. j
2. Input corresponding texts in the dialog box. ¥
3. Click “OK” to finish creating texts. H

Concel

Enclose Text with Object: Place a circle, a slot, or a rectangle around each selected text or mtext object. The diameters of the
circles can be constant or fitted to each object. The width and height of the slots and rectangles can be constant or variable.

Menu: Text > Enclose Text with Object

Command Entry: TCIRCLE @

Usage Example:

-Circles: Constant radius( Fig 1).  -Circles: Variable radius( Fig 2). _ :
Fig 1 Fig 2

Automatic Text Numbering: Adds sequential numbering to text objects. The numbering can appear as a prefix, suffix or
replacement text. After selecting one or multiple texts, you can set the text sorting method, the starting number and increment
of text sorting and generated numbers placement mode.

Menu: Text > Automatic Text Numbering Command Entry: TCOUNT
16



Operation steps:

1. Start the command.

2. Select TEXT MTEXT or ATTDEF objects.

3. Sort selected objects by [X/Y/Select-order]

X: Places numbers by increasing the x-coordinate value of the selected text.

Y: Places numbers by decreasing the y-coordinate value of the selected text.

Select-order: Places numbers according to the order in which the text was selected. After specifying the method of order, the
following prompts will be displayed in the command line.

4. Specify starting number and increment (Start increment) <1,1> Enter the starting number and increment, separated by a
comma, or press ENTER. Note: Negative increments (decrements) are supported. Precede decrements with a minus sign.

5. Specify the placement of numbers in text [Overwrite/Prefix/Suffix/Find&replace..] < Prefix>:, Enter an option or press ENTER

Overwrite: Replaces selected text strings with numbers. Prefix: Adds the number as a prefix to text.
Suffix: Adds the number as a suffix to text. ~ Find&replace: Replaces a user specified text string with a number

Usage Example:

1. Starting number = 1, increment = 2. Starting number = 20, increment 3. Starting number = 2, increment =
1 added as prefix: = -10 added as suffix: 2, Qverwrite:

/] 2
Number one 1 Number one P /’ I"“. 4
Number two 2 Number two AN ,/" | 5
Number three 3Number three N |

OITJ'« 8
20rIr 01T 'x\.:wn' 10
200

Text Incremental Copy: This command can accomplish kinds of incremental methods for text.
Menu: Text > Text Incremental Copy ~ Command Entry: GC_dztext

The incrementation dialog box is displayed:

Distance: Specify incremental Distance, you can input value directly or single click the y e — |
button on the right to specify by the crosshair. [ Distance =
Amount: If do not specify Amount, the system will calculate the amount according to the ‘*‘mm: 1 s
initial points of the crosshair.

Incrementation: Specify the incrementation.

Select Incremental Object: 1f there are mixed letter cases and numbers in the text, user can specify different incremental
objects.

17



1. Open Text Incremental Copy.
2. Select the incremental objects.

Textincremental copy.dwg %

3. Set incremental methods, the completed incrementation

o PART LIST
gffect is displayed. 11 | BMW-W-1 SMALL BUSHINGS 3
il 10 |  BMW-U-1 SHAFT 1

Free Incremental: It is used when the Incremental Copy !’AM 1o B s ST !
) ) . eromerin A B BMW-Q-1 MULTI-HOLE BASE PLATE 1
location is relatively free, for example: number of spare parts 7 | Buw.o1 THREADED SHAFT 1
in the assembly drawing. e B it 2
4] BMW-K-1 SUPPORT PLATE 1

@ BMW-I-1 BUSHING "A" 1

1. Open ‘l’ext Incremental Copy B BMW-G-1 BMW - THREADED PIN "B" 1
. Y R BMW-E-1 BMW - THREADED PIN "A" 1

2. Do not select Distance or Amount, please set " e e — :
X ITEM NO ,DE':“}]RFE,% NO NOMENCLATURE OR DESCRIPTION Qty

incrementation as you need. Then select the text.
3. Specify incremental text location.

4 Model | Layoutd |

Distance only: Itis used if the distance of incremental text is fixed, for example: number column in the form.

1. Open Text Incremental Copy.

2. Select Distance and do not select Amount, please specify Incrementation and Distance as you need. You can input value
directly or single click the button on the right to specify by the crosshair. Then Select the text.

3. Specify incremental distance and direction. The system will automatically calculate the amount according to the initial points
of the crosshair.

Amount only: 1t is used when you know the incremental amount and do not know the incremental distance.

1. Open Text Incremental Copy.

2. Select Amount and don't select Distance, please specify the Incrementation and Amount as you need. Then select the text.
4. Specify the incremental distance and direction. The system will place the incremental text between initial points of the
crosshair as below:

Distance and Amount: You can fix the Amout and Distance first, and use the crosshair to specify the incremental direction.

Scale: This command can be used for single line text and multiline text, you can specify scale center and text height with this
command.

Menu: Text > Scale Command Entry: SCALETEXT A
Operation steps: — —

1. Start the command. 2. Select objects which need to scale. (Command Lie

3. Specify scale center. 4. Specify the text height and Press enter to finish scaling. 23?&@

ISelect object: 1found
ISelect object:

Select base point:

[Specify scale factor or [Copy/Reference] <2.00003:

18



Text Outline: Text Outline function will split more thoroughly, after processing, texts are no longer words, but lines. When
editing single line fonts, precision can be set to 1, set to higher numerical will make text warp, using truetype font from
operating system, you can increase accuracy appropriately. The higher the accuracy, the shorter segments you will get, so you
will get more segments.

Menu: Text > Text Outline

Command Entry: EXPLODETEXT TEXTOUTLINE" TEXTOUTLIEN
EXPLODE EXPiODM

Operation steps: - -

1. Start the command. Command:

2. Select objects to explode. E?ng"?°§m"§;gw out 1, total 3

3. Press enter to finish. The text will break up into outline. o=

Justify Text: Change a text object's justification without changing its position. Works with text, mtext, and attribute definition
objects.

Menu: Express > Text Tools > Justify Text
Command Entry: TJUST

Select objects: Use an object selection method.
[Start/Center/Middle/Right/TL/TC/TR/ML/MC/MR/BL/BC/BR] <Start>: Choose the new justification

Usage Example: Covert text to middle justified

-Text left justified. -Text after justification change.
TEXTOUTLINE  °© . TEXTOUTLINE
EXPLODE EXPLODE

Rotate Text: Aligns text, mtext and block attribute objects to new orientation. Rotates text, mtext, and attribute definition objects
s0 that they end up being as close as possible to horizontal or right-read (similar to the behavior of dimension text). Objects are
rotated about their middle point in 180-degree increments. For example, if the text is upside-down, it becomes right-side up
after a TORIENT operation. Similarly, left-read text becomes right-read text.

Menu: Express > Text Tools > Rotate Text
Command Entry: TORIENT

®
o« T e X Thig i5.text
) . . ’?*é'( . 2 2 o 5 ket This is 1eMia 15 text
-Select objects: Use an object selection method ¥ g,b&'-&im\e This is text  This is text

-New absolute rotation <0>:Enter a new absolute orientation angle ¥ = =i el et This s text

& 5‘9‘}:;’-’%??’:’ &
for all selected text. Usage Example: -Text before rotation (Fig 3) g @ 3 ff-“ Ty This is text  This is text
. . . & is ja. teblis i
-Text after rotation specified angle of 0 degrees (Fig 4) £ = % e iR
Fig 3 Fig 4
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Document Input: This function can input document (*.txt) to the drawing directly.

Menu: Text > Document Input Command Entry: WJSR
(@ e e e . ==

A VERSION - 0 i*@

Operation steps:

1. Start the command and a dialog box will pop up.
2. Select a TXT file.

3. Specify the insert point of the first line text.

4. Specify the height of text.

5. Specify line space. R — aa
6. Press enter to finish inputting. e ] [rmire. i

Name Date modust Type Sae
Deers SIS Mo Fie folder
BtendCmd S/29/213954 Mo Fiefoider

¥

29 5S4 Alo.. File folder
TooPaletes S/29/2013954 Alo...  Fie folder
UsesDataCache S/29/2013954 Mo Fie folder

[®fefumiv,

Convert Text to Mtext: Convert one or more normal text objects to Mtext.

Menu: Text > Convert Text to Mtext Command Entry: TXT2MTXT

Operation steps: I . T — iy
1. Start the command. N N T v
2. Select objects: Here we select two text objects and convert i -
. Select text objects, or [Options]<Options>:
them to Mtext object. et et oy dal 2 5
. . 1Text objects removed, 1 MText object added. -
3.1 Text objects removed, 1 MText object added. conmand: g~

Change Text Case: Changes the case of selected text, mtext, attributes and dimension text.
Menu: Text > Change Text Case Command Entry: TCASE

Command line prompts as follow:

-Select object: Use a selection method to select annotation

objects.

-Execute this command, start "TCASE - change text case" t case
dialog box, select an option.

Menu: Express > Text Tools > Change Text Style [ E S T Xt
Command Entry: CHGSTY I N e
Operation steps: fﬁ:iiﬂiﬁiiﬁimw-

1. Start the command. st e

2. Select the text to change text style and you can modify several objects at a
time. Then Press enter to finish the command.
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Chinese Characters Split: This function can split single line texts to single text one by one, because the English word is a
combination of several letters, this function only make sense for Chingse Characters.

Menu: Express > Text Tools > Chinese Characters Split Command Entry: HZCF

ext Text

Operation steps:
1. Start the command.
2. Select the text to be split.
Command: _HZCF
3. Press enter to finish splitting. e o Pt SR

[Command =D

Character Break:  Menu: Express > Text Tools > Character Break Command Entry: WZDD

Operation steps:
1. Start the command. 2. Select the text to break. 3. Specify the position for the break.

Change Character: This function can continuously revise multiple text objects, single line and Mtext are applicable.

Menu: Express > Text Tools > Change Character
Command Entry: DDEDIT

Texx S

Operation steps:

1. Start the command. -
2. Select the text to be replaced. Command._oDEDIT

[Select an annotation object or [Unde] -
3. Input characters to replace and press Enter to finish. jelectan annotaion object o Lndol

Change One Character: This function can change texts in selected single line texts, you can just input characters to be replaced
and characters to replace according to the prompts, Moreover it can be used in several single line texts at the same time.

Menu: Express > Text Tools > Change One Character ~ Command Entry: CHGTXT

Operation steps: T t
1. Start the command. eX

2. Select the text to be replaced. pommand Lo

Command: CHGTXT
['Select the text to be replaced

3. Input the characters to be replaced. ket st Sy et e o
4. Input characters to replace. bk chos o

[hanged 1 rows

5. Press enter to finish.

Change Text Height/Width/Angle/Position: This function is used to modify text height, text width, text angle and text position.
You can click or select characters by window selection.

Menu: Express > Text Tools > Change Text Height/Width/Angle/Position
Command Entry: TXTHEI / TXTWID / TXTANG / TXTPQOS
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Delete Annotation: This function is based on this kind of circumstance, you can select one text annotation to be deleted , the
software will register all the annotations in one layer, you can just press enter and all the text annotations will be deleted or you
can select the texts by window selection and it will not affect the texts of other layers.

Menu: Express > Text Tools > Delete Annotation  Command Entry: WZOFF

Operation steps:

1. Start the command.

2. Specify a text annotation to be deleted. At this time you only specify the operation layer, if you directly press enter, the entire
layer single texts will be deleted.

3. Select annotations to be deleted (you can select several objects by window selection) and press enter to finish.

Adjust Character: When the texts are mixed with Chinese characters, English letters and Arabic numerals, the text height will be
different and the visual effect is not good. You can use this function to match the text height, but this function will explode the
text's and it will be difficult to re-edit, so we suggest using this function after the user finished editing the drawing.

Menu: Express > Text Tools > Adjust Character Gsta rCAD
Command Entry: TTL2 -
Gst1arCAD

Model / Layoutl . Layout2

—
PliCommand: TTL2

Operation steps:
1. Start the command.

2. Select the text object which needs to adjust the height. * ;:;e:ft object o need repair the charater high :
3. Press enter to finish. Command :

|1465.2982, 5573208, 0
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Dimension Tools

Change Dimension Text: Change the dimension content into the specified value.

Menu: Express>Dimension>Change Dimension Text

Command Entry: CHGDIMTXT

Command line prompts as follows:
-Select dimension objects: Select a dimension

-Currently label content <129.9>, input new dimension text <practically

measure dimension>. Type a new value (130)

Change Dimstyle: Apply the current dimension style

to the dimensions in the drawing.

Menu: Express>Dimension>Change Dimstyle

Command Entry: Dimstyle

130

Reset Dim Text Value: Restore a measurement value to overridden or

modified dimension text.

Menu: Express>Dimension>Reset Dim Text Value

Command Entry: DIMREASSOC

Command line prompts as follows: Select object: Select dimension
objects with non-associative text or press ENTER to quit.

12422

Update Dimension: Updates any other dimension(s) to the current dimension style you want to apply.

Menu: Express>Dimension>Update Dimension

Command line prompts as follow:

Command Entry: DIMUPDATE

-Select a dimension for standard: Select a dimension as a base.

-Select a dimension, ensure update the dimension style: Select dimension(s) to be update.

Dimension to be
Updated

Standard

23



Dimstyle Export: Exports named dimension styles and their settings to an external file.

Menu: Express>Dimension>Dimstyle Export ~ Command Entry: DIMEX e ==
o
Executing this command, starts the following dialog box:

Available Dimension Styles
Export Filename: Creates a DIM file. Enter the DIM file name or select Browse to locate the mmm
file. If the file does not exist, it is created. If the file does exist, a prompt requests permission

to overwrite. The new file is an ASCI! file.

Test Style Options

Available Dimension Styles. Selects the dimension styles to write to the ASCII file. The current Sy

Eull Text Style Information

dimension styles are displayed. Each selected style is written to the file indicated in the
Export Filename group.

Text Style Options. Saves either the dimension's Full Text Style
Information or the Text Style Name Only to the ASCII file.

Note: Dimstyles are created and saved with the DDIM command. You
must select at least one Dimstyle for the export to be successful.

Dimstyle Import: Imports named dimension styles from a DIM file into the current drawing.

Menu: Express>Dimension>Dimstyle Import ~ Command Entry: DIMIM

Executing this command, starts the following dialog box:

Import Filename: Names the file you want
to import. Enter an existing file name or
select Browse to specify a DIM file to
import. The file must be of the form
generated by the corresponding DIMEX
command. All dimension styles in the
selected file are imported into the current
drawing. Text styles are also imported.

Import Options: Includes Keep the Existing Style, to keep the dimension style in the current drawing and Overwrite Existing
Style, to overwrite styles in the current drawing. The Keep the Existing Style option ignores the similarly named style being
imported; Overwrite Existing Style uses the similarly named style being imported.

jon: Attach | li M | lock ref
Attach Leader to Annotation: Attach leader line to Mtext, tolerance, or block reference Use the QLATTACH

object. command to attach
leaders to Mtext

Menu: Express>Dimension>Attach Leader to Annotation  Command
Entry: QLATTACH / /
-Select Leader: Select a leader
-Select a dimension: Select the Mtext, tolerance, or block reference object for the annotation.
24



Usage Example:

-Select a leader, and then specify the Mtext object to attach.
-Separate leader line and Mtext objects.

-Leader line with mtext attached as one object.

At the Select Leader: prompt, you will be prompted until you select a leader object or abort the command.
At the Select Annotation: prompt, you will be prompted until you select an MText, Tolerance, or Block Reference object for the
annotation.

Detach Leaders from Annotation: Detach leader ling from mtext, tolerance, or block reference object.

Menu: Express>Dimension>Detach Leaders from Annotation Command Entry: QLDETACHSET

-Select objects: Select leader line. WITHOUT Leader line

Leader line
Usage Example:
-Select a leader line to detach from an mtext object.

Global Attach Leader to Annotation: Globally attaches leaders line to mtext, tolerance, or block reference objects.
Menu: Express>Dimension>Global Attach Leader to Annotation  Gommand Entry: QLATTACHSET

-Select objects: Select one or multiple leader lines and annotation objects.

Usage Example:

-Select leader line(s), and miext objects to attach. MTEXT
-Select objects: Select one or multiple leader lines and annotation objects, /

the command line prompts: Number of unlocked leaders = 2, Number with

annotation detached = 2 _ _
~Leader with detached Mtext object (Fig 5) Fig 5 Fig 6
-Leader attached to block object (Fig 6)

Selection Tools

Get Selection Set: Create a temporary selection set of objects.

Menu: Express> Selection>Get Selection Set  Command Entry: GETSEL /m

-Select an object on the Source layer: Use a selection set method or press Selectior]

N 5] N =]
ENTER for all layers. Fgs 7 Fige -
-Select an object of the Type you want: Use a selection set method or press o E:;ﬂh . 2
ENTER for all object types. s

25



Select Filter: Select, edit, and name filters for object selection.

Menu: Express>Selection>Select Filter
Select Object Filter dialog box Options:

1.X, Y Z Parameters. Defines
additional filter parameters depending
on the object. In the filter parameters,
you can use relative operators such as
< (less than) or > (greater than).

2. Select: Displays a dialog box listing
all items of the specified type in the
drawing. Select the items to filter.

3. Add to List: Adds the current Select
Filter property to the filter list. Filter
properties that you add to the
unnamed filter remain available during
the current work session unless you
manually delete them.

4. Replace: Replaces the filter
property selected in the filter property
list with the one displayed in Select
Filter.

Command Entry: Filter

(= )

Edit tem Delete Clean list
= Named Fiters
-
,
5. Add Selected Object: Adds Sbunts
(o] ] L

one selected object in the

drawing to the filter list.
6. £dit ltem: Moves the selected filter
property into the Select Filter area for
editing. To edit a filter property, select
itand choose Edit Item. Edit the filter
property and choose Substitute. The
edited filter replaces the selected filter
property.

7. Delete: Deletes a selected filter
property from the current filter.

8. Clear List: Deletes all the listed
properties from the current filter.

9. The filter name is used: Displays,
saves, and deletes filters.
10. Current: Displays saved filters.

Get Selection by Block Name: You can use this function to multi-select objects

with the same name in specified area.

Menu: Express>Selection Tools> Get Selection by Block Name

Command Entry: GETBLKSEL

Operation steps:
1. Start the command.

2. Select object, specify a block name for operation.

3. Specify the region.

4. System will bring all the blocks with same name in region selected area into the

selection.

Get Selection by Object Type: You can use this function to multi-select objects

with the same entity type in specified area.

Menu: Express> Selection Tools>Get Selection by Object Type

Entry: GETENTSEL
Operation steps:
1. Start the command.

Command

Select a filter list to make it current.
The named filter and its list of
properties are loaded from the default
file, filter.nfl

11. Save As: Saves a filter and its list
of properties. The filter is saved in the
filter.nfl file. Names can contain up to
18 characters.

12. Delete Current Filter List: Deletes a
filter and all its properties from the
default filter file.

13. Apply: Exits the dialog box and
displays the Select Objects prompt,
where you create a selection set. The
current filter is used on the objects
you selec

fena)

Eommend GETBLXSEL
fSeect ctyect

14 Phemse seect Ertty Otject. | Enives hawe been slected
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2. Select object and system will take the specified entity type as target type. Then specify region.
3. System will bring all the blocks with same entity type in region selected area into the selection.

Get Selection by Layer: You can use this function to select all the objects in specified layer and specified region at one time.

Menu: Express>Selection Tools>Get Selection by Layer
Command Entry: GETLAYSEL

Operation steps:

1. Start the command.

2. Specify an entity which is in the target layer, then specify region.

3. System will select all the objects in specified layer and specified region

Get Selection by Color: Quick select the objects with the same color. Menu: Express>Selection Tools>Get Selection by Color
Command Entry: GETCOLSEL

Operation steps:

1. Start the command.

2. Select one object and system will take the object’s color as target color.

3. Specify region.

4. System will select the objects which have the same color as the target object automatically.

Get Selection by Object/Layer: Select entities by entity type and layer. Menu: Express > Selection Tools > Get Selection by
Object/Layer Command Entry: GETENTLAYSEL

Operation steps:

1. Start the command.

2. Select one object and system will take the object layer as target layer.

3. Specify region.

4, System will select the objects which are in the same layer and with same entity type automatically.

Get Selection by Object/Color: Select entities by entity type and color. Menu: Express > Selection Tools > Get Selection by
Object/Color  Command Entry: GETENTCOLSEL Operation steps:

1. Start the command.

2. Select one object and system will take the object’s color as target color.

3. Specify region.

4. System will select the objects which have the same entity type and color as the target object automatically.

Get Selection by Layer/Color: Select entities by color and layer. Menu: Express > Selection Tools>Get Selection by Layer/Color
Command Entry: GETLAYCOLSEL

Operation steps:

1. Start the command.

2. Specify an entity which is in the target layer.

3. Specify region.

4. System will select the objects which have the same color and same layer as the target object automatically.
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Modify Tools

Align Tool: Allows align selected objects such as: rectangle, circle, line, spline, arc, pline, block and even 3D model object
along X or Y axis coordinates. This tool has different alignment methods, includes offset option for each axis and can be
combined as well.

Menu: Express tools>Modify>Align Tool  Command Entry: Aligntool

There are several align tool options within align tool window. All the options
are design-intent to align objects X and Y axis as a reference.

@@@o;

Y Axis Align to

1.- Left object X axis Align. Aligns the the selected object(s) at central
9| ) Spedfied object _I

selected object(s) at left side X axis. side Y axis. a1

2.- Center object X axis Align. Aligns 7.- Bottom object Y axis Align: 11 @ sekctmbouniery | m

the selected object(s) at central side Aligns the selected object(s)

X axis. downwards Y axis.

3.- Right object X axis Align: Alignsthe 8.~ Y offset: Offset object(s) after selected object(s) to a specific point
selected object(s) at right side X axis. select any Y axis alignment option. of the second selected object, after
4.- X offsel Offset object(s) after 9.- Specified object: Aligns the select any X or Y axis alignment
select any X axis alignment option. selected object(s) to a specific object option.

5.- Top object Y axis Align: Aligns the or any end point of it, after select any 11.- Selection boundary: This option
selected object(s) upwards Y axis. Xor Y axis alignment option. is by default when you select any X or
6.- Center object Y axis Align: Aligns 10.- Specified point: Aligns the Y alignment option.

We can apply this tool to align a quantity
objects (columns) in the correct place. Also
notice that the objects are not aligned at same
position each other, and also these are
independent blocks. We will perform Top
object Y axis alignment and specified object.
After started the command Aligntool, a prompt
message will display > Please select the
object to align: Then select the objects in any
order you want:

After you have selected the objects, the Align tool
settings window will pop up: first we have to
check the option Top object under Y axis
alignment. After check this option the objects
(columns) will be aligned at same level:

After the objects have been aligned, we have to
select the option specified object under Align to.
Then select the object (blue line) where we want
to align and place the objects. Finally you will
get a faster result performing this operation:
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Arrange Tool: ArrangeTool can quickly adjust the arrangement of multiple objects. It can align multiple objects at left, right, top,
bottom and center and also can arrange vertical or laterally.

Menu: Express tools>Modify>Arrange Tool

Command Entry: ARRANGETOOL

For example, ArrangeTool makes the bearings evenly distributed in the shaft.
ArrangeTool supports real-time preview when user adjusts the parameters. In

addition it supports distribution specifies.

J Arrange Tool
2

6

Region

() Specify spacing E_'

") Specify region &l

©) Selection boundary

1.-Left horizontal arrangement:
Arranges selected objects horizontally,
taking leftmost object as arrangement
reference.

2.-Middle horizontal arrangement:
Arranges selected objects horizontally
in two ways (top or bottom left object).
3.-Nearest side horizontal arrangement:
Arranges selected objects horizontally
to the nearest side object taking top
left object as reference.

4 .-Right horizontal arrangement:
Arranges selected objects horizontally,
taking right edge of the leftmost

object as arrangement reference.
5.-Top vertical arrangement: Arranges
selected objects vertically, taking top

There are several arrange tool
options within arrange tool

selected.

object as arrangement reference.

6.-Middle vertical arrangement:
Arranges selected objects vertically,
taking middle of the top object as
arrangement reference.

7.-Nearest side vertical arrangement:
Arranges selected objects vertically to
the nearest side object taking top
object as reference.

8.-Right vertical arrangement:
Arranges selected objects vertically,
taking bottom edge of the top object
as arrangement reference.

9.-Specify spacing: Can be combined
with any horizontal and vertical
options. Also you can input a value for
column in horizontal objects

B1 B2 B3 |-
inesigass iERS %ML,
el e el /A
w5 X £5 E][B'

&

N
B1 B2 B3 E&
iSae S5 1{:‘),{*&@:& 7N

N

window. All the options are design-intent to arrange object’s position
horizontally or vertically. This tool can work at least with 2 or more objects

arrangement and raw for vertical
objects arrangement.

10.-Specify region: Can be combined
with any horizontal and vertical
options by specifying the start and
end points of the new region. Then,
the objects selected will be arranged
according to the new region.
11.-Selection boundary: After
selecting objects, the arrange tool
dialog box pop up, this option is
selected by default, so just you need
to select any horizontal or vertical
arrangement option. And the objects
selected will be arranged horizontally
or vertically and equidistant each
other according to the boundary.

Remarks: Under Specify spacing there are 2 titles: Raw and Column. Raw value only works if we combine it with any vertical

arrangement option. And Column value works with any horizontal arrangement option.

For example, we can apply this for
arrange the part numbers distribution
over the leader lines. Notice that the
objects to be selected are Mtext and
will be distributed according to the
top object level as a reference.

540
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After started the command, a prompt message will display > Please select the object to arrange:

Then select the part numbers. After select the part numbers, the arrange tool window will pop up, select the option: Specify
spacing and then check or select the option: Top vertical arrangement. See the result below:

240

J[Reseect J [0k ][ conl ]

Layout By Path: Unlike common array function, LayoutByPath distributes object copies along a path (curve) with a variety of
array options. Users can choose ra8ndom, division and measure options and array in different directions along the path.

Menu: Express tools>Modify > Layout by path Command Entry: Layouthbypath

For example, on mapping drawing, we can apply this
tool to array the discontinuous central axis of the road
or highway as shown in the picture:

IR )L
Lt

" [tavouTeveaTH

| LAYOUT

After started the command Layoutbypath, a message will Rivousveat

V LAYOUTREGENCTRL

display in the command line> Please select the object o e | oINS /
array: i

After select the object, a prompt message will display:

Please specify the base point:

The base point is the point where you want to start doing array from
the object. We can select the low left end point of this object:

ecify the base point:

After select base point of the object, a prompt message will display: /',{ L‘\ 5

Specify the object’s direction along the curve <Y axis of WCS>: - \ f S

This message is important because this will play with the object’s direction along /)w

the path. Because we select the end low point of the object as base point, we have  E=iieisis 8 p———

to specify a parallel point direction to keep the object parallel along the path (long e
green line):

|
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After specify the object’s direction, a prompt message will

display:

Please select the curve: //
Then select the long green line. This line is the curve or path

that the object will follow.

After select the curve or path, a prompt message will display:
Specify select along which side of the curve <Ieft side or forward
direction>: T
his message is also important because we will specify the side
which the object will be array. For example, we specify left
side of the curve as shown in the picture.

After specify the side of the curve, a prompt message will
display: Select the method Random (R) / Division (F) / Measure (D):

There are three options random, division and measure:

Random: This allows to array the selected object along the path in a specify point according to user’s need.
Division: This allows to array automatically the selected object along the path by inputting the number of objects.
Measure: This allows to array automatically the selected object along the path by inputting the distance value.

For example, if we do not know the distance between objects but we know the objects quantity, we can select the option
Division:
e s [T

After select the option, a prompt message will display:
Enter the number: And we enter the value 11

After enter the value, a prompt message will display:
Pick a point on the curve as start point (Distribute from the

end curve when selection is empty): ﬂ? —
Then pick one of the end points of the curve: [Pick a point on the curve as stat point(Distibute from the end of curve when selection is empty), (252 |[< 230" |
Aifter pick the point of

the curve, you will get
accurate result: And
also you can repeat
the same array option
for the other blue
central axis of the
road.
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Area Sum: When using traditional area command, users usually need to redraw the boundary of the region, or convert the
boundary into a single object, and then get the area of the closed region. AreaSum can automatically search the boundary of
complex graphic. After selecting multi close regions, the command line will add the current region value and area sum
sequence faster in real time.

Baseball Field
Area summatory

Menu: Express tools>Modify >Areasum
Command Entry: Areasum

[,
After started the command, you have to ¢ /
pick points in closed regions to be added

areasum T
283152536,43mm?2 = 283,15m2 [

ect (0)]:

according to your need. For example, pick
up the hatching regions of each object.
After pick point the hatched regions, the
command line will show up in real time
the region value sequence and area sum
in (mm2):

ect (0)]: Object

3ect (0)]:

ect (0)]:

oct ) 4[]

Move/Copy/Rotate: Move, copy, rotate, and scales object(s) with a single command.
Menu: Express tools >Modify >Move/Copy/Rotate Command Entry: MOCORO
Command line prompts as follow: Select objects: Select object(s) and press Enter (Fig 7).

Base point: Specify a base point (Fig 8)
[Move/Copy/Rotate/Scale/Base/Undo] <eXit>: Once an option is specified (Fig 9\Fig10)

Fig 7 Fig 8 Fig 9 Fig10

Options
Move: Move object(s). Copy: Make multiple copies of object(s). Rotate: Rotate object(s). Scale. Dynamically scale object(s).
Base: Specifies a base point for object(s) to be moved, copied, scaled or rotated.
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Region Scale: You can select a region of a drawing to be cut and copied to a new location.
Menu; Express tools>Modify>Region Scale  Command Entry; ICAD_DYJT

|
|
|
Command line prompts as follow: 14
Specify left up corner point for full-page proof: Select a region from left up to ‘ |
R

right down corner

O

D=' DETAIL

REMARKS

BOLTS, NUTS, WASHERS AND CIRCUPS
SHALL BE BORNE BY THE MANUFACTURER

Select the object to Trim or shift-select to Extend or [Edge/Fence/Crossing/Project]: , \ 2

Select objects to trim or press Enter to finish the operation.

Input zoom scaling, the block and text will zoom together <Enter- No Zoom>: Press Enter to finish the
operation.

Trim Enhancement: Trim one side of an object which is intersecting with other objects. The object can be polyline, line, circle,
arc, ellipse, image or text.

Menu: Express tools>Modify>Trim Enhancement  Command Entry: EXTRIM

Operation steps:

1. Start the command.

2. Select an object as trim reference, here we select the rectangle for example. (Fig 11)

3. Specify the side to trim on. (Fig 12)

4. Here we select the internal point of the rectangle, you will see that the internal lines of the rectangle are trimmed. (Fig 13)
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Fig 11 Fig 12 Fig13
Extended Offset: This enhanced version of the OFFSET command offers several advantages over the standard command,

including layer control, undo, and a multiple option.

Menu: Express tools>Modify >Extended Offset ~ Command Entry: EXOFFSET

1 Specify offset distance or [Through] <T=>: Specify the offset distance or through point
2 .Select object(s) to offset or [Options/Undo]: Select an object to offset, change options or undo
3 .Specify an option to set [Distance/Layer/Gaptype]: Specify an option

EXOFFSET Options:

Distance: Specify the offset distance or through point

Layer: Specify the layer for new objects. Current Layer or Source Object Layer

GapType: Sets or changes the offset mode as controlled by the OFFSETGAPTYPE variable. The options are: Normal, Fillet or
Chamfer.

/ / e / // //
Yy / // s
Normal / / Fillet/ / Cha f}/ A
Y i o 7 o
— T << (! L <
\\ s\ \
NN NN N\
N\ \\\ X N\
\\‘ N \\\ \\ ’ \\
- N N N
Distance Layer GapType

Multiple Pedit: This command is almost the same as the standard command.

Menu: Express tools>Modify>Multiple Pedit ~ Command Entry: MPEDIT

1 .Start the command.
2. Select object
3. Specify an option to set [Open/Close/Decurve/Fit/Linetype-mode/Spline/Width/eXit] <eXit>.

Example to close plines:
1 .Select object: select plines which you want to close.
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2 .[Open/Close/Decurve/Fit/Linetype-mode/Spline/Widih/eXit] <eXit>:Input keyword: C and enter.
3. You will get the plines closed.

e st |

Overkill: This function can not only manage overlapped lines, circles, Plines linear objects etc, but can also manage entire
coincident blocks, texts, dimensions and regions .Moreover, remove does not simply mean delete, it judges by layer, color, line
type and many relevant attributes and can delete or connect coincident parts of 2D and 3D Plines, circles, arcs and overlapping
line parts. Using this option can not only delete redundancy objects, but can also avoid editing and printing problems caused
by overlapped objects.

Menu: Express tools > Modify > Overkill Command Entry: OVERKILL

Start the command and the command line prompts as follow: Select objects: Select the objects to be compared and deleted.
In the overkill dialog box, you can set-up the object comparison, comparison precision (distance between objects) and the
object type. After selecting the options according to your need, select OK.

2

Overill
Object Comparison Setting
@)\I. EI 7| Ignore Layers Companision Preasion: 0.000001
[
[

| 1gnore LineType

7| lgnore Color
Igonore LineVieight
Ignore PlotStyle
[ | Object type(Lines Arcs and Pines) and overkil style
I | AN 7] Pines - Optimize segments within plines
Eij’ Ej e V| Overlap - Combine co-inear objects that partially overiap
7]nd to End - Combne codinear objects when algned end to end
oK [ concel
Block Block :
duplicated N duplicated i
millimetrically \® deleted | \@

Multiple Copy: Copy multiple objects with Repeat, Array, Divide and Measure options.
Menu: Express tools>Modify >Multiple Copy Command Entry: COPYM

Start the command and the command line prompts as follow: Select objects: Select the objects to be copied

Base point: Specify a base point

Second point or [Repeat (last)/Divide/Measure/Array (dynamic)/Undo] <exit>: Select a second point or any option

Options:

Repeat: Repeat the last copy using the same offset distance.

Divide: Linear divide option. Prompts for an additional point and the number of copies to make. Makes evenly spaced copies of
the selected objects between the base point and the second selected point
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Divide

Measure: Linear measure option. Prompts for an additional point and the distance between copies. Makes evenly spaced
copies at the specified distance between the base point and the second selected point.

Array: Displays the Array Options prompt.

Measure

Array

Statistics Summation: This function sums up selected text or mtext. The selected text can not contain any other characters
behind the number and the selected mtext can only contain a row of numerical values without blank spaces. Figures with prefix
can also make statistics Summation and the system will summate them by different prefixes.

Menu: Express tools>Modify> Statistics Summation

Start the command and the command line prompts as follow:

Select objects : Select Text or Mtext numerical value

In the Statistics dialog box, you can see the cumulative
sum from the selected text numerical values. You can
also re-select, replace, copy text numerical value again
plus fill-in (show) the cumulative sum in any point of
your current drawing.

O @
oL

office $ath?
[

Command Entry: KLLO1
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Prefix Statistic number Cumulative sum

__EIFEF

Selected objects:

C o

Exit

Total Area 94.00

Break Object: In some industrial application design, ..., _ B > I N
sometimes we need to break pipes or cable lines in our RUURN_N?Q B ’ ¢ e
schematic drawing to indicate their spatial relationship.
Sometimes we also need to break lines at crossing point to
make it convenient for the later edit. Break Object tool
came from this kind of needs.

BACKFLOW
( PREVENTION
DEVICE

COLD WATER
MAKE UP

xFsoz

Menu: Express tools>Modify>Break Object ~ Command Entr

This tool provides four breaking modes with gap distance to visualize the differences between breaking options.

Gap: Indicates the gap value between broken objects

Break all objects selected with each other: This option breaks all intersected objects each other. You can select objects by
window selection or picking each object.

Break selected objects with other selected objects: This option breaks all intersected objects by two selection sets (A and B). The
objects selected under the first set (A) will be broken meanwhile the objects selected under the second set (B) will be not
broken.

Break objects touching selected objects: This option breaks all intersected objects that touch at first instance selected object.
Break selected objects with any objects that touch it: This option breaks the first instance selected object with all intersected
objects to it.

' = 'BreakObject

Gap: 100
Select type of Break Function needed:

[ Break al objects selected with eatch other |

( Break selected objects with other selected objects ]

( Break objects touching selected objects ]

( Break selected objects with any objects that touch it |
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Draw Tools

Superhatch: Fills an enclosed area or selected objects with a hatch pattern, solid fill or gradient hatch.
Menu: Express > Draw > Superhatch Command Entry: Superhatch

The Superhatch dialog box is displayed:

Image: Accesses the Select Image dialog box to specify the image for the hatch pattern.

Block: Opens the Superhatch_Insert dialog box to specify the block for the hatch pattern. Superhatch -
Xref Attach: Accesses the Select reference file dialog box for specifying an xref file for a

hatch pattern.
WipeOut: Selects a wipeout object as a hatch pattern.
Select Existing. Selects an existing image, block, xref, or Wipeout as a hatch pattern.

For Images:

1. Open Superhatch dialog box. g
2. Click Image... button, choose an image file, the e
Superhatch Imageraster dialog box is displayed. Postin:  FGSTARCADPRCDUET LI PLATFORGSTARCAR PROTO
3. Pick the OK button in the Superhatch Imageraster M"“ e —
dialog box, specify insertion point, scale factor and e BT ] | e o=
angle of rotation. o (CEEE
4. The prompt “Is the placement of this IMAGE
acceptable? [Yes/Noj <yes>": —
5. Pick a point in the rectangle, press ENTER to finish.
For Blocks: — —
— [
1. Open Superhatch dialog box. Dot bed 1 pattam: *
2. Click the Block... button to access the Doutlebes 1
Superhatch_Insert dialog box: Iswtg"t'ﬁ onseser _
Block: Click the Block... button to select a block in x: [o000000 x: [L000900 | snge; [o.000m00
e curent e ==
File: Pick the File... button to select a drawing file ‘
as the block

3. Select the block in the Defined Blocks dialog box and press OK.
4. Specify insertion point, scale factor and angle of rotation.
5. The prompt “/s the placement of this IMAGE acceptable?
[Yes/No]<yes > "is displayed. Choose No to Esc. If you
choose Yes, GstarCAD will ask you to specify the first point
and the next point to place the image.

6. Specify an internal point of the objects for hatch boundary
then press ENTER to finish hatch

Command Line
Command: SUPERHATCH
W\ finsentEnter block name or [7] <NEW BED>: NEW BED
R [Unit: Milimeters convert: 1.0000
(Specify insertion paint or [Basepoint/Scale/X/Y/Z/Rotate]
[Erer X scale factor, speciy oppesie comer, o [Comer/XYZ] <1: Enter Y scal
"t [ factor <use X scale factors:
(Specty rotation angle <0>:
(Specify insertion paint:
Enter X scale factor <1.000000>:
lesse appoint the rotate angle:
I the placemert of this BLOCK acosptable? [Yes/Noj<Yes>Y
lease appoint the first point:
Command
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For WipeOut:

1. Access Superhatch dialog box and
click the Wipeout button:

2. GstarCAD will ask you to specify
insertion point to create an area that
masks underlying objects

3. Press ENTER to finish creating the
boundary that masks underlying objects.
4. As shown in the picture, move the new block to the carpet, the block will automatically cover

the object under it:
I-III-III
e ||| ke

Superhatch &J

Block. ..

¥ref Attach..

WipeQut...

Select Exiting

)

AP

=
\'|I| B e e e III\I AT IO

Breakline Symbol: Creates a polyline and inserts the breakline symbol. The options within this command are provided to control
the relative size and appearance of the breakline symbol and an extension of the polyline beyond the selected start and end
points.

Menu: Express tools> Draw > Breakline Symbol Command Entry: BREAKLINE

Once start the command, the command line prompts as Structiral Detail

follow: :
OO0

Block = BRKLINE.DWG, Size = 1.000, Extension = 1.250 .

e O D D
Specify first point for breakline or [Block/Size/Extension/sPecify PEeE
line for breakline]: Specify a point, or enter options N 10000
Options: - Structural Detail

Eo9ee

Specify first point for breakline: Draws break line through specifying its
start point and end point.

Heeee

10000

Block: Determines the block to be used as the breakline symbol. Structural Detail
Enter the block name for breakline symbol <BRKLINE.DWG > :
Enter a block name and press ENTER or press ENTER. If you press EO00e-
ENTER directly, the saving path of the break symbol file will be
displayed on the command line. IR A
N 10000
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Size: Determines the size of the breakline symbol. - Structural Detail
Breakline symbol size < 1> Specify the size of the breakline symbol é}

Extension. Determines the length of the line extension beyond selected

points. S-S PO im—% i
Breakline extension distance <1.25>: Specify the extension distance. R O YT X
Once the start point for the break line or the setup break symbol is — -— 10000
assigned, the command line prompts as follows: RS Glolotos |
Specify second point for breakline: Specify a point ]

10000

Specify location for break symbol <Midpoint>: Specify the point on the line
segment to specify the location of the breakline symbol, or press ENTER to use the midpoint of the line.

Pline Boolean: Menu: Express>Draw>Pline Boolean ~ Command Entry: GC_BoolOP

The Pline Boolean dialog box is displayed as shown in the following

Bool Operation Option
p icture. © Union O Intersection O Subtraction
Delete the entity chosen by second selection: Choose whether 10 delete | = petete the entity choosed by second selection

the second selected object. There are different Boolean operation
options such as union, intersection and subtraction. After the operation the object will be a polyline.

Operation case: Here, we use two boolean operations as shown below to complete the design of mechanical parts.

Before operation After operation

excirele roundlet

1. Start command, the dialog box will pop up; Bool Operation Option
2. Select the option "union" and uncheck the option "Delete the entity Ui D @ SRR
ChOOSGﬂ by SGCOﬂd SE|ECti0n" as Shown b6|0W [ Delete the entity choosed by second selection

3. First select the exterior circle and then the small circles around it, it will keep all small , el 0

circles around enabled for the next operation and you will get the first polyline as shown right : '-.5'-,:"{.\- *g
e 48
4. Start again the boolean operations, select option "subtraction” and check "Delete the entity \ M f, ﬁ
chosen by second selection". Pl PR X

5. Then select the interior circle and then the . - & .0
small circles around it, then the small circles will | 0.,
be automatically deleted.

© Union O Intersection © Subtraction

Delete the entity choosed by second selection
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Spline to Line: Converts spline(s) to numbers of straight lines.
Menu: Express tools>Draw> Spline to Line Command Entry: SPLINE2LINE

Once the command is started, the command line prompts as follow:

Select spline or [Set parameters(S)]: Select spline(s) or input “S” to set parameters

[The line precision/Starting point (S)<1.00>]: Input a new value bigger than 0 to join precision between segment lings
Conversion in a straight line to allow the greatest number of <5000>]: Input a new value smaller than 5000 to number of lines

At first, the system will fit the spline with a segment ling which precision (Length) has been specified, if the ling’s number
needed is more than the maximum number, the system will extend the length of the lings by force, using the maximum number
of lines to fit the spline.

Select spline or [Set parameters(S)]: Then select the spline(s) to be converted and press Enter to finish the operation

Spline to Pline: With this tool the SPline created can be converted to a polyline according to the accuracy (number of segments
of the arc) that the user assigns. The more specified the segment number is, the higher is the matching degree between the
converted Polyline.

Menu: Express tools> Draw>Spline to Pline Command Entry: SPTPL

For example, draw the follow spline sample with 5 arcs as shown:

5 ARCS IN THE SPLINE
After the command SPTPL is started, Please select the object (Spline).

After selecting the object, a prompt message will be displayed > Delete ? 7

the spline? Yes(Y) / No(N): In this case, if we select Yes, this option will 3

delete the spline in place but if we select No, it will keep the spline. 8 7
After inputting the delete spline option, a prompt message will be 1 . y

displayed > Please enter the number of arcs Non-zero: And we have to
input a value higher than zero, for example 8. This value determings the
segment number of arcs to be created in the new Polyline.

8 SEGMENTS CREATED IN THE PLINE
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Line to Pline: This function can convert one or multiple connected straight line(s), arc(s) to one polyline. You can access from:

Menu: Express tools>Draw>Line to Polyline Command Entry: Line2pl

After starting the command, a
prompt message will be displayed>
Please enter the join precision: 0

The Join precision will determine

the union space between end

points of each object. In this case,
we will input value 0 to ensure the |
connection between objects (lines).

After inputting the join value, Please select the objects to be joined and converted to Polyline:

In this drawing there are many lines

And finally, you have successfully created a polyline:

Now the objects selected are converted as Polyline

|

|
_%_m;_________________________________jm_

|

i)
20 Polyfine

Calor ByLayer
Layer [
Linstype ByLayer

Cloud Line: Creates polyline objects comprised of arcs that T e ARt
resemble cloud lines. ‘

Menu: Express tools>Draw>Cloud Line ~ Command ( W
Entry: REVCLOUD ' N/l Items 2
( ] | } and 5

Once the command is started, the command line prompts as
follow:
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Minimum arc length: Current Maximum arc length.: Current Style: Normal

Specify start point or [Arc length/Object/Style] < Object> Specify a point or enter an option or press ENTER.

Starting point: Specifies the starting point of the cloud lines.
Guide crosshairs along cloud path...

Once the first arc links to the last arc, the prompts is displayed: Reverse direction [Yes (Y)/No (N)]: By inputting “Y”, all the arcs

will change into an inverse position. By inputting “N”, the arcs will keep the current position.

Arc: Specifies the arc length.
Specify minimum length of arc <current> Specify the arc length value or press ENTER.
Specify the maximum arc length <current>. Specify the arc length value or press ENTER.

Then specify start and end point to finish the operation.

Note: The maximum arc length should not be greater than 3 times the minimum arc length. The valug of arc length is stored in

the register.

N - ;
G/ © ks ©

TN e MR

ool Check

Check

Items 2 /

and 5 N

€
B
Items 2
andb ¢ {

Object: Converts the closed object to the cloud lines. It can only be O - bl
applied to the closed object. ‘:P '

Select objects: Select a closed object(s) e

Reverse direction [Yes (Y)/No (N)]: By inputting “Y”, all the arcs will ftarms 7

change into an inverse position. By inputting “N”, the arcs will keep the @ and 5 =y

current position. Select any option and press Enter to finish the
operation.

Style: There are two styles: Normal (same as above) and
Calligraphy, which makes the arcs of the cloud thicker than the
normal one.

Select arc style [Normal/Calligraphy] <Normal> Select

Calligraphic

Reverse direction [Yes (Y)/No (N)]: By inputting “Y”, all the arcs O
will change into an inverse position. By inputting “N”, the arcs
will keep the current position. Select any option and press Enter
to finish the operation. "

Check
Items 2
and 5
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Tools

Command Alias: This function allows users to add, modify, delete command alias and shell commands.

Menu: Express tools>Tools>Command Alias

Operation steps:

1. Start the command and a dialog box
will pop up.

2. Select commands to be deleted and
click “Remove” button to delete
command alias.

3. Select the command to be modified
and click “Edit” button, a dialog box will
pop up.

4. Click “OK” 1o finish editing.

System Variable Editor:

Command Entry: ALIAS

" GstarCAD CommandAlias
File Edit Help

*Command Alias | Shell Command|

GstarCAD commands entered from shortcut:

Alias GstarCAD command 4 Add
34 3DARRAY =
300 3DORBIT

3F 3DFACE

3P 3DPOLY

A ARC

Ah AREA

AC BACTION

ACADBLOC... BLOCK

ACADWBLO... WwBLOCK

ADC ADCENTER

ADCENTER ~ ADCENTER

AL ALIGN v
< %

Confim changes

Menu: Express tools>Tools> System Variable Editor

Command Entry: SYSVDLG

System Variables Dialog Box Options:

List Box: Displays a list of system variables. The edit field
above the list box allows for filtering the list box display
based on user input. For example, entering DIM* in the
edit field filters the list to display only system variables
that start with DIM. If nothing is entered in the edit field,
the list displays all system variables. If more than one

_PKSER
TVERNUM
ACISOUTVER
ADCSTATE
AFLAGS
ANGBASE
ANGDIR
APBOX
APERTURE

AUDITCTL
AUNITS
AUPREC

Edit Command Alias 3]

Type the alias and its ICAD command
string into the boxes below.

Alias:
3 | ok ]
GstarCaD
|3DARRAY

IDARRAY A
3DFACE =)
3DORBIT
3DORBIT
aDPOLY |
ADCENTER v

Allows you to view, save, load and compare system variable settings.

New Value:
Current Value:

Initial Value:

[Read-only)

0.0000

SavedIn:  Not saved

Type: Real

AREA is both a command and a system variable. The AREA system
variable stores the last area computed by the AREAcommand. Because

entering area at the Command prompt invokes the AREA command,
you must use the SETVAR command to access the AREA system
variable.

AUTOSNAP
BACKZ

Save All... “ Read... H Compare with saved “ 0K ” Eancel]

BINDTYPE

system variable is highlighted, all edit and display options are unavailable.

New Value. Displays the current value
of the system variable highlighted in
the list box and allows you to edit that
value. No changes are committed
until the dialog is closed with the OK
button.

Current Value: Displays the value of
the system variable highlighted in the
list box as if SYSVDLG was started.

Initial Value: Displays the initial value
of the system variable highlighted in
the list box. This is the value the

system variable has in a new drawing.

Saved In: Displays where the value of
the highlighted system variable is
saved.

Type: Displays the type of the
highlighted system variable; for

example, integer, real, string, and so
on.

Save All: Saves the current system
variable settings to an SVF or SCR file.
SVF files can be read into SYSVDLG
and SCR files are AutoCAD scripts

that can be run from the AutoCAD
command line. The button will display
Save All, Save Selected or Save
Filtered depending on the condition of

the system variable list.
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Read: Restores saved settings from an with the Cancel button. SYSVDLG will Compare with saved: Compares the
SVF file. No changes are saved to the validate new system variable values as variables of the drawing with the
drawing until you choose OK. All they are changed. saved SCR file.

pending changes can be discarded

Make Linetype: Creates a linetype based on selected objects. e

» GstarCAD2012 Professio... »

| 1. support

Menu: Express tools>Tools>Make Linetype Gasre
Command Entry: MKLTYPE B g

ToolPalettes
UserDataCache
= veA

i [ 1cAD

~ [m@ ICADISO

- |G

Once the command is started, the following window will be displayed.
You can find the Line files (*.lin) and apply them to the current drawing.

Attach Xdata: Attaches extended object data (xdata) to a selected object.
Menu: Express tools>Tools> Attach Xdata Command Entry: XDATA

Select object: Use an object selection method.
Input application name: Specify application name.
Enter an option [3Real/DIR/DISP/DIST/Hand/Int/LAyer/LOng/Pos/Real/SCale/STr/eXit] < eXit>:

Options:

Application name: An ASCII string up to 255 bytes long Int: A 16-bit integer (group code 1070).

(group code 1000). Layer: A layer name (group code 1003).

3Real: 3 real numbers (group code 1010). Long: A 32-bit signed long integer (group code 1071).
Dir: A 3D World space direction (group code 1013). Pos: A 3D World space position (group code 1011).
Disp: A 3D World space displacement (group code 1012). Real: A real number (group code 1040).

Dist: A distance (group code 1041). Scale: A scale factor (group code 1042).

Hand: An object handle (group code 1005).

List Object Xdata: Lists the xdata associated with an object.
Menu: Express tools>Tools> List Object Xdata Command Entry:XDLIST

Select objects: Use an object selection method.
Input application name <> Specify an application name or press ENTER for all applications.
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Table Tools
Table Fill In: You can use this function to fill in the table or edit the texts.

Menu: Express>Table Tools>Table Fill In - Command Entry: FORMTXT

Operation steps:
1. Start the command.

2. Click in the cell or input “Q” and a dialog box will pop up. Crih R

Test High Fashiors | Measwedwordhigh = | Jjuct Fashion:  (Justlell

3. In the dialog box you can set the text height fashion, just fashion Fiup Test High: |45 st Space betveen 40 :
. [¥] Change Test High [7] Change Test Just
and other text attributes.

4. Click the blank area of a cell and input texts directly.
5. Enter to finish filling in.

Draw Table: This function can help you draw a table.

Menu: Express>Table Tools> Draw Table ~ Command Entry: BGE

Operation steps:

1. Start the command.

2. Specify the first point of the table.

3. The command line prompts.

a. Press Q key and the width of the form will increase a little, is used to adjust the horizontal width.
b. Press W key and the width of the form will decrease a little, used to adjust the horizontal width.
c. Press A key and the height of the form will increase a little, used to adjust the vertical height.

d. Press S key and the height of the form will decrease a little, used to adjust the vertical height.
4.You can input the corresponding options to adjust the size of the table.

5. Specify the second point to finish drawing the table.

Merge Cells: This function is similar to merge cells in Excel.

Menu: Express>Table Tools>Merge Cells ~ Gommand Entry: BGH

(Q)increase level width /(W)minish level width /(A)increase vertical high /(S)minish vertical high /(0)input width and highspecify the second orientation poin
t of form(cell width16,cell highs,coluani3,row-13): <

Operation steps:

1. Start the command.

2. Specify the borderline of the form to merge or the first cell, as shown below.
3. Merging effect as below. And press Enter to finish the command.



Sample1: Specify the borderline of the form

Sample2: Specify the first cell and another cell

[Spemify the first peint of the ferm fenterl:

Sperify another cell

Split Cells: This function is similar to split cells in Excel. Fig 14

Menu: Express>Table Tools>Split Cells ~ Command Entry: BGFG ﬁ
3 Column * 2 Row

Operation steps:

1. Start the command.

2. Specify the cell which needs to be split. (Fig14).

3. Move the cursor, when the rows and columns are a size up,
click the mouse and the cell will be split automatically, (Fig15).

Fig 15

Add Bias: This function can add bias for a cell.

Click the start and end point according to the prompts and the system will provide an intersection snap and can easily find the
start and end point of the bias, or you can click any area in one cell and the system will find the top left point of the cell
automatically, then the system will prompt you to select the end point, you can also click any area in the cell, system will take
the bottom right point as the end point automatically, this way, a bias is added in a cell.

Menu: Express>Table Tools>Add Bias ~ Command Entry: BGX

Operation steps:

1. Start the command.

2. Specify start point, you can click the top left point or click
the blank area in the cell.

3. Specify end point to finish drawing the bias.

Drag Multiple Lines: You can change the row and column width by dragging the line of the table and the corresponding parts of
the line will also change. For example, drag the line you selected to the right side and all the lines in the right side will move to
the right side correspondingly.

Menu: Express>Table Tools>Drag Multiple Lines ~ Command Entry: BGMT

Operation steps:
1. Start the command.
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2. Specify the line of table for dragging. (Fig16)
3. Specify the place or distance to drag to (left is positive). (Fig17)
4. Enter to finish moving. (Fig18)

Fig 16 Fig 17 Fig 18

Drag Line: Different to Multiline drag, Drag line will just move the line you selected and other relevant lines will not move.

Menu: Express>Table Tools>Drag Line Command Entry: BGST

Operation steps:

1.Start the command.

2.5pecify the line of the table for dragging. (Fig19)

3.Specify the place or distance to drag to (left is positive).  (Fig20)
4.Enter to finish the command. (Fig21)

Fig 19 Fig 20 Fig 21

Drag Segment: This command will not change the lines of the whole table, but just move the side line of a cell.

Menu: Express>Table Tools>Drag Segment
Command Entry: BGJT

Operation steps:
1. Start the command. Fig 22 Fig 23
2. Specify the line of the table for dragging (Fig22).

3. Specify the place or distance to drag (left is positive). (Fig23)
4. Enter to finish the command (Fig24).

Fig 24

Selection Scale: This function can zoom in and zoom out the whole table base on the point you specified.

Menu: Express>Table Tools>Selection Scale  Command Entry: BGSF

Operation steps:
1. Start the command and specify the base point for the line of table. (Fig25)
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2. Move the cursor and the table will zoom. (Fig26)
3. Drag to a suitable position and click. (Fig27)

Intersection;e base point for the li:

Fig 25 Fig 26

Add Row: This function can add rows to the table.

Menu: Express>Table Tools>Add Row ~ Gommand Entry; BGZH

Operation steps:

1.Start the command.

2. Specify the position of the new row.

3. The system will add a row below the point you specified.

Add Column: This function can add new columns to the table.

Menu: Express>Table Tools>Add Column ~ Command Entry: BGZL

Operation steps:

1. Start the command.

2. Specify the direction of the new column.

3. The system will add a new column on the right side of the table.

Delete Row: This function can delete the row of the table you specified.

D incres

Menu: Express>Table Tools>Delete Row

Command Entry: BGSH

Operation steps:

1. Start the command and specify the cell of row for delete.
2. The system will delete the row you specified.

Delete Column: This function can delete columns you specified.

Menu: Express>Table Tools>Delete Column  Command Entry: BGSL

Operation steps:
1. Start the command.
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2. Specify the cell of column for delete.
3. The system will delete the column you specified.

Delete Table: This function can delete the table you selected.

Menu: Express>Table Tools>Delete Table ~ Command Entry; BGSC
Operation steps:
1. Start the command and specify the table for delete.

2. Enter to finish deleting.

Text Orientation Adjust: This function is used to adjust the alignment of the texts.

T T
Opposite corner: I ”( 156°

Menu: Express>Table Tools>Text Orientation Adjust
Command Entry: BGJS

GstorCAl GstarCAIl GstarCAL

GstarCAL GstorCAL GstorCAL

Operation steps:
1. Start the command and select the text for adjust.

GstorCALl GstorCAl GstorCAL

‘Command Bar

2. Press Enter and the command line will prompt the location mode.

Command: BGJS

*Text orientation adjust*=Bgjs

3. Here we input “1” to select left alignment. select the text for adjust:

Select objects:Find out 1, total 1
Select objects:

Enter new justification...(@ Center,1 Left,2 Right,3 Both)<flush center>:

4. The text you specified will align to the left, as shown below.

GstorCAL GstarCAIL GstorCAD

GstarCAL GstorCAL GstorCAL

GstarCAll GstorCAL GstarCAL

Notice:
1. This function can only orient and adjust the table text in the TABLE layer.

2. The distance to the table line using left alignment or right alignment has already been set by the program, if you thunk that

the distance is not suitable, you can use the GstarCAD command to adjust the distance.

CAD Table to Excel: This command will convert sheets, composed by line/Spline and text/Mtext in CAD, to EXCEL.

Menu: Express>Table Tools> CAD Table to Excel Command Entry: GC_CTE

Operation method:

1. Start the command and specify the conversion ratio.

2. Select the table that need to be changed and press enter, the system will
automatically open EXCEL after conversion.

@ CAD Table to EXCEL (i)

Table Soale: Ad
i
1/3
144
1/8
2
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3. Save the EXCEL sheet.

PART LIST

GSTARCAD

BMW CHASSIS CLAMP

ASSEMBLY

T BWMCP-1(

Coordinate Tools
Coordinate Point; Dimensions the point coordinate in

Menu: Express>Coordinate Tools>Coordinate Point

!i

Change Z Coordinate: Choose several objects at one time and then change

the Z coordinates together.

Menu: Express>Coordinate Tools>Change Z Coordinate

Command Entry: CHANGEZ

PART UST

GSTARCAD

Y006304 |

the drawing.

Command Entry: DIMCOORD

and: _HCZZBD
seftings: Auto = On, Cantrol = All, Combine = Yes, Layer = Yes
seltings: Auto = On, Control = All, Combine = Yes, Layer = Yes
settings: Auto = Off, Control = All, Combine = Yes, Layer = Yes
Input dimension text scale<15.0>:5

input dimension text high<8.0>:3

the coordinate point <Bxt>:

Unit: Unitless convert: 1.0000

Enter attribute values

the coordinate direction Or [Change Parameter{Q)]<Enter>:

the coordinate point Or [Change Parameter(Q)j<Exit>:Cancel®
settings: Auto = Off, Control = All, Combine = Yes, Layer = Yes
settings: Auto = Off, Control = All, Combine = Yes, Layer = Yes
settings: Auto = Off, Control = All, Combine = Yes, Layer = Yes

TMiE
BMW CHASSIS CLAMP
ASSEMBLY

(i

«

3

|Command: a1

.
I'-“I
{- a8
e
P e s e
[Select object:
" et
L Fommand
X i ” i ’
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Drawing Tools

Drawing Lock: Sometimes a designer sends drawings to other people, but doesn’t want others to modify the drawings. The
“Drawing Lock” function can turn the drawing into a whole block. You can’t explode it or modify the objects of the original

drawing. It is a good way to prevent others from modifying the drawing.
Menu: Express tools>Drawing Tools>Drawing Lock Command Entry: LOCKUP

Once the command is started, the follow wizard will be displayed:

Use this function will not be able to modify the drawing,
please save your file prior to use it or save a file backup

Select objects: Select all the objects in the current drawing to be locked and press Enter. Note: Please save your drawing before
using this function, because the locked drawing can’t be modified.

mroen (o0l (SETARCAD 2012
|

1 AW G ABeE CLAMP
Pt

3
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Drawing Compare: Drawing compare is an exclusive function in GstarCAD which is added according to the user’s requirement.
[t enhances collaboration by using color-coded displays to show items on a drawing that have been changed, added, or deleted
by other members of the design team. Changes to items such as styles, block attribute, object of block can also be tracked. The
program will analyze the differences between two drawings automatically. Then the differences will be marked with different
colors. Users can also set the marking color by clicking the “option” button.

Menu: Express tools>Drawing Tools>Drawing Compare (‘comparedug =
Command Entry: CMP 0Old DWG: D:\ORIGINAL DRAWING.dwg —
‘New DWG: D:\WMODIFIED DRAWING.dwg Browse
Result
Once the command is started, the following window will be displayed: SE"E“ET:“ '
Result Path: | Dt Browse
[(compare ] [Loptn | [ concl ]

In this window, you have to browse the old DWG (original drawing) and the new DWG (drawing modified). You can also assign
a path to save the compared drawing. Then select the button Option to set-up the comparison parameters.

Cmp Precision: 0.0001 v Mark color(dlick change)

Cmp detail Old DWG New DWG

Dover  Dotwiotr N o= N <o

[¥] color [¥] font style - modified modified

[¥]line type  [¥]entin block | no modified

[cancel]

After setting up the comparison parameters such as: 2OW ) MUY —
i i = e &
colors, layers, line type, etc. select Ok to confim &
these parameters. Note: Pay attention to the mark color
because the deleted, modified and added objects will !
i ; __2F I Classroom
assume these into the compared drawing. Then select =1
the button Compare in the window below to compare @
both drawings.
C1521
CI515 _ pi ,
s ) =8 M| 5 cea c2721
Old DWG: D:\ORIGINAL DRAWING.dwg
New DWG: D:\MODIFIED DRAWING.dwg Erowse e ED < > 3600 M0930
Result IS} £ i H—/ [ | | |
[] save Result S2|i=D )
Result Paths D11\ | [ Bromse ‘ED 1
[(compare ] [Lopen | [ conl ] | i Teachers
=D i == Room
. . A331F
D
|
==
C1521 ,
C1515

M, o e |
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Graphic Compare: As we know the drawing compare function in GstarCAD can be used to compare similar drawings containing
nearly number of drawn objects to each other, especially to compare different versions of revision drawings.

T OCRIVEgwy 7 OCHEVA Gy | =

& X

=

Menu:  Express  tools>Drawing  Tools>Graphic ~ Compare | Goreerebus

C om mand Entry O C M P Old DWG: :\PLATFORM\GSTARCAD 2017\G17 FEATURES DWG\DCREVA.dwg
New DWG: F:\GSTARCAD\PRODUCT LINE\PLATFORM\GSTARCAD 2017\G17F

CMP Result

Drawing compare can make comparisons between two similar (7} save Drawing

drawings (old DWG and New DWG) and generate them as separate || "= " TS
files. After pressing COMPARE button within CompareDwg dialog box, ope ) (o ] [ o )
the program will generate and open _old and _new.dwg files, where [ compare opion

you can see the differences between drawings. i e

Cmp detail 0ld DWG New DWG
Drawing Compare can find out differences (drawn objects) and show A

[¥] color [¥] font style

the result with different colors, e.g. if a line is modified, removed or live type. [@entinbock nomodited
newly drawn, it will be displayed in different colors. =

=

7] plot width I = N o
| L]

modified modified

| |,

But there is something else that drawing compare

could not accomplish so accurately. Drawing compare  ~ —+—
can’t insert and show the compared objects on the [
current drawing working space that you are working at FFAE
real time. Besides, drawing compare can’t show the

details of how the objects were located before they

were modified. DC REVISION "A" i DC REVISION "B

So the details are very important when comparing
objects. Now the new and innovative Graphic Compare tool can do more! It does not only compare two drawingswith similar
objects geometry and find out the differences but also display the details of any change at the current workspace of your
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drawing in real time, e.g. if a line is modified, only the changed part of the line is displayed in different color. The unchanged

part remains unchanged.

Graphic compare dialog box

You can invoke the Graphic Compare dialog box by tipping OCMP command at command line or by dynamic input.

Specify Drawing: Offerstwo options of drawing comparison
between select objects on your current drawing or specify
files.

Select Objects: Offers two options of objects selection
including their base points to be compared.

Select base objects and base point: This option allows select
all objects, including a basis point as a first selection set to
be compared.

Select compare objects and base point: This option allows
select all objects, including a basis point as a second
selection set to be compared with the first selection set.

Specify File: Checkingthis option allows browse two drawing file to be

compared known as base and compare file.

Output Drawing: Offers two options of drawing compared output.

= Drawing Compare @
Specify drawing
@ Select objects

[ Select base objects and base point \ cﬂ No object selected

[Select compare objects and base pointj ﬂ No object selected

() Spectify file

Output Drawing
@ Insert cumrent document ") BExport to a file Output settings

C:AUsers\asus\Documents\ocmp .dwg

8] (oo | [ e ]

= Qutput Settings (=3

Objects only in the base drawing

Insert current document: This option allows insert the compared set of Layer: o 7]

selected objects on the current workspace.

Layer: 0 v
Color: [OYelow -
Linetype: ( Continuous _~ |
Obiects only in the compare drawing

Color (HRed -
Linetype: [ Continuous v |

Export to a file: This option allows output the compared set of selected Coincidence objecis

objects to a drawing file.

Output setings: You can setup properties like layer, color and linetype for Linetype: [
all selected objects to be compared to enhance visual differences

between them.

Inserting Compared Objects Set into Current Drawing

Layer: 0 -

Color: i [H Color 8 - ]

Continuous v ]

[ ok ] [ cancel ]

To insert compared objects set into current drawing, first select the Specty drawing

buttonSelect base objects and base point.

Then select allobjects as first selection set called base objects and
specify a base point for the base objects.Then select the buttonSelect

©) Select objects
I[ Select base objects and base point ] 35 objects selected I
|ESeled compare objects and base poima 41 objects selected l

compare objects and base point and repeat all previous process mentioned above.
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_____________________________

DC REVISION "A"

Under Output Drawing, check the option Insert current document.
If you want setup visual properties for the compared objects,

Specify the base point: [1283.2361,1142.7652

DC REVISION "A"

Output Drawing

@) Insert curent document ) Export to a file

C:\Users\asus\Documents‘ocmp.dwg

click Output settings button. After that you can place the fiename:arid patt
compared objects set in a convenient point according your need.

[ o | [ cocel | [ beb |

- - BEE

DC REVISION "A" DC REVISION "B" COMPARED

Batch Purge (Batch Files Cleaning): This new function allows to batch purge the excess objects such as blocks, layers, line
type, dimension style or text style on several DWG files. The Batpurge tool doesn’t need to open files. It executes the command
of purge directly, which makes it run with very high efficiency. You can access it from:

Menu: Express>Drawing Tools>Batch Purge  Command Entry: Batpurge
After the command is started, a dialog box will be displayed. In this dialog box you can add, select, unselect, clean and start
purging objects within DWG files with the following options:

DWG Files Batch

Fles List

Add Files: Add one or more batch files from the selected
path.

Add Folder: Add DWG files from a selected folder.
Select All: Select all the DWG file lists at once.

[T

Fhetiame state Attrbute

[]0:65TARCAD|PROCUCT LINEPLATFORMIGSTARCAD 20 LSIDRAWING RESOURCEDWG FOR THE SALES STAF... [MotDe | |
[l o: GSTARCAD PRODUCT LINEPLATFORMIGSTARCAD 20 13|DRAWING RESOLRCEDWG FOR THE SAES STAF.. [NotDo | |
JE4J0: \GSTARCAD PROCUCT LINEPLATFORMIGSTARCAD 2013\DRAWING RESOLRCEYDWG FOR THE SALES STAF...

[ addrocer |
@iRearsve
[totoo |

mssbtta]

[ seecrene |

[ 0:\o5TARCAD PR ODUCT LINE PLATFORMIGSTARCAD 20 L3\DRAWING RESOURCE \DWG FOR THE SALES STAF... | Not
(€] 0: 57AR CAD PROCUCT LINEPLATFORMIGSTARCAD 20 13\DRAWING RESOLRCEDWG FOR THE SALES STAF.._

[_odete__|
Select None: Unselect all the DWG files at once. =
Delete: Delete selected object(s) in the file list. |
Clear: Clean all the DWG file lists at once. s | [ ]

Start Purge: Starts purging the selected DWG file list. After
purging, GstarCAD will generate a notepad file where you can see the purge details.
Log: After the purge operation is finished, you can Login in to the created notepad file and see the batch purge detail record.
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AutoXLS Table Tools

Create Table:  Menu: Express tools>AutoXIsTable>Create Table ~ Command Entry: CAOT AUTOXLSTABLE CREATE

Operation steps:
1. In the AutoXLSTable pull-down menu, click Create Table.
2. Create an Excel spreadsheet or open an existing Excel spreadsheet in

Create

Table =]

Excel.

3. Click Finish button in the AutoXIsTable pull-down menu in Excel.
4. Specify insertion point in GstarCAD.

c dpMove D) Revowe ~-Tom -
- Bcopy Mmmor [T rmet - X
&

iy 1

epTeas

S5 1At

<[\ etrvge Clscate B army T EEE BB 1 ke | il x v o]
L —
—— 4 A B || o | €& | FE | 6 | H | 1
% PART LIST ABC- ASSEMBLY DRAWING REXROT
‘ 3 |ABC-REXROT 38 1 | CARBON STEEL
—_—
‘ 4 |ABC-REX- PT39 3 | CARBON STEEL
PART LIST ABC- ASSEMBLY DRAWING REXROT 5 |ABCREX- PT40 1 | CARBON STEEL
ABC-REXROT 38 1 | CARBONSTEEL 6 |ABC-REX- PT41 5 | CARBON STEEL
|ABC-REX- PT39 3 | CARBONSTEEL 7 |ABC-REX- PT42 7 | CARBON STEEL
scaoc i s -usonsrea b L Lamonni
1
ABCREX- PTA2 7 | CARBONSTEEL R 2
ABCREXPTA3 3 | carsonsTeR. 10 |ABC-REX- PT45 10 | CARBON STEEL
ABCREX- P44 2 | CARBONSTEEL 11 |ABC-REX-TP321 7 MILD STEEL
ABC-REX-PTAS | 10 | CARBON STEEL 12 |ABC-REX-TP322 4 | CARBON STEEL
ABCREXTP321 7 MILD STEEL 13 |ABC-REX-TP323 1 | CARBON STEEL
ABC-REX-TP322 4 CARBON STEEL A RBON STEEL
[ABC-REX-TP323 1 | CARBONSTEEL ki Sl ABC-ASSEMBLY
ABCREX-TP324 1 | CARBONSTEEL OROD Ao AR R ABC REXTP325 RIECARDON IR REXROT
ABCREX-TP325 1 | CARBONSTEEL S R 16 | DESCRIPTION | SERIAL | QT | MATERIAL |TREATMENT| OBS
DESCRIPTION seRwL | ar MATERIAL | TREATMENT | 0BS 17

Edit Table: Menu: Express tools>AutoXIsTable>Edit Table Command Entry: CAOT_AUTOXLSTABLE_EDIT

Operation steps:

1. Click Edit Table.
2. Select a table created by AutoXIsTable in GstarCAD then the Excel file will

lp  Express
Express

open.

M |
o B A B c D E F G H 1
Taple 4 ||~ 1
5 PART LIST ABC- ASSEMBLY DRAWING REXROT
3 [ABC-REXROT 38 1 | MILD STEEL
4 [ABC-REX- PTS9 3 | MILD STEEL
PART LIST ABC- ASSEMBLY DRAWING REXROT T 5 | ABC-REX- PT40 1 MILD STEEL
PYTereere T 6 |ABC-REX- PT41 5 | MILD STEEL
ABCREX.PT39 3 | L CARBONGIEE. 7 |ABC-REX- PT42 7 | MiLD sTEEL
[ABCREX- PT40 1 | CARBONSTEEL 8 |ABC-REX- PT43 3 | MILD STEEL
[ABC-REX- PTa1 5 | CARBONSTEEL 9 [ABC-REX- PT44 2 | MILD STEEL
ABC-RER- 112 i |SiCARBORSTEEL 10 | ABC-REX- PT45 10 | MILD STEEL
AC B e 3 SN, 11 [ABC-REX-TP321 7 | mip sTEEL
[ABC-REX- PT44 2 CARBON STEEL
ARCRECPTAS 10| CARBONSTERL 12 | ABC-REX-TP322 4 | MILD STEEL
ABCREX-TP321 7 MILD STEEL 13 | ABC-REX-TP323 1 MILD STEEL
[ABCREXTP322 4 | CARBONSTEEL 14 | ABC-REX-TP324 1 | MILD STEEL
. GSTARCAD ABC-ASSEMBLY
ABCREX-TP323 1 | CARBONSTEEL 15 | ABC-REX-TP325 1 MILD STEEL b REXROT
ABCREXTP324 1 | CARBONSTEEL GSTARCAD ABC-ASSEMBLY 16 | DESCRIPTION | SERIAL | QT | MATERIAL | TREATMENT| OBS
[ABC-REX-TP325 CARBON STEEL DRAWING REXROT
DESCRIPTION SERIAL ar MATERIAL TREATMENT OBS.
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Update Table: Update table whose original Excel spreadsheet was modified.

Menu: Express tools>AutoXIsTable>Update Table
Command Entry: CAOT AUTOXLSTABLE UPDATETBL

Operation steps:

1. Click Update table.

2. Select the table to update then the table will update
automatically according to the relevant Excel.

[ Update table

Home
O PMove OReohe -Tim- 2 B B S 6 | 8B G B

/ ’D @ r O“‘%er Mmiror {7 Filet - 3% | GO - A r_

Une Poyine Crde  Arc |[Neruse Clsce Sarwy & |G @ B B B E B B Tet  Une

A 8 c D 3 F G H 1
: : ! ! - - Drawingldwg
; s PART LIST ABC- ASSEMBLY DRAWING REXROT
3 [ABC-REXROT 38 1 | MILDSTEEL PART LIST ABC- ASSEMBLY DRAWING REXROT
4 |ABCREX-PT39 3 | miLDsTEEL ABCREGOT S8 S i
5 |ABC-REX- PT40 1 | MILD STEEL ABCREX-PT39 5 | DS
6 |ABC-REX- PTA1 5 | MILD STEEL ABCREX- PT40 1| MDSsTEEL
7 |ABCREX-PT42 7 | MILD STEEL ABCREX- PT41 5 | miosteeL
8 |ABCREX-PT43 3 | miLDSTEEL ABC-REX-PT42 7 | MILDSTEEL
9 [ABC-REX- PT44 2 | MILD STEEL ARCREX"PT48 L MILD STERL
10 [ ABC-REX- PT4S 10 | MILD STEEL ANCREN: Prad 2 | WunivEs
11 |ABC-REX-TP321 7 | MILD STEEL ABC REX FTAD 101 AIDSTERL
ABC-REX-TP321 7 MILD STEEL
12 | ABC-REX-TP322 4 | MILD STEEL ABCRECTPIT: o niDee
13 | ABC-REX-TP323 1 | MILD STEEL ABCREXTP323 T | WD STERL
14 |ABCREX TPS24 1 | MILDSTEEL GSTARCAD ABC-ASSEMBLY ARCRFYCTPRIA 1l wEnSIER GSTARCAD ABC-ASSEMBLY
15 | ABC-REX-TP325 1 | MILDSTEEL REXROT ABCREXTP325 1| MiDsTEEL e
16 | DESCRIPTION | SERIAL | QT | MATERIAL | TREATMENT| OBS DESCRIPTION | SERWAL [ QT| WMATERIAL | TREATMENT| OBS

Update All the Tables: Menu: Express>AutoXIsTable>Update All the Tables Command

Entry: CAOT_AUTOXLSTABLE UPDATEALLTBL

After executing this command, the system will update all the table objects created by “Create Table” command.

File Link Management: You can use this function to edit, manage the link relation between a table object and an external EXCEL

file.
Menu: Express>AutoXIsTable>File Link Management

Operation steps:
1. Start the command.

2. Select table object in the drawing and a dialog box will pop up.
3. Click the “ Browse” button to open the file selection dialog box.

4. Select an XLS file which needs to be connected with a table

object and click “OK”, then return to the Link Manager dialog box.

[T

5. You can use the “Attach”, “Delete” and “Update” button to
complete link related editing and management.

Command Entry: CAOT_AUTOXLSTABLE MANAGELINK

|
‘ File Name Sheet Selec... Date Saved Path
Book! xisx Sheett 2013/6/14 15:13..  C:Users\Tian\Desktop|
< (1] | »
Excel File At; Sheet Name; Selection Address
C:\Users\Tian\Deskiop\OEM.xis

[8))]

8



Path Settings: This function is used to set the path of an Excel file.

Menu: Express>AutoXIsTable>Path Settings ~ Command Entry: CAOT AUTOXLSTABLE USINGPATH

Operation steps: cerieren s DN
. . Please select excel file path:

1. Start the Command and a dlalog bOX WI” pOp Up aS belOW (") Using Relative Path Default: same path as dwg

2. In the dialog box, you can set the path pattern of the Excel file. @ sing Absolute Path

Selection Management: You can use this function to calculate objects length and area, when the length and area change, the
calculating data will update automatically.

Menu: Express>AutoXIsTable> Selection Management Command Entry: CAOT_AUTOXLSTABLE SELECTION

Purpose: use the “Selection Management” function to calculate the area of a circle and a rectangle, when length and area
change, the calculating data will update automatically.

1. Draw a circle and a rectangle as below, use the “Create Table” function to create a table as below.

L ~ CHENEE
4 A B N
1 OBJECTS _ |AREA
2 CIRCLE
3 RECTANGLE

a

® & EEH@”B|
==z = %

2. Start the “Selection Management” command and a . : .
Q Selection Manager ~ ¥ Selection ManagﬂA g

dialog box will pop up.

3. Input “CIRCLE” and click the “New Group” button. -
4. Select the circle.
5. Press enter, the “Selection Management” dialog box

Group Name: Group Name:

will add a new item “CIRCLE”, as shown below. G o=

6. You can add a “RECTANGLE" item using the same e 68| e %

operation as above. 7. Click P—

“Close” to exit “Selection Management”. 8. Use the Coonnf [ oce-

. . N , . Expi Rename Explode
Edit Table” command to edit the table. 9. Click the cell

on the right side of “CIRCLE” and click the “Insert e ——— o e

Function” icon, as shown below:
10. In the dialog box, you can specify the entity as “CIRCLE”, Layer as “All” and click “OK”.
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x| LR s [E3 Insert Function :

mm"‘e Lols Fage oL " Block Calculate
AutoXisTable » 3 (@ 4, W GF = - CAD Block Calculate
Block: ] ﬂ Layer: | ;l [T Attibute
Tag: ] ;j WYalue: I ;I
Menu Commands Custom Toolbars L
B2 v& 3 ‘\ & Area Calculate
A B ~CAD Area Calculate
1 | OBJECTS AREA Entity: |CRICLE ~| Layer v | Factor [1 ‘
2 |CIRCLE " Length Calculate
3 RECTANGLE - CAD Length Calculate
: Entity: j Layer: | ;l Factor: [1 ‘
Cancel
ETH 5~ T T —
0 Home Insert Page Layout P
AutoXisTable -| 3, (@ #f, W} < =2 . . . . .
% = 11. Use the same operation to insert the rectangle area calculating function. Then Click the
bl " pull-down menu “Finish” option of AutoXIsTabl as shown.
Delete Function I & fi\ 60.4¢
' Options... I B C
EE Tools... REA
2 CIRCLE 110.08
3 [RECTANGLE 60.49 & e
G g » <l 3

Create

Table =

12. Back to CAD and the table will calculate the area of the circle
and rectangle.
13. Scale the rectangle and the table data will change automatically.

OBIECTS AREA

|:| CIRCLE  [110.08

RECTANGLE|60.49

[ B |OBJECTS AREA
; CIRCLE 110.08

RECTANGLE|159.78
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GstarCAD Tools

Drawing Scale: You can set the drawing scale before drawing, when you are using other tools (for example “Line Such as Chord”
and “Modify Line width”), our software will adjust the scale automatically.

Menu: Express>GstarCAD Tools>Drawing Scale  Command Entry: SASCL
Operation steps:

1. Start the command.

2. Input a drawing ratio and enter to finish.

ey g7 |5

Rotate Cursor: The cursor can rotate anti-clockwise by 0 degree or 45 degree.

Menu: Express>GstarCAD Tools>Rotate Cursor>0 or 45 Comand: T

ENTER to use last point[Follow]<Start of line>:

Command Entry: RTCURO/RTCUR45 TAngle/ LengthTcend point>: T

Side Line:  Menu: Express>GstarCAD Tools > Rotate Cursor>Side Line
Command Entry: RTCUR1 [Specity next pont:_ B[E0 <% |

Operation steps:

1. Start the command. Fease seloce the reference line: ]
. . . Command: L X X D

2. Select the reference segment and system will align the X axis of the cursor to EMTER €0 use last point[Follow]cstart of line>:
[Angle/Length]<End point>:<Ortho on> <[ r

the selected segment.

Real Time Rotate:  Menu: Express>GstarCAD Tools>Rotate Cursor>Real Time Rotate  Command Entry: RTCUR

Operation steps:
1. After executing the command, the command line prompts as below.
2. You can use the AWSD four keys to control the cursor direction until you are satisfied and press enter.

ICommand: _rtcur
|Counterclockwise coarse (4) / clockwise coarse (D) / counterclockwise Fine Tuning (W) / clockwise Fine Tuning (S) / normal (0):0

SNAP  GRID poLaR [SURG) OTRACK  LHT

Draw Axonometric Line: Using this function can easily draw an axonometric drawing.

Menu: Express>GstarCAD Tools>Draw Axonometric Line  Command Entry: SALPL

Operation steps:
1. Start the command and input the line width value.

3. The command line will prompt as below, input corresponding options, /
you can use it to switch between 0 degree and 45 degree and you can Comand: salpl
l?!.ease enter a drawing line width: <@>Starting point
also input any angle value. Then press Enter to finish the command. back to back (u)/input angle(1)/@ degree(.)/ 45 degree(/)/<next point>:

back to back (U)/input angle(I)/@ degree(.)/ 45 degree(/)/<next point>:
back to back (U)/input angle(I)/@ degree(.)/ 45 degree(/)/<next point>:
back to back (U)/input angle(I)/@ degree(.)/ 45 degree(/)/<next point>:

Command :
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Visual Extension: Normally after extension, the extension effect will be displayed, but Visual Extension can display the effect in
real time until you confirm the position.

Menu: Express>GstarCAD Tools>Visual Extension ~ Command Entry: ETT

Operation steps: e —
1. Start the command.

Opposite corner:

2. Select the line that needs to be extended, the system will choose the nearest o -

side you clicked as extension side automatically. Comaand:
Opposite corner:
3. Move the cursor and the segment will extend in real time. r—T ey |

Normal Connect: The Normal Connect function is similar to zero distance chamfer, it can delete the lines of actual intersection
or apparent intersection parts.

Menu: Express>GstarCAD Tools>Normal Connect Command Entry: GXFILT

Operation steps: / \ / "‘._

1. Start the command. -

2. Select the first line segment. et
. The first segment:
3. Select the second line. The sacond Hna:
The first segment:
4. The result will be as shown in the picture. | command:
Flex Connect: This function can extend or cut down the line to the actual intersection or apparent intersection point.
Menu: Express>GstarCAD Tools>Flex Connect ~ Command Entry: GXFSS /_
‘m
Operation sample: -
L —
1. Start the command. Comand:
. . , Pleace chooee where. to-sake reot segments
2. Select the elongation (or shortening) of the line. Pleace select the clongation (or snorcening) of the line:

Cancel

Command :

Super Fillet: This function can not only do the fillet operation but can also unify the filleted line layer, color and line type and
the unified standard will take the first selected fillet object as reference.

Menu: Express>GstarCAD Tools>Super Fillet ~ Command Entry: SFILLET

Operation steps: ]
1. Start the command and input fillet radius. e " /\
| 8 | |

2. Choose the first segment, as shown below. After executing the command, | —

Please enter a rounded radius <1@3>:

the layer, color, line type of another line and fillet will match with the first Please chouse the First: root
Pisase ciopss $he First: voot sepmert ficlsion iayer calors Sioe Gk

segment. comsani:
3. Choose the second segment.

root segment (decision layer, color, line type):
e
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Modify Linewidth: Modify the line width you specified, if what you specified is a line and our software will convert the line to
Pline automatically and change the line width. This function is similar to the pedit function, we can use it as a shortcut version
and it is very convenient for modifying the line width.

Menu: Express>GstarCAD Tools>Modify Linewidth ~ Command Entry: LCW

Operation steps: I
1. Start the command. Q
L |

2. Select the line. opposit “Find out 2, total 2
Sel
3. Enter a new line width value and here we input “2” for example. raie 1o recopmine e P again.
o . . . Unable to recognize entry. Please try again.
4. Enter to finish and the effect will be as shown in the picture. (comand:

Cross to Break: In engineering drawings, many places need to break the cross line. If we do this the original way, it will be very
complex. Using this function breaking lines can be easily done.

Menu: Express>GstarCAD Tools>Cross to Break ~ Command Entry: CBK

Operation steps:
1. Start the command.
2. Specify the occluded line. ok

Please specify the occluded line:
Please choose the occluded(To be disconnected) line:

3. Choose the occluded (to be disconnected) line and what you selected Will e |prease choose the occluded(o be disconnected) Yine:

Please choose the occluded(To be disconnected) line:
Please choose the occluded(To be disconnected) line:

cut off aUtomatlca”y Please choose the occluded(To be disconnected) line:
4. Enter to finish the command.

|Comand:

Control Break Width: This function is used to set break width for Cross objects.

Menu: Express>GstarCAD Tools> Control Break Width .,,f",-.
Command Entry: CBKWID Ty
I."

Operation steps:
1. Start the command.
2. Enter the width of the break space.

|Command :
Enter the width of cross-quick break<5.@ee>:5

Icomanm
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Modify Text: In here you can find several tools to modify text properties.

Text Height: ~ Menu: Express tools> GstarCAD Tools>Modify Text>Text Height ~ Command Entry: TXT40

1. Start the command. SAMPLE -
2. Selecta single line text. oo

Command :

3. |npUt tEXt height Select Text (can be multi-selected, automatically filter out non-Text entities):
o g:i::: ::;:Z:::Flnd out 1, total 1
4. Press enter to finish the command. Surface-height <carriage return does not change):
Command : <l

Width Factor:  Menu: Express tools>GstarCAD Tools>Modify Text>Width Factor ~ Command Entry: TXT41

1. Start the command. SAMPLE o & iy BT

2. Select a single line text. - ________________________|

3. Input Width height ratio. i;‘}l:t t?ib; i it b

4. Press enter to finish the command. oy T et Cerriags Fbm doss ook <lges §
Command: <[

Angle:  Menu: Express tools>GstarCAD Tools>Modify Text>Angle ~ Command Entry: TXT50

1. Start the command.
2. Select a single line text. SAMPLE g

3. Input rotation angle. I

Select Text (can be multi-selected, automatically filter aut non-Text entities):
4. Press enter to finish the command. s e R SR
ﬂiﬂ:ﬂ angle <carriage return does not change>:

Command: <«

Obliguing Angle: Different to the rotation angle, after executing the command, the text will get an inclination deformation effect.

Menu: Express tools> GstarCAD Tools>Modify Text>Obliquing Angle ~ Command Entry: TXT51

SAMPLE 4.0+
1. Start the command. -
2. Select a S|ng|e ||ne text Select Text (can be multi-selected, automatically filter out non-Text entities):
Select objects:Find out 1, total 1
. Select objects:
3. |nput t||t angle E:::a:gfle <carriage return does not change>:

Opposite corner:

4. Press enter to finish the command. ey

Command :

Options Modify: You can use this function to modify all the options above.

Menu: Express tools>GstarCAD Tools>Modify Text>Options Modify ~ Command Entry: EDTXT
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Print Tools

Print PLT: Users can send PLT files to printer for printing.

Menu: Express tools>Plot Tool>Print PLT ~ Command Entry: PrintPlt

[ Goneral |
Select Printer
Operation Steps_ {#] Canon PRT 22.05 LASERINJ_|
1. Start the command. g T
. . . Status: Ready
2. Select PrintPlt.exe in the dialog box. ot
3. Double-click the PrintPlt.exe file, then the “Print” dialog box will be displayed, Foge Forge
. . . . @Al Number of copies: 1 ]
in the dialog box you can select printer or change settings. skt Corert Page
] . L i ) Pages [ [|collate jﬂjﬂ jﬂ
4. Click the OK button, the “Open” dialog box will be displayed and you can el
select the printed file.
Batch Plot Setup
. . . . . . Specify batch setup
Batch Print: Batch print drawings with the same drawing frame attribute. T 0 v e
Curtent window(21.34,253.12)267.23,6253) Rlefl’“iﬂ*x
TlAccmding to the selected info, need to plot 2 frames E@
Menu: Express tools>Plot Tool>Batch Print  Command Entry: BP Plot Setup_Oplions
Plotter Name: ‘Canon MF4400 Series UFRII LT v}
Page Name: Model Paper Size: | A4 v
Operation steps: WPEL Ve SykeTade
TR T B G G
1. Start the command. e '
2. Specify the type of frame, you can select Layer/ Block/ Polyline so that the @Center  OOffset = [0 v [IO00000
. Plot
system can recognize the frame. PitOiects: | Pittoie 7
. . . Prefix Name: Pﬁf_i E)ﬁ;r;_ded ;ﬁji Efliz..?fif:d
3. Corner select the frame you want to print, you will get a dialog box. ot {EZ\F@';&H%\Gﬂa’mméﬁa,;s.
4. Set the print Parameters, click “OK” to execute bath print. G
OFitPaper  (DFisedScale  Scale 1000000 . [1.000000
Units: iW“'“S‘e'
Apply to Layout

Arrange Frame Automatically: This function can search frames
automatically, calculate according to the size of the frame and then
arrange several drawings to a big drawing.

Output Dra... | Qu

Menu: Express tools>Plot Tool>Arrange Frame Automatically
Command Entry: ZDPT

Operation steps: ( e | mem] [ Eottnt ] Fmomtes | ’
1. tart the command, a dialog boxil popup. [T S e R e B
2. In order to get a reasonable drawing plot (i A W
arrangement, you can choose which industry
you want to use in advance. Click “Options”
and you will get a dialog box.
[(Cencel | o ] [ conca ] [ Pevew | [omom)
—_—
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3. Click “Insert files”, a “Add file Manner” dialog box will pop up, you can set the manner

you like to add to the file.

Folder: This option will add all the DWG files from the root directory to the arranged list, if
you check “File that contains subfolders” option and all the DWG files from subfolders will be

added to the arranged list.
Drawing list: Add specified LST file list.
File: Add specified DWG file.

4, After selecting, all the files will be in the list.

5. Click the “Preview” button to preview the arrangement effect. The

system will arrange the drawings intelligently according to the frame above.
6. If you are satisfied with the effect, you can click “OK”, then the system
will arrange the drawings and insert the drawing frames into the current

file.

® Folder

() Drawing list

) File

Add file Manner A

[ File that contains subfolders

==

File
AD\PROD

F\GSTARCAD\PRODUCT LINE\PLATFORM\GSTARCA.
F\GSTARCAD\PRODUCT LINE\PLATFORM\GSTARCA.
F\GSTARCAD\PRODUCT LINEVPLATFORM\GSTARCA.
FAGSTARCAD\PRODUCT LINE\PLATFORM\GSTARCA.
FAGSTARCAD\PRODUCT LINE\PLATFORM\GSTARCA.

FAGSTARCAD\PRODUCT LINE\PLATFORM\GSTARCA...
F\GSTARCAD\PRODUCT LINE\PLATFORM\GSTARCA...
F\GSTARCAD\PRODUCT LINE\PLATFORM\GSTARCA...

FAGSTARCAD\PRODUCT LINE\PLATFORM\GSTARCA...
F\GSTARCAD\PRODUCT LINE\PLATFORM\GSTARCA...
F\GSTARCAD\PRODUCT LINE\PLATFORM\GSTARCA...

HrmemeAdth | BAGCTARC AT DRNNIICT [ TNEVDI ATENBAN GETARC A 02 AX
i,

Graph Size

149838571 X ..
0X01
001
65.05255 X 13,
224236074 X
216378436 X
199.644862 X
0X25

550 X425
236.25 X625
23625 X625

Output Dra... | ~

00
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100
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on vos  1nnn

[ msetfie | [ Pemovefie | [ Ewponlit | [ Filepropeties |
Diaving Size Pags Seings
® AD Format pltter ) Other Paperlength 11890
() AT Farmat platter mm  Paperinterval 100
Scoe: 10
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