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GstarCAD8 Introduction 

GstarCAD8 is a brand new platform thought to satisfy user’s needs. GstarCAD8 adopts a new engine more agile and compatible 

with a number of innovative technologies that work bonded to make its graphic speed 3-5 times faster, accelerating operation 

performance and reaching less memory usage than previous versions. Not only the speed and performance are guaranteed but 

also the stability concept has changed radically through a new modular architecture software. These three links empower 

GstarCAD8 to boost speed and performance beyond complex tasks on huge drawings supported by outstanding stability than 

any other CAD platform.  

This section helps you get started using GstarCAD8 software by explaining how to install it and providing basic information 

about how to use it. 
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GstarCAD8 Installation 

Users can visit www.gstarcad.net to download GstarCAD8 to your computer or server.  

GstarCAD8 installshield wizard will guide the user to complete successfully the installation of the software in the operating 

system. GstarCAD8 standard and professional versions are not the same. The software will automatically distinguish according 

to the user when registering dongle or serial number. The installation steps are as follow: 

1.- Double-click the executable file downloaded             and the "Gstarcad-InstallShield Wizard" dialog box will pop 

up. Click the "Next" button to continue the installation. See figure 1-1. 

2.- The “License Agreement” dialog box is displayed. If you agree, check “I accept the terms of license agreement” and click 

the "Next" button to continue the installation. See figure 1-2. 

 

  

 

   

 

 

  Figure 1-1             Figure 1-2 

3.- The "User Information" dialog box pops up, enter your user information and click the "Next" button. See figure 1-3. 

4.- Then choose the destination path where setup will install the files and click the "Next" button as shown in Figure 1-4. 

 

 

  

 

 

 

 

 

  Figure 1-3             Figure 1-4 

http://www.gstarcad.net/
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5.- Then "The install option" dialog box pops up, you can choose between uncheck or check the VBA option. To continue with 

the installation just click the "Next" button. See figure 1-5. 

6.- Then the wizard is ready to begin the program installation. If you want to review or change any of your installation settings 

just click the "Back" button. Click the "Install" button to continue with the installation. See figure 1-6. 

7.- Then "The GstarCAD wizard" dialog box pops up. The GstarCAD wizard has successfully installed the program. Click the 

"Finish" button to exit the wizard. See figure 1-7. 

 

 

 

 

 

 

 

 

 

 

 

 Figure 1-5                 Figure 1-6 

 

 

 

 

 

 

 

 

 

 

 

 Figure 1-7 
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Starting up GstarCAD8 

The User Interface 

You can enjoy working at GstarCAD8 environment in different ways. You can display and rearrange elements like the toolbars, 

display the command bar, switch between workspaces, change the interface themes and enable the status bar. The toolbars and 

command bar can also be floated anywhere on the screen or docked as well.  

 

 

 

 

 

 

 

 

 

 

 

1.- Quick Access Toolbar:  

Display the frequently used tools like: New, Open, Save, Undo, Redo, Save As, Plot, Plot Preview and 

Help. Moreover you can customize it (adding more commands from the drop-down button) or 

showing it bellow/above the ribbon.   

                                     

2.- Workspace Switching: Switch between two workspaces (2D Drafting and GstarCAD Classic).  
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3.- Menu Bar: The menu bar is used for selecting commands by mouse instead of inputting commands by keyboard. In it you 

can find the follow menu tabs: File, Edit, View, Insert, Format, Tools, Draw, Dimension, Modify, Window, Help and Express. 

  

                                      

 

Menus and Shortcut Menus 

You can use any of the option on the Menus from the menu bar at the top of the drawing 

area. Choose one of the following methods to use a menu:                      

- On the menu bar, click a menu name to choose the menu or to expand a list of options.                                                            

- Press Alt and the key for the underlined letter in the menu name to open the 

corresponding menu item list, and then choose menu items from it. For example, to edit 

the drawing file, press <Alt+E> to open the Edit menu.  

Shortcut menus provide quick access to specific commands. A shortcut menu displays 

when you right click an object, status bar, the Model tab name, or a Layout tab name. The selections presented in the shortcut 

menu depend on what you clicked. 

 

 

 

 

 

 

Shortcuts Customize 

A faster way to invoke a command is customize its shortcut. The CUSTACC 

command allows you to customize, delete or modify existing command 

shortcuts. To access this command go through the menu bar, under tools, 

select customize and choose Shortcuts Customize. After that, the shortcut 

customize window will pop up. As you can see, there is a list of shortcuts 

command that you can easily modify, delete or even make a new one over an 

existing one.  
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If you want to create a new one, just click the New button and the 

customize command window will pop up. Then you can search the 

command or select one from the command list. For example, you can 

input “command line” and then select the requested command. Notice 

that by selecting the requested command, at the right side of the window, 

will display the command properties. After selecting the command, press 

the OK button. 

Then the set shortcut window will pop up. You can 

input the desire keyword(s). For example, you can 

input the number 1. If you want to delete a created 

shortcut command, invoke the command CUSTACC 

and then select the delete button from the Shortcut 

Customize window. 

4.- The Ribbon: The ribbon consists of several panels, which are organized into each tab according to their task label. The tools 

and controls in each panel are also available in toolbars and dialog boxes. 

     

 

Panel                      Tab           Expandable panel     Expandable tools button 

 

Tab: The ribbon is structure by tabs. Every tab displays a 

series of panels with its own tools (commands or thumbnails) 

easier to select or pick. 

Panel: The panel shows the most used tools. Some 

thumbnails has an expandable tools button that can be 

expanded in a drop-down method. In addition, most of 

panels at home tab have an expandable panel that show up more commands related. 

Expandable Panel: The expandable panel is located at the bottom of the panel. If you 

click at the bottom of the panel, more commands related will be displayed. 

 

                                                                                          

Expandable Tools Button: Some thumbnails (tools or commands at the panel) have an expandable 

tools button that can be expanded in a drop-down method. If you click this button, all related tools will 

be displayed. 
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5.- Appearance: You can manage the interface’s theme plus show/display toolbars, menu bar, file tabs and status bar.    

  

 

  

  

           

6.- Drawing Area: Your drawings are displayed in the drawing window.   

 

 

 

  

 

  

 

7.- Toolbars: Toolbars partially contain buttons that start commands. When you move your mouse or pointing device over a 

toolbar button, the tooltip displays the name of the button.  
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The Standard toolbar at the top of the drawing area contains commonly used commands such as Copy Pan and Zoom, as well 

as Microsoft Office standard commands such as New, Open, and Save. GstarCAD8 classic workspace initially displays several 

toolbars by default: 

- Draw toolbar 

- Draw order toolbar 

- Change toolbar  

- Properties toolbar 

- Layer toolbar 

- Style toolbar 

- Standard toolbar 

Displaying and Hiding Toolbars 

GstarCAD8 provides many toolbars, which you can show or hide in both classic and ribbon interfaces. You can also move and 

dock toolbars. To choose which toolbars to display: 

1.- Execute TOOLBAR command or select the option TOOLBARS from the drop-down list under Appearance button (at top right 

of the interface) to open the Toolbar dialog box. 

2.- Choose the toolbars you want to hide or display by checking/unchecking the small boxes in the dialog box, then click OK. 

 

 

 

 

 

To make floated a horizontal docked toolbar, just click and hold the 

left side of it and drag around the place you need.  

To make floated a vertical docked toolbar, just click and hold the top 

of it and drag around. To dock any toolbar, just double-click at the left 

side of it.   

Starting Commands Using Toolbars 

To start a command from a toolbar, click a command button and 

respond to the prompts. 
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8.- User Coordinate System (UCS): The icon indicates the orientation of the drawing in two dimensional space.  

  

 

           

 

 

9.- Model Space and Layout Space tabs: Click a tab to switch between the drawing of your model and a printed layout.            

   

 

 

 

 

 

 

 

10.- Command Window: The command bar is a dockable window in which you can type commands and view prompts and 

other program messages. You can move the command bar by dragging it. 

When the command bar is floating, you can drag the top or bottom of the window to change the number of lines of text it 

displays. You can dock the command bar at the top or bottom of the drawing. 
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Enter Commands on the Command Line 

Type the full command on the command line and press ENTER or 

SPACEBAR, or right-click your pointing device to start the command. 

Some commands also have abbreviated names (aliases). 

 

Specify Command Options 

Once you have entered a command on the command line, 

it displays a set of options or a dialog box. To choose a 

different option, enter one of the options in the brackets 

(either uppercase or lowercase letter is OK), and then 

press ENTER or SPACEBAR

Execute, Repeat and Cancel Commands 

To execute commands, press SPACEBAR or ENTER, or right-click your pointing device when the command names has been 

entered or responsive to prompts. If you want to repeat a command that you have just used, press ENTER or SPACEBAR. To 

cancel a command in progress, press ESC. 

 

Nesting a Command 

To use a command inside an active command, type an apostrophe before you type the command. For example, you turn on the 

object snap while you are drawing a circle, thus you can setup Object snap mode before continuing drawing. 

Command: circle > Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: 'osnap 

(Setup object snap mode as Center in Draft Settings dialog, and then close the dialog to go on performing CIRCLE command) 
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Enter System Variables on the Command Line 

System variables are available for controlling how certain 

commands work. For example, GRIDMODE is used to control the 

grid status ON or OFF. 

 

Using the Prompt History Window 

The Prompt History window displays a history of the commands 

and prompts issued since you started the current session of 

GstarCAD. 

To display or close the Prompt History window press F2. 

To view entries in the Prompt History window, just drag the scroll 

bars or use the Up (↑) and Down (↓) arrows to display previously 

used commands.  

 

Switch Dialog Boxes and Command Line 

If you enter LINETYPE on the command line, the Linetype Manager dialog box will pop up. Entering -LINETYPE on the 

command line displays the equivalent command line options. The system variables below affect the display of dialog boxes as 

well: 

-ATTDIA controls whether INSERT uses a dialog box for attribute value entry.                               

-EXPERT controls whether certain warning dialog boxes are displayed.                                        

-FILEDIA controls the display of dialog boxes used with commands that read and write files. For example, if FILEDIA is set to 1, 

OPEN displays the Open Drawing As dialog box. If FILEDIA is set to 0, OPEN displays prompts on the command line. Even 

when you set FILEDIA to 0, you can get a file dialog box displayed through entering a tilde (~) at the first prompt.  

 

Dynamic Input 

"Dynamic input" box is a floating window which appears near the 

cross cursor. It provides a convenient method for users to input 

commands or system variables dynamically and display the index 

information. When the DYN mode is turned on, a drop-down box 

will appear near the cross cursor. 
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11.- Status Bar: Display information such as the current cursor coordinates, Snap, Grid, Ortho, Polar, Osnap, Otrack and other 

settings. In addition to displaying information, the status bar is a quick way to access many features. You can click status bar 

items to make changes, and right click items to display short cut menus that allow you more choices. By default, the status bar 

is shown as the picture below: 

 

                                     

 

 

 

By doing right click mouse on an empty are of the status bar, you can show or hide commands or even change these into icons: 

   

 

  

12.- Properties Palette: You can modify the value or properties of object(s) you wanted in each column. The Properties palette 

shows all properties of the specified object. When selecting multiple objects, the Properties palette shows the command 

properties of the selected objects. If none of the object is selected, the Properties palette displays the general properties of the 

current layer, View properties as well as the UCS information. By default, double-click an object opens Properties palette if the 

Properties palette is hidden. This operation is not available when the objects are block, hatch pattern, text, multiline, external 

reference or gradient fill. 
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Customize the Drawing Environment 

In GstarCAD8 there are different elements of the working environment that can be customized to fit your needs. 

Set Interface Options 

In the Options dialog box, you can change many of the settings that affect the interface and drawing environment. 

 

 

 

 

 

 

 

 

Settings of Modifying Interface: 

Automatic Save (Open and Save tab): Save your drawing at specified time intervals. To use this option, in the Options dialog 

box, Open and Save tab, select Automatic Save and enter the interval in minutes. 
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Color (Display tab): Specify the background colors used in 

the layout and Model tabs and the color used for prompts 

and crosshair.                                                                                 

Font (Display tab): Change the fonts used in the window 

and in the text window. This setting does not affect the text 

in your drawings.  

Search Path (Files tab): Set the search path to find drawing 

support files such as text fonts, drawings, linetypes, and 

hatch patterns. 

 

 

 

 

 

 

 

 

 

 

 

Save and Restore Profiles 

Creating profiles for different users or projects and sharing profiles by importing and exporting profile files are enabled in 

GstarCAD8. By default, your current options are stored in a profile named Default. The current profile name, as well as the 

current drawing name, is displayed in the Options dialog box. 

 

 

 

 

 

 

 

GstarCAD8 stores the profile information in the system registry and saves it as a text file (an ARG file) and also organizes 

essential data and maintains changes in the registry as required. 

If you make changes to your current profile during a session and you want to save those changes in the ARG file, you must 

export the profile. When you export the profile with the current profile name, GstarCAD updates the ARG file with the new 

settings. You can re-import the profile into GstarCAD8 to update your profile settings. 
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Tool Palettes 

Tool palettes are tabbed areas within the Tool Palettes window. The items you add to a tool palette are 

called tools. You can create a tool by dragging an object onto the tool palette. In GstarCAD, blocks and 

external references (xrefs) can be dragged onto the tool palette. The new tool inserted will has the same 

properties into your drawing. Also you can create, delete, rename and customize panels by doing right 

click on it. To open the tool palettes just press CTRL+3 or Type TOOLPALETTES command. 

 

 

 

Design Center 

With Design Center, you can organize access to drawings, blocks, text styles and other drawing contents: 

-Browse for drawing content on your computer or a networked drive.                                                   

-View definition tables for named objects and then insert, attach, copy and paste the definitions into the current drawing.                                                               

-Create shortcuts to drawings and folders that you access frequently.                                                    

-Add content such as xrefs, blocks to a drawing.                                                        

-Drag drawings, blocks to a tool palette for convenient access 

Folders Tab: The following icons are displayed in this tab: networks and computers, computer drives, folders, drawings and 

related support files, Xrefs, layouts and named objects, including blocks, layers, linetypes, text styles and dimension styles 

within a drawing. 

Open Drawings: A list of currently opened 

drawings is displayed. If you click a drawing 

file and then click one of the definition tables, 

you can load the content into the content area.                                                    

History: A list of previously opened files is 

displayed. If you double-click a drawing file 

from the list, you can load the content into the 

content area. 

Favorites: If you have contents need to access quickly on a regular basis, the Design Center provides a solution to finding those. 

When you select any type of content, you can right-click and choose to add it to Favorites. In favorite folder you can save 

shortcuts to content on local drives, a network drives. The original file or folder doesn't move; but all shortcuts you create are 

stored in the Favorites folder. 
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Create, Open, Save and Recover a Drawing 

Create a Drawing 

Create a New Drawing Using Default Settings 

When the system variables FILEDIA and STARTUP are set to 1, typing NEW 

at the command bar, it opens Startup dialog box, from which you can use 

Default Setting, Template or Wizard to create a new drawing. 

You can select either imperial or metric units for the new drawing. 

Imperial measurement system: The drawing uses internal default values 

with default boundary is 12 × 9 inches. 

Metric measurement system: The drawing uses internal default values with default boundary is 429 × 297 millimeters. 

 

Create a New Drawing Using a Setup Wizard 

From the Startup dialog box, you can select "Use a Wizard" tab to create a new 

drawing by the wizard. There are two wizard options illuminated as follows: 

 

Advanced Setup Wizard:  

From this option, you can set units of measurement, precision of displayed units, and grid limits. Also specify angle settings 

such as units of measurement style, precision, direction, and orientation based on template gcadiso.dwt. 

 

 

 

 

 

 

Quick Setup Wizard: From this option, you can specify units of measurement, precision of displayed units, and grid limits 

based on template gcadiso.dwt. 



Chapter 3_ Create, Open, Save and Recover a Drawing 

17 

 

Create a New Drawing Using Template 

When you need to create several drawings with the default settings, you can 

save time by creating a template file designed to create the same drawing files 

so that you does not need to specify default settings each time you start. 

Conventions and settings commonly stored in template files include: unit type 

and precision, title blocks, borders, and logos, layer names, snap, grid, and 

ortho settings, grid limits, dimension styles, text styles and Linetypes. 

Also when the system variables FILEDIA and STARTUP are set to 1 and 0 separately, typing NEW opens Select Template dialog 

box, from which you can select the desired one or use the default template by clicking the arrowhead button next to the Open 

button. 

 

 

 

 

 

 

 

 

 

Open a Drawing 

Open a Drawing 

You can open drawing (.dwg) files, Drawing Exchange 

Format (.dxf) files and drawing template (.dwt) files. You can 

also open and check drawings that you suspect are 

damaged. 

 

To open an existing drawing:  File > Open     Command line> OPEN     Using shortcut> CTRL+O 

-In the dialog box, choose the type of file you want to open.                                                        

-Choose the folder containing the desired file.                                                           

-Choose the drawing you want to open, and then click the 

Open button or Double click on the drawing you want to 

open. 

Remark: If the drawing requires a password, enter the 

password, click OK to verify the password, and then click 

Open again. 
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Multiple Open Drawings 

You can open multiple drawings at one time. There are several methods for switching a drawing to another. 

- Acting the drawing by clicking it or using shortcut keys of <Ctrl+Tab>.                                                   

-You can change the display styles to Cascade, Title Vertically or Title Horizontally from the Window menu. You can also use 

Arrange Icons to align icons if there are several minimum drawings. 

Remark: The document switch preview function is only available after you opened three or more drawings. 

  

  

 

 

 

 

Save a Drawing 

Save a Drawing 

You save drawing files for later use. You can also set up automatic saving and backup files and save only selected objects. In 

addition, you can also save a drawing in a Drawing Exchange Format (.dxf) file or a drawing template (.dwt) file. If you created 

your drawing using a template, saving the drawing does not alter the original template. 

To save a drawing:  File > Save     Command line> SAVE     Using shortcut> CTRL+S 

  

   

 

 

 

 

Remark: When you save a drawing the first time, the program displays the Save Drawing As dialog box so that you can choose a 

directory and type a name for the drawing. 
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Save Your Drawing Automatically 

You can specify to save drawing files automatically in order to minimize the lost data once a 

problem occurs. 

If you start the automatic save option, your drawing is saved at specified time intervals. By 

default, system assigned the name filename.ac$ for temporarily saved files, filename here 

refers to current drawing name. 

 

 

Save Part of a Drawing File 

You can use BLOCK command or WBLOCK command to create a new drawing from 

part of an existing drawing. You can select entities or a block definition in your 

current drawing and save them in a new drawing file. The description also can be 

saved in the new drawing. 

 

 

 

Save to a Different Type of Drawing File 

Choose the format from Save as Type in the Save 

Drawing As dialog box, you can save a drawing to 

an earlier version of the drawing format (DWG) or 

drawing interchange format (DXF), or save a 

drawing as a template file. 

To save a different format:   

File > Save As    Command line> SAVE AS     

Using shortcut> SHIFT+CTRL+S 

 

Use Backup Files 

GstarCAD8 creates a backup file with the current drawing name and a ".bak" extension to save the previous version of the 

current drawing when launching "backup automatically" option. 
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Reduce the Time Required to Save a Drawing File 

In order to reduce the time of saving a drawing file, you can specify the incremental save 

percentage on the Open and Save tab of Options dialog box or from the ISAVEPERCENT system 

variable. 

The incremental save updates only the portions of the saved drawing file you changed. Drawing 

files will contain a percentage of potentially wasted space when you use incremental saves. 

This percentage increases after each incremental save until it reaches the specified maximum 

value, and then a full save is perform. 

Recover a Drawing 

Recover a Damaged File 

You can recover some or all of data by reverting to a backup file or using commands to find and 

correct errors if a drawing file is damaged. A drawing file may be damaged by a hardware 

failure, power outage and system crash. You had better create a backup file if the drawing is 

important.  

On the Open and Save tab of Options dialog box, you can specify the backup file are created 

when you save drawings and set the proper interval time for saving. Then a backup copy file 

with a ".bak" extension is created when you save the named drawing once again. After that, a 

backup file is always updated while you executing the command SAVE or SAVEAS. 

You can use RECOVER command to check and attempt to open a damage file.           

Then uses AUDIT command to find and correct errors. 

To open a damaged file:  File > Drawing Utilities> Recover     Command line> RECOVER 

 

   

  

                                                         

-In the dialog box at Files of Type, choose the type of 

file you want to recover.                                                        

-Choose the directory containing the damaged file.                                                     

-Choose the damaged file you want to recover and 

Click the Open button or Double click on the drawing 

you want to open. 
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To check errors for a drawing file:  File > Drawing Utilities> Audit     Command line> Audit 

  

 

 

 

 

 

 

1. To choose from the opened drawing, click on File > Drawing Utilities > Audit 

2. Input Y or N to determine whether to recover the errors that are automatically found by GstarCAD, and then press Enter. 

 

Drawing Recovery Manager 

Once terminated by hardware problems, power failure or software problems, the application is capable of backup the opened 

drawing file. At the next startup, the program starts "Drawing Recovery Manager" in which all of the auto-backup drawing files 

that have been closed accidentally will be displayed. You can open the file of your demand by double clicking at the Backup 

File list on the "Drawing Recovery", if there is any damage to the file, system attempts to recover the drawing in process of 

backup. 

When program or system stopped by accident, the drawing files need to recover are sorted into the following types. 

-Recovered drawing file saved when program fails (DWG)                                                  

-Auto saved file, so called "auto-save" file (ac$)                                                              

-Backup file (BAK)                                                                           

-Source drawing file (DWG)  
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Control the Drawing Views 

Redraw and Regenerate a Drawing 

As you work on a drawing, visual elements may remain after the completion of a command. You can remove these elements by 

refreshing, or redrawing, the display. 

To redraw (refresh) the current window display:  View > Redraw     Command line> REDRAW 

To regenerate the current window:  View > Regen     Command line> REGEN 

 

 

 

 

 

 

 

Information about drawing entities is stored in a database as floating point values, ensuring a high level of precision. 

Sometimes a drawing must be recalculated, or regenerated, from the floating point database to convert those values to the 

appropriate screen coordinates. 

 

 

Magnify a View (Zoom) 

 

You can use ZOOM command to zoom in or zoom out the 

drawing view to meet your need. You can change the 

magnification of your drawing at any time. The cursor 

changes to a magnifying glass when a zoom tool is active. 

Zoom out to reduce the magnification so you can see more 

of the drawing, or zoom in to increase the magnification so 

you can see a portion of the drawing in greater detail. 

Remark: If you are working in a layout viewport and cannot 

zoom, the layout viewport may be locked. The scale and view do not change in model space while panning or zooming in a 

locked layout viewport. 
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Zooming Methods 

To zoom, you can use any of the following methods: 

-To define the portion of the drawing to zoom, create a window.                                                          

-To zoom in real time, use the Zoom Realtime tool on the Standard toolbar.                                                 

-If you have a mouse with a wheel, rotate the wheel to zoom in and out. 

Zoom to Magnify a Specified Rectangular Area 

You can specify a rectangular area defined by two corners to display the objects within that area as large as possibly.        

The lower-left corner of the specified area becomes the lower-left corner of the new view. 

To zoom in to an area using a window:  View > Zoom> Window     Command line> ZOOM 

-Choose View > Zoom > Window                                                                

-Select one corner of the window around the area you want to magnify.                                                   

-Specify the opposite corner of the window around the area you want to magnify. 

 

 

  

 

 

 

 

Zoom in Real Time 

Realtime option zooms dynamically by moving your pointing device up or 

down. By right-clicking, you can display a shortcut menu with additional 

viewing options. 

To zoom in real time:  View > Zoom>Realtime             

Command line> RTZOOM  

-Choose View > Zoom > Realtime from the main menu.                                                               

-Hold the left mouse button, then drag the cursor forward to zoom in and 

move back to zoom out.                                              
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Displaying the Previous View of a Drawing 

After you zoom in or pan to view a portion of your drawing in greater detail, you may want to zoom back out to see the entire 

drawing. On the View > Zoom menu, the Previous tool lets you restore the previous view. Selecting this tool repeatedly steps 

back through up to 25 successive zoomed or panned views. 

Zooming to a Specific Scale 

You can increase or decrease the magnification of your view by a precise scale factor measured relative to the overall size of 

the drawing or in relation to the current display. When you change the magnification factor, the portion of the drawing located at 

the center of the current viewport remains centered on the screen. 

To zoom to a specific scale relative to the current display:  View > Zoom>Scale        Command line> ZOOM 

-Choose View > Zoom > Scale from the main menu.                                                                      

-On the Zoom toolbar, click the Zoom Scale.                                                                         

-Type ZOOM in the command line, choose the Scale option, and then press Enter.                                        

-Type the scale factor, followed by an x (such as 2x).                                                           

-Press Enter. 

 

 

 

 

 

 

 

 

 

Displaying the Entire Drawing 

ZOOM Extents option, displays a view that includes all of the objects in the drawing as large as possible. The view can display 

the objects on layers that are turned off but do not include objects on frozen layers. 

ZOOM All option, displays all of objects within either the user-defined limits or the drawing extents, whichever view is larger. 

You can use the Zoom All tool on the zoom toolbar to display an entire drawing. The Zoom Extents tool on the zoom toolbar 

displays the drawing to its extents, making the image fill the display to the greatest possible magnification. 
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Pan and View 

You can move the drawing in any direction using the pan command. Panning shifts or slides the view of the drawing 

horizontally, vertically, or diagonally. The magnification of the drawing remains the same, as does its orientation in space.   

The only change is the portion of the drawing displayed. To pan, you can use any of the following methods: 

-For precise panning, specify two points defining the magnitude and direction of the pan. The first point indicates the starting 

point of the pan. The second point indicates the amount of pan displacement relative to the first point.                 

-To pan in real time, use the Pan Realtime tool on the Standard toolbar.                                           

-If you have a mouse with a wheel, press and hold the wheel, and then move the mouse. 

To pan in real time:  View > Pan>Realtime     Command line> PAN 

-Choose View > Zoom > Realtime from the main menu.                                                     

-Move the cursor in the direction you want to pan.                                                                  

-To stop panning, press Enter, ESC or choose Exit from the shortcut menu. 

To pan using a mouse with a wheel:  

-Press and hold the wheel, and then move the mouse in the direction you 

want to pan (The MBUTTONPAN system variable controls this feature.) 

 

 

Display Multiple Views on Model Space 

When you begin a new drawing, it is displayed in a single window. You can view the drawing in a second window, or you can 

divide one window into multiple windows. You can also open and display multiple drawings. 

Set Model Space Viewports 

The viewports created on the Model tab completely fill the drawing area and do not overlap. As you make changes in one 

viewport, the others are updated simultaneously. You can do the following operations at the model space viewport: 

-Set Snap, Grid, and UCS icon modes; Pan; 

Zoom; and restore named views.                                                 

-Save orientations of UCS with individual 

viewports.                                                    

-When executing a command, you can draw 

from one viewport to another.                                                

-Name a viewport arrangement in order to you 

can reuse it on the Model tab or insert it on a 

layout tab.                        

-When you work on 3D models, is helpful 

setting up different UCS in individual viewports. 
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Working with Multiple Views of a Single Drawing 

You can open and work with several views of the same drawing simultaneously. After you divide a single window into multiple 

windows, you can control each window separately. For example, you can zoom or pan in one window without affecting the 

display in any of the other windows. As you draw, any changes you make in one window are immediately visible in the others. 

And also you can switch from one window to another at any time. 

To create multiple views:  View > Viewports     Command line> VPORTS 

-Choose View > Viewports                                                                      

-In viewports menu, choose 1, 2, 3, or 4 viewports.                                                    

-Type h if you want the horizontal orientation, or type v if you want the vertical orientation. 

To join two views:  View > Viewports> Join     Command line> VPORTS 

-Choose View > Viewports > Join                                                                  

-Click anywhere inside the window you want to keep.                                                                     

-Click anywhere inside the adjacent window you want to join to the first window. 

To restore a named window configuration: 

-Type -VPORTS system variable at the command line and press ENTER.                                                                                

-Then type Restore.                                                                                

-Then type the name of the window configuration you want to restore. 
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Working with Multiple Drawings 

With the multiple document interface, you can open and work on several drawings at one time, you can copy, cut, or paste an 

entity from one drawing to another. Each drawing appears in a drawing window, which has the following advantages: You can 

see two or more drawings side by side, and you can easily copy entities from one drawing to another. Under the Window menu, 

the following three methods that determine how drawings are arranged are provided for user's choice. 

-Cascade                                                                                      

-Tile Horizontally                                                                                            

-Tile Vertically 

 

 

 

 

 

 

 

 

 

 

View Manager 

With the view manager, you can create, set current, update 

layers, edit boundaries, and deletes named views, and 

switch quickly between each views, it is helpful to reduce 

many unnecessary view adjust operation. 

 

 

 

 

 

Specify a 3D View 

You can set a 3D view to facilitate verifying the 3D effects of the drawing, constructing and visualizing 3D models. You can 

specify a new viewpoint to create new objects or modify the existing objects. 

Set the Viewing Direction 

You view three dimensional drawings by setting the viewing direction. The viewing direction establishes the viewing position, 

When you view a drawing from the default viewpoint (0,0,1), you see a plan view of the drawing. You can change the viewing 

direction to look at the drawing from a different vantage point or to work on a three dimensional model from a different 

orientation. 
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To set a new viewing direction:                                                                 

View > 3D Views> Viewpoint Presets    Command line> DDVPOINT  

-Choose View > 3D Views > Viewpoint Presets                                                                   

-Set viewing angles at absolute to WCS and relative to UCS by moving the position of the                            

needle according to your preference. Then click OK button. 

 

To display a plan view of the current drawing: View > 3D Views> Plan View     Command line> PLAN 

-Choose View > 3D Views > Plan View from the main menu.                                                        

-It concludes three plan views: Current UCS, World UCS and Named UCS. Choose one what you want. 
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Isometric View 

You can define perspective views of a 

model to create realistic effects. Select 

predefined standard orthographic and 

isometric views by name or description. 

These views represent commonly used 

options: Top, Bottom, Front, Left, Right, 

and Back. In addition, you can set views 

from isometric options: SW (southwest) 

Isometric, SE (southeast) Isometric, NE 

(northeast) Isometric, and NW (northwest) 

Isometric. 

 

Draw 2D Isometric Views 

With Isometric Snap, you can create 2D objects that appear to be 3D solids.  

By setting Isometric Snap on the Draft Settings dialog box and turning on Snap and Grid, you can easily align objects along one 

of three isometric planes. However, although the isometric drawing looks like 3D, it is actually a 2D representation.  
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Set Isometric Grid and Snap 

By aligning along three major axes, isometric drawing simulates a 3D drawing from specified viewpoint. When the snap angle 

is set to 0, the axes of the isometric plane are 30 degrees, 90 degrees and 150 degrees. With Isometric Snap on, you can work 

on any of three isometric planes, each with a pair of associated axes. 

-Left. The left isometric plane defined by a pair of 90- and 150-degrees axes. The snap and grips align along the 90- and 

150-degree axes.                                                                                    

-Top. The top isometric plane defined by a pair of 30- and 150-degrees axes. The snap and grips align along the 30- and 

150-degrees axes.                                                                                  

-Right. The right isometric plane defined by a pair of 90- and 30-degrees axes. The snap and grips align along the 90- and 

30-degrees axes. 

 

 

 

  

 

 

 

 

In addition to using ISOPLANE command to switch isometric planes, you can also use shortcut key F5 or CTRL+E. specifying 

one of the three isometric planes results in Ortho and crosshairs to be aligned along the corresponding isometric axes. 

For example, when Ortho is on, the points you specified align along the simulated plane you are working on. Therefore, you can 

draw the top plane first, and switch to the left plane to draw another side, and then switch to the right plane to complete the 

drawing. 

 

 

 

 

 

 

 

Top plane           Left plane         Right plane 

 



Chapter 4_ Control the Drawing Views 

31 

 

Change a 3D View Dynamically 

You can view objects from any viewing direction by holding down mouse or other pointing devices and moving dynamically. 

With dynamic viewing, you can display the effects of changing viewpoint while you change the view. You can execute move or 

zoom operations as the 3D Orbit is active. When the 3D Orbit is active, you are not allowed to modify objects. To close 3D Orbit, 

press Enter, ESC or choose Exit from the shortcut menu. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Hide Lines or Shade 3D Objects 

Hides or shapes for 3D objects in the current drawing, suppresses the display of the objects (partly or entirely) that are located 

behind other objects, or generates a simply shaded image displayed in the current view. You can use HIDE command to 

remove the hidden lines to verify the current placement of these surfaces. Hiding background lines makes the display much 

clearer, but you cannot modify hidden-line or render views. 
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Add Simple Shading to 3D Objects 

Although hiding lines can enhance the drawing and clarifies the design, shading produces a more realistic image of your model. 

You can modify shaded objects as you normally would. When a shaded object is selected, the wireframe and grips appear on 

top of the shading. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Render 

Rendering creates a 2D image based on a 3D scene. It 

shades the scene's geometry using the lighting you've set 

up, the materials you've applied, and environmental 

settings such as background and fog. At a basic level, 

you can use the render command to render your model 

without applying any materials, adding any lights, or 

setting up a scene. You cannot move or adjust this light. 

  

 

Render Environment 

You can use environmental features to set up atmospheric effects or background 

images. You can enhance a rendered image by means of atmospheric effects like fog 

and depth cueing or by adding a bitmap image as a background. Fog and depth 

cueing are actually two extremes of the same effect: a white color is fog, and a black 

color is traditional depth cueing. You can use any color in between. 
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Light                                                                                                                     

 

Lighting adds the finishing touch to the scene. You can add point lights, spotlights, and distant lights and set the location and 

photometric properties of each. 

Point Light: A point light radiates light in all directions from 

its location and does not target an object.  

Spotlights: A spotlight can be directed towards an object. 

Distant Lights: Simulates the effect of sunlight and can be 

used to show how the shadows cast by a structure affect the 

surrounding area. 

Light List: Displays a list of type and light name used in 

model. Distant lights and the sun do not appear as interface 

objects in the model. 

 

Materials 

You can add materials to objects in your drawings to provide a realistic effect. In 

the context of rendering, materials describe how an object reflects or transmits 

light. Within a material, maps can simulate textures, bump effects, reflections, 

or refractions. 

 

 

Precision Tools and the Properties of Drawings 

Specify Units, Angles and Scale 

 

Specify the units of measurement you want to use, their format, and other conventions. 

 

Set the Units Format 

You can set the display format of the unit that includes: scientific, decimal, 

engineering, architectural and fractional notation. To enter architectural feet and 

inches format, you can indicate feet using the prime symbol ('), for example, 72'3. 

You do not need to specify inches by entering quotation marks ("). You can set the 

unit type and precision in the Quick Setup wizard, the Advanced Setup wizard, or the 

Units Control dialog box. These settings control how your coordinate, offset, and 

distance entries are interpreted, and how coordinates and distances are displayed. 

To open drawing units dialog:  Format > Units    Command line> UNITS 
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Set Angle Conventions 

You can specify the location for angle 0 and the positive direction for the angle measurement: clockwise or counterclockwise. 

You can also specify the format and the number of decimal fraction. 

-Specify the measurement unit and precision: The units include 

grad, radian, surveyor's unit and degree, minute and second. 

-Specify where the angle measurement starts from: east, west, 

south, north or others. For example, to enter a coordinate 

relative to the current coordinate for a property line that is 54 

feet, 7 inches long with a bearing of 60 degrees north, 12 

minutes, 6 seconds east, enter @54'7"<n60d12'6"e. 

-Specify the positive direction: counterclockwise or clockwise. 

The angle 0 can be set to any location. 

 

Setting Scale Factors 

Instead of drawing to a particular scale, you draw everything full size in the 

program. When you print your drawing, you can assign the scale at which 

the drawing is to print. Scale, however, does affect the way a few elements 

such as text, arrows, or linetypes print in your drawing. For example, when 

you draw text, you need to determine the text size so that when you print it 

later at a particular scale, the text height is correct. 

After you determine the eventual scale of your finished drawing, you can 

calculate the scale factor for the drawing as a ratio of one drawing unit to 

the actual scale unit represented by each drawing unit. 

The following table shows some standard architectural and engineering 

scale ratios and equivalent text heights required to create text that measures 

1/8 inch high when you print the drawing at the specified scale. 

You can use these scale factors to predetermine the size of your drawing to 

make sure that it fits on a specific size paper when you print it. You control 

the size of your drawing by the drawing limits. To calculate the drawing 

limits to match the size of your paper, multiply the dimensions of your 

paper size by your scale factor. 

 

  

 

 

Standard scale ratios and equivalent text heights 

Scale Scale factor Text height 

1/16" = 1'-0"  192 24" 

1/8" = 1'-0"  96 12" 

3/16" = 1'-0"  64 8" 

1/4" = 1'-0" 48 6" 

3/8" = 1'-0" 32 4" 

1/2" = 1'-0" 24 3" 

3/4" = 1'-0" 16 2" 

1" = 1'-0" 12 1.5" 

1 1/2" = 1'-0" 8 1" 

3" = 1'-0" 4 0.5" 

1" = 10' 120 15" 

1" = 20' 240 30" 

1" = 30' 360 45" 

1" = 40' 480 60" 

1" = 50' 600 75" 

1" = 60' 720 90" 

1" = 100' 1200 150" 



Chapter 5_ Precision Tools and the properties of Drawing 

35 

 

Drawing Limits 

You can specify the drawing limits that form an invisible boundary around your drawing. You can use the drawing limits to make 

sure that you do not create a drawing larger than can fit on a specific sheet of paper when printed at a specific scale. 

For example, if you plan to print your drawing at 1/8" = 1'-0" (in other words, using a scale factor of 96) on a sheet of paper 

measuring 36 inches x 24 inches, you can set drawing limits to 3,264 units wide (that is, 34 x 96) and 2,112 units high (22 x 

96), which allows a 1-inch margin around the edges of the printed image. 

To set the drawing limits:  Format > Drawing limits    

Command line> LIMITS 

-Choose Format > Drawing Limits                                                                                     

-Specify the x-coordinate and y-coordinate of the upper right 

drawing limit and the lower left drawing limit. You can also click 

Select to specify the drawing limits by selecting points in the 

drawing. 

 

Grid and Grid Snap  

The grid in GstarCAD8, is a rectangular pattern 

comprised of minor and major lines extended over the 

drawing area. Displaying grids and using grids snap 

improve the performance of regenerating. When you 

turn Snap mode on, the cursor adheres or snaps to 

the invisible grids. Grid and snap settings are effective 

tools to use in your drawing to ensure accuracy. In 

addition, the cursor can be restricted to move 

orthogonally only or guides can display on the screen 

automatically at specified polar angle increments. 

 

Change Grid and Snap Spacing 

You can turn Grid and Snap on and off and specify their spacing on the Snap 

and Grid tab at the Drafting Settings dialog box. Grid spacing does not have to 

match snap spacing. A wide grid spacing can be used as a reference while a 

closer grid spacing helps you specify points accurately. 
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Use Object Snaps 

Object snaps enable you to quickly select exact geometric points on existing 

entities without having to know the exact coordinates of those points. With 

object snaps, you can select the endpoint of a line or arc, the center point of a 

circle, the intersection of any two entities, or any other geometrically significant 

position. You can also use object snaps to draw entities that are tangent or 

perpendicular to an existing entity. 

 

Setting Object Snaps 

You can set object snaps using any of the following methods: 

-Choose Tools > Drafting Settings > Object Snap, and then click one of the 

object snap tools.                                         

-On the Object Snap toolbar, click one of the object snap tools.                                                          

-On the status bar, right-click on the Object Snap button to choose Settings.                                                

-Press and hold down the Shift key while right clicking anywhere within the 

drawing window to display the object snap shortcut menu, and then choose 

the object snap you want to set. 

 

AutoSnap Tools 

The automatic snap tool is a visual aid tool for snapping that help you see and use object snaps more efficiently. When any 

object snap is on, the system displays a marker and a tooltip when you move your cursor on over a snap point. AutoSnap turns 

on automatically when an object snap is on. By default, AutoSnap marker, tooltip and magnet are on. You can change the 

settings of AutoSnap on the Options dialog box. AutoSnap consists of the following snap tools: 

-Marker. The object snap location is displayed when the 

cursor moves over or near an object. Marker shape is 

determined by the snap it is marking. 

-Tooltip. Indicates which part of the object you are snapping 

to in a flag at the cursor location. 

-Magnet. Attracts and locks the cursor onto the nearest 

detected snap points. Provides a visual that is similar to 

snapping to a grid. 

-Aperture box. Surrounds the crosshairs and defines an area within which, when you move the cursor, system evaluates objects 

for object snaps. You can determine the aperture box is displayed or not, and the aperture box size can be changed too. 
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Use Polar Tracking and Object Snap Tracking 

Auto tracking includes polar tracking and object snap tracking. You can turn them on and off by repressing POLAR and OTRACK 

buttons on the Status Bar. When the polar tracking mode is on, the cursor moves along the specified angle. When the object 

snap tracking is on, the cursor moves along an alignment path based on the snap point. 

Polar Tracking 

When polar tracking is turned on, guides display on the screen automatically at the polar angle increment that you specify. For 

example, if you draw a line with polar tracking turned on with angle increment set as 65 degrees, the rubber-banding line 

displays at 65 degree increments. 

To enable polar tracking and specify the polar angle increment: 

1.Do one of the following:                                                                               

-Choose Tools > Drafting Settings from the main menu.                                                         

-On the Object Snap toolbar, click the Object Snap Settings button.                                         

-Type DSETTINGS in the command line and then press Enter. 

 

 

2.Switch to the Polar Tracking tab.                                                              

3.Select the Polar Tracking On checkbox.                                                                              

4.Do one of the following to specify the polar angle increments:                                              

-Select an angle from the Increment Angle drop-down list.                                              

-Mark the Additional Angles check box and click New to define a custom angle increment.                                                   

5.Click OK. 

 

 

 

 

 

 

 

Remark: To toggle polar tracking on and off at any time, click the Polar Tracking button on the status bar or press F10. 
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To draw objects using polar tracking: 

-Turn on polar tracking and start a drawing command, such as ARC, CIRCLE, or 

LINE. You can also use polar tracking with editing commands, such as COPY and 

MOVE. 

-As you move your cursor to specify points, notice the dotted polar tracking line 

that appears at the tracking angles you specified. Points you specify while the 

line is displayed conform to the polar tracking angle. 

 

Object Snap Tracking 

Object snap tracking can track along alignment paths that are based on object snap points and display tooltips at the acquired 

points. After you acquire a point, horizontal, vertical and polar alignment paths relative to the point are displayed when the 

cursor moves over their drawing path. For example, you can specify a point along a path that is based on an object endpoint or 

midpoint or an intersection between objects. 

You can also use system variable TRACKPATH to control the display of polar and object snap tracking alignment paths. 

 

 

 

 

 

 

 

 

 

 

Use Orthogonal (Ortho Mode) 

You can restrict cursor movement to the current horizontal and vertical axes so that you can draw at right angles, or 

orthogonally. For example, when the Draw Orthogonal option is enabled, lines are restricted to 0 degrees, 90 degrees, 180 

degrees, or 270 degrees. As you draw lines, the rubber banding line follows either the horizontal or vertical axis, depending on 

which axis is farthest from the cursor. When you enable the isometric snap and grid, cursor movement is restricted to 

orthogonal equivalents within the current isometric plane. Ortho mode and polar tracking cannot be on at the same time. 

Turning on Ortho turns off polar tracking. 

To fast enable orthogonal drawing: 

-Press F8 or press the ORTO button at the status bar 
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Working with Linetypes 

A linetype is a repeating pattern of dashes, dots, and blank spaces displayed in a line or a curve. You can assign linetypes to 

objects by layer, or by specifying the linetype explicitly. And also, you can specify its scale, load more linetypes into the 

program from a linetype library file, and create your own custom linetypes.  

By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, and 

BYBLOCK. You cannot rename or delete these linetypes. 

Remark: You should not confuse these linetypes with the hardware linetypes provided 

by some plotters. Both linetypes of dashes produce the similar effects. However, if you 

use both linetypes at the same time, the results can be unpredictable. 

Load Linetypes 

GstarCAD includes the linetype definition files gcad.lin and gcadiso.lin. If you select gcadiso.lin, you can use ISO pen-width 

option when you plot. If you want to know what linetypes are already available, you can display a list of linetypes that are loaded 

in the drawing or stored in an LIN (linetype definition) file. Both linetype definition files contain several complex linetypes. 

 

 

 

 

 

 

Change the Linetype of an Object 

You can change the linetype of an object by changing the linetype of the layer the object is on, reassigning the object to 

another layer, or by specifying a linetype for the object directly. 
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Set the Current Linetype 

By default, all objects are created using the current linetype, which is displayed in the Linetype Control on the Properties 

toolbar. To modify this current linetype, you can select a linetype and make it current in the Linetype Manager dialog box. If the 

current linetype is BYLAYER, objects are created using the linetype assigned to the current layer. 

If the current linetype is BYBLOCK, objects are created 

using CONTINOUS linetype until they are grouped into a 

block. When you insert the block, it acquires the current 

linetype setting. 

To make the linetype current: 

Select a linetype from the Linetype Control pull-down list 

on the Properties toolbar, which is set to the current 

linetype. 

 

Control Linetype Scale 

You can set global or individual scales for objects to control the display of linetypes. The Global Scale Factor and Current 

Object Scale are displayed in the Linetype Manager. The Global Scale Factor value is stored in the system variable LTSCALE, 

which changes the linetype scale globally for new and existing objects.  

The Current Object Scale is stored in the system variable CELTSCALE, which specifies the linetype scale for new objects. In a 

layout, you can use system variable PSLTSCALE to adjust the linetype scale in different viewports. 

Remark: Setting the linetype scale too large or too small may result in a line pattern looking like a solid line, depending on what 

the scale view is or at what scale the drawing is printed. 

To set the current individual linetype scale:  Format > Linetype    Command line> LINETYPE 

-Choose Format > Linetype                 

-Click the Show Details button.                  

-In the Current Object Scale field, type the linetype scale 

that you want to make current.                

-Click OK. 

To change the global linetype scale:   

-Choose Format > Linetype                  

-Click the Show Details button.                  

-In the Global Scale Factor field, type the global linetype 

scale that you want to change. Then click OK button.  
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Working with Layers 

Layers are like the transparent overlays you use in manual drafting. You use layers to organize different types of drawing 

information. Each object in a drawing exists on a layer. When you draw an object, it is created on the current layer. 

Create and Name Layers 

You can create an unlimited number of layers in every drawing and use those layers for organizing information. When you 

create a new layer, it is initially assigned the color white (or black, depending on your system settings) and the linetype 

CONTINUOUS. By default, a new layer is also visible. After you create and name a layer, you can change its color, linetype, 

visibility, and other properties. 

To create a new layer:  Format > Layer    Command line> LAYER 

-Choose Format > Layer                                                                          

-Click the New Layer button.                                                                                 

-Type a name for the new layer and then click 

OK button.  

To change a layer name in the current drawing:   

-Choose Format > Layer                                                                       

-In the Layer Properties Manager dialog box, 

click the name of layer you want to change.                                   

-Type a new name and click OK button. 

 

Setting the Current Layer 

When you start a drawing, objects are created in the current layer. By default, the layer 0 is set to the current layer, but you can 

also create a new one and make it current. Any subsequent objects you create are associated with the current layer and use its 

color and linetype. 

To make a layer current: 

-Choose Format > Layer                                                                       

-In the Layer Properties Manager dialog box, 

select a layer and then click the Set Current 

button to make the layer current.      

-Click OK. 

Removing Layers 

You can remove unused layers from your drawing with PURGE or by deleting the layer from the Layer Properties Manager.  
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Controlling Layer Visibility 

A layer can be visible or invisible. Objects on invisible layers are not displayed and do not print. By controlling layer visibility, 

you can turn off unnecessary information.  

To turn layers on or off:  Format > Layer    

Command line> LAYER 

-Choose Format > Layer                                                                      

-Click the icon under "On" tab in the layer list.                                                             

-Click OK button. 

 

Locking and Unlocking Layers 

Locking a layer prevents you from accidentally modifying its objects. When a layer is locked (but visible and thawed), you 

cannot edit them. If you lock the current layer, you can still add new objects to it. You can also change the linetype and color 

associated with a locked layer. Unlocking a layer restores full editing capabilities. 

To lock or unlock layers:  Format > Layer    Command line> LAYER 

-Choose Format > Layer from the main menu.                                                      

-Click the icon under "Lock" tab in the layer list.                                                             

-Click OK button. 

 

Controlling Layer Printing 

Controlling layer printing is another way you can specify which objects print in your drawing. By controlling layer printing, you 

can turn off unnecessary information during printing. When you turn off printing for a layer, objects drawn on that layer are still 

visible, but they do not print. 

To turn layer printing on or off:  Format > Layer    Command line> LAYER 

-Choose Format > Layer                                                                      

-Click the icon under "Plot" tab 

in the layer list.                                                                     

-Click OK button. 
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Setting a Layer's Print Style 

If your drawing uses named print style tables, you can specify a print style for each layer. Named print style tables contain print 

styles that you set up to control what objects look like when they print, without actually changing the objects in the drawing. If 

your drawing uses color-dependent print style tables, you cannot specify a print style for a layer. These types of print style 

tables automatically determine printing requirements by the color assigned to a layer or an object. 

To change the print style assigned to one or more layers (only in a drawing that uses named print style tables): 

Format > Layer    Command line> LAYER 

-Choose Format > Layer                                                                     

-Click the name of Plot Style in the layer list to open Select Plot 

Style dialog box, from which, you can specify the desired plot style.                                                                                           

-Click OK button. 

 

Freeze or Thaw Layers 

You can also freeze layers to improve the performance of operations such as zooming and panning or producing hidden lines or 

shaded images. When a layer is frozen, objects drawn on that layer are no longer visible. 

To freeze or thaw layers:  Format > Layer    Command line> LAYER 

-Choose Format > Layer                                                                         

-Click the icon under "Freeze" tab in the layer list.                                                             

-Click OK button. 

 

Setting the Layer Color 

Each layer in a drawing is assigned a color. GstarCAD uses the BYLAYER color as the default color setting for object creation so 

that new objects are drawn in the color of the layer on which they are inserted. 

To change the layer color:          

Format > Layer   Command line> LAYER 

-Choose Format > Layer                                                                                  

-Click the icon under "Color" tab in the layer 

list to open Select Color dialog box, from 

which, you can specify the desired color 

through index, true and color books tabs 

–Then click OK button. 
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Setting a Layer's Linetype 

Each layer uses a default linetype. Linetype determines the appearance of objects both on the screen and when printed. It's 

recommendable to assign the BYLAYER linetype to any objects that you draw on that layer. 

To change the linetype assigned to one or more layers: Format > Layer    Command line> LAYER 

-Choose Format > Layer                                                                       

-Click the Linetype name in the layer list to open Select Linetype 

dialog box, from which, you can specify the desired linetype.   

-Click OK button. 

 

Setting a Layer's Lineweight 

Each layer uses a default lineweight. Lineweights determine the thickness of objects both on the screen and when printed. All 

new layers are assigned the DEFAULT lineweight, which is .25 millimeters or .01 inches. If you want a different lineweight 

assigned to a layer, you can easily change it using Layer Properties Manager. 

To change the lineweight assigned to one or more layers:                 

Format > Layer    Command line> LAYER 

-Choose Format > Layer                                                                     

-Click the Lineweight name in the layer list to open Lineweight 

dialog box, from which, you can specify the desired lineweight.                                                                           

-Click OK button. 

 

Filter List of Layers 

You can use a layer filter to limit the display of layer names in the Layer Properties Manager. The following properties can be 

included in the filter definition: Layer names, colors, linetypes, lineweights, and plot styles. Whether layers are locked or 

unlocked, turned on or off, frozen or thawed in the current viewport or all viewports. When setting filter conditions, you can also 

use wild-card characters to filter names by name. For example, typing D* displays layer name preceded with D, just click Add 

button if the filter name has been 

specified. 

To filter list of layers:   

 

-Choose Format > Layer                                                                     

-Click the New Property Filter icon, 

located at top left of the window.                                                       

–In the Layer Filter Properties dialog 

box, under filter definition, click the tabs properties you want to filter. Then click OK button. 
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Displaying Lineweights 

Lineweights are displayed differently in paper space layout than model space. Lineweights are useful for graphical 

representations of different objects and information. 

Display Lineweights in Model Space 

In model space, a 0-value lineweight is displayed as a pixel, and other lineweights are display with a pixel width proportional to 

their real-unit value. In model space, lineweight display does not change with the zoom factor. A lineweight value that is 

represented by a width of several pixels is always displayed using the same number of pixels. In model space, press LWT 

button on the status toolbar to turn lineweight display on and off. 

 

 

 

 

 

 

 

Display Lineweights in Layouts 

In paper space (layout tab), lineweights are displayed in exact plotting width. In plot preview and paper space, lineweights are 

displayed in real-world units, and lineweight changes with the scale factor. From the Plotting Scale tab of Plot dialog box, you 

can control the lineweight plotting and scaling in a drawing. In paper space, press LWT button on the status toolbar to turn 

lineweight display on and off. This change does not affect the lineweight plotting. 
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Create Objects 

Drawings are made up of objects. In general, you draw objects by specifying points with the pointing device or by entering 

coordinate values at the command prompt. 

Draw Linear Objects 

Lines: A line consists of two points: a start point and an endpoint. You can connect a series of lines, but each line segment is 

considered a separate line object. To draw a line:  Draw > Line    Command line> LINE 

1.Choose Draw > Line from the main menu.                                                      

2.Specify the start point.                                                                   

3.Complete the first line segment by specifying the endpoint.                                                        

4.Press Enter to complete the command. 

To start a new line at the endpoint of the last line drawn, start the Line 

command again and press Enter directly at the "Specify first point:" 

prompt. 

 

Multilines: Multilines consist of several parallel lines, called elements. 

You can determine the position of elements by specifying offset from the origin of each element. By default, multiline objects 

contain two elements. You can create and save new multiline styles by yourself or modify existing mline styles. 

To draw a multi-line: Draw > Multiline    Command line> MLINE 

1.Choose Draw > Multiline from the main menu.                                                               

2.Specify the start point.                                                                            

3.Specify the endpoint.                                                                                  

4.Press Enter to complete the command. 
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Rays: A ray is a line in three dimensional space that starts at a point and extends to infinity. Because rays extend to infinity, they 

are not calculated as part of the drawing extents. The default method for drawing a ray is to select the start point of the ray and 

then specify its direction. To draw a ray:   

Draw > Ray    Command line> RAY 

1.Choose Draw > Ray from the main menu.                                                                             

2.Specify the start point and the direction.                                                                                 

3.Press Enter to complete the command. 

 

 

Construction Lines: A construction line is a line through a given point, 

oriented at a specified angle in three dimensional space and extending to 

infinity in both directions. You can also draw a construction line at a specific 

angle or at an angle relative to an existing object.        

To draw a construction line:                                     

Draw > Construction Line    Command line> XLINE 

1.Choose Draw > Construction Line from the main menu.                                                              

2.Specify a point along the line.                                                                                                      

3.Specify the direction.                                                                                                     

4.Press Enter to complete the command. 

 

 

Polylines: A polyline is a single object with connected sequence of line segments 

or/and arc segments. When you draw a polyline, you can switch to different options. 

After you draw more than one segment, you can close the polyline, undo or finish. 

To draw a polyline with straight segments:                              

Draw > Polyline    Command line> PLINE 

1.Choose Draw > Polyline from the main menu.                                                  

2.Specify the start point.                                                                    

3.Specify the endpoint of each segment.                                                         

4.Press Enter to end, or enter c (close) to close the polyline. 
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To draw a line and arc combination polyline:                                                        

Draw > Polyline    Command line> PLINE 

1.Choose Draw > Polyline from the main menu.                                                   

2.Specify the start point.                                                                   

3.Specify the endpoint.                                                                        

4.At the command prompt, choose Arc.                                                         

5.Specify the endpoint of the arc segment.                                                          

6.To complete the command, Press ENTER. 

 

To create closed polylines: Draw > Polyline    Command line> PLINE 

When creating polylines with PLINE command, the Close option is only available if no less than two line or arc segments are 

drawn. A closed polyline object is drawn if you connect the start point of the polyline to endpoint of the last line or arc segment 

with a line or arc. 

 

 

 

 

 

To create wide polylines: Draw > Polyline    Command line> PLINE 

You can draw polylines of various widths by using the Width and Halfwidth options of PLINE command. The Width and 

Halfwidth options set the width of the next polyline segments you draw. You can set the width of individual segments and make 

them taper gradually from one width to another. 
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To draw a boundary polyline: Draw > Boundary    Command line> BOUNDARY 

1.Choose Draw > Boundary from the main menu.                                                  

2.Specify the objects by doing one of the following: 

-Current viewport Define a boundary set with all entities in the 

current viewport. if this option is selected, any boundary set 

currently used will be canceled. 

-Existing set Click New button to switch to the drawing area, and 

prompt users to select objects for defining boundary sets. Press 

Enter to return to the dialog box after selection. This option is only available after selecting objects by using the New button. 

3.Select the Island Detection option.                                                            

4.Click Pick Points.                                                                           

5.In the drawing, click inside the area whose closed perimeter forms the boundary, not on the polyline itself. If desired, 

continue clicking inside additional closed perimeters.                                                   

6.To complete the selection, press Enter.                                                                         

7.In the Boundary Creation dialog box, click OK. 

 

 

 

 

 

 

 

 

 

 

Polygons: Creating polygons is a simple way to draw squares, equilateral triangles, octagons, and so on. Polygons are closed 

polylines with between 3 and 1,024 equal-length sides. 

To draw a polygon by vertex:                                

Draw > Polygon    Command line>POLYGON 

1.Choose Draw > Polygon from the main menu.                                                     

2.Type 6 to specify six sides for the polygon.                                                       

3.Specify the center of the polygon.                                                                        

4.Specify the vertex of the polygon. 

 

 



Chapter 6_ Create Objects 

50 

 

Rectangles: Rectangles are closed polylines with four sides. You draw a rectangle by specifying its opposite corners. The 

rectangle is normally aligned parallel to the current snap and grid alignment, but you can use the Rotated option to align the 

rectangle to any angle. 

To draw a rectangle:                              

Draw > Rectangle  Command line>RECTANG 

1.Do one of the following:                                                                     

-Select Draw > Rectangle on the main menu.                                                       

-Click the Rectangle tool or type RECTANG command and press 

Enter. 

2.Identify one corner of the rectangle or enter an option. Specify 

first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: 

3.Identify the opposite corner of the rectangle or enter an option. Specify other corner point or [Area/Dimensions/Rotation]: 

 

Points: You can draw a point object formatted as either a single dot or as one of 19 other possible display styles. 

To draw a point: Draw > Point    Command line>POINT 

1.Choose Draw > Point > Single Point from the main menu.                                               

2.Specify the location of the point. 

To draw several points: 

1.Choose Draw > Point > Multiple Point from the main menu.                                        

2.Specify the location of each point. 

To change the size and appearance of point objects:                                                  

Format > Point Style    Command line>DDPTYPE 

1.Choose Format > Point Style from the main menu.                                                 

2.Under Point Style, select the style you want.                                                      

3.Under Point Size, specify the point size, or choose one of the options.                                                

4.Click OK button. 

 

When you regenerate the drawing, all point objects change to reflect the new size and 

appearance settings. 
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Freehand Sketches: A freehand sketch consists of many straight line segments, created either as individual line objects or as a 

polyline. Before you begin creating a freehand sketch, you must set the length, or increment, of each segment. The smaller the 

segments, the more accurate your sketch, but segments that are too small can greatly increase the file size. 

To create a freehand sketch: 

1.On the command line, enter SKETCH and press Enter.                                                  

2.At the "Record increment" prompt, enter the minimum line segment length.                                                

3.Move the cursor to the drawing area, then click or enter p (pen)               

to begin sketching.                                                 

4.Click or enter p (pen) again to lift the pen up and stop drawing,                

so that you can move the cursor around the drawing area without drawing.                                                                             

5.Enter R (Record) at any time to write into the drawing the line you're drawing       

and those already drawn.                                                 

6.Press Enter to complete the sketch and write all lines into the drawing. 

To erase freehand sketch lines: 

1.While running the SKETCH command, enter E. If the pen was down, it moves up.                                         

2.Move the cursor to the end of the line you drew last and then move it back as far      

along the line as you want to erase.                                                                           

3.To end the erasure and return to the sketch Command prompt, enter E. If you want        

to change the current viewport while sketching, make sure the pen is up and all lines        

were written into the drawing. 

 

Draw Curved Objects 

Arcs: An arc is a portion of a circle. There are numerous ways to define an arc, the default 

method uses three pick points, a start point, a second point and an end point. Using this 

method, the arc will start at the first pick point, pass through the second point and end at the 

third point. Once you have mastered the default method try some others: 

-3 points                   -Start, Center, End        -Start, Center, Angle                     

-Start, Center, Length      -Start, End, Angle         -Start, End, Direction                                                                                                          

-Start, End, Radius         -Center, Start, End        -Center, Start, Angle                                                                                                                 

-Center, Start, Length       -Continue                                                                                                                                                                                           

To draw an arc by 3 points as sample:              

Draw > Arc>3 points   

1.Choose Draw > Arc > 3 Points from the main menu.                                     

2.Specify the start and second points.                                               

3.Specify the endpoint. 
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Circles: The default method for drawing a circle is to specify a center point and radius.                             

You can draw circles using any of following methods:                                                 

-Center, Radius   -Center, Diameter                                                                                           

-2 points        -3 points                                                                                            

-Tangent, Tangent, Radius                                                                              

-Tangent, Tangent, Tangent 

 

To draw a circle by specifying its center and radius:                                                    

Draw > Circle>Center, Radius   Command line>CIRCLE 

1.Choose Draw > Circle > Center, Radius from the main menu.                                        

2.Specify the center point.                                                                    

3.Specify the radius of the circle. 

 

 

To draw a circle tangent to existing objects:                                                        

Draw > Circle>Tan, Tan, Radius   Command line>CIRCLE 

1.Choose Draw > Circle > Tan, Tan, Radius from the main menu.                                       

2.Select the first tangent point on the object to be tangent with the circle.                                  

3.Select the second tangent point on the object to be tangent with the circle.                               

4.Specify the radius of the circle. 

 

Ellipses: The default method for drawing an ellipse is to specify the endpoints of one axis of the ellipse, and then specify a 

distance representing half the length of the second axis. The endpoints of the first axis determine the orientation of the ellipse. 

You can draw ellipses using any of the following methods:  -Center   -Axis, End   -Ellipse, Arc 

To draw an ellipse by specifying the axis and endpoints:                              

Draw > Ellipse>Axis  Command line>ELLIPSE  

1.Choose Draw > Ellipse > Axis, End from the main menu.                                           

2.Specify the first endpoint and second endpoint.                                                                

3.Specify a distance for half the length of the second axis. 
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To draw an elliptical arc by specifying the axis endpoints:                                              

Draw > Ellipse>Arc   Command line>ELLIPSE 

1.Choose Draw > Ellipse > Arc from the main menu.                                              

2.Specify the first endpoint.                                                                 

3.Specify the second endpoint.                                                              

4.Specify the half length of the other axis.                                                       

5.Specify the start angle of the arc.                                                             

6.Specify the end angle. 

 

Splines: Spline is a smooth curve that passes through a series of control points. Multiple points are required for drawing 

irregular splines than can be closed as well, so the start and endpoints are coincident and tangent. The tolerance in a spline, 

describes how precisely fits between multiple points (lower tolerance, more closely the spline fits the points). Usually there are 

two ways to create splines:                                                                     

-Create a spline converted from a polyline using Spline option of PEDIT command.                                          

-Create a spline using SPLINE command. 

To draw a spline:  Draw > Spline   Command line>SPLINE 

1.Choose Draw > Spline from the main menu.                                                    

2.Specify the first point of the spline.                                                          

3.Specify the second point of the spline.                                                         

4.Specify as many more points as you want.                                                       

5.When you have finished, press Enter.  

 

 

To draw a closed spline: Draw > Spline   Command line>SPLINE 

1.Choose Draw > Spline from the main menu.                                                    

2.Specify the first point of the spline.                                                          

3.Specify the second point of the spline.                                                         

4.Specify as many more points as you want.                                                      

5.When you have finished, on the command line, type C and press Enter.                                     

6.To complete the command, specify the tangent point. 
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Helix: Creates a 2D spiral or 3D spring. Initially, the default base radius is set to 1. 

During a drawing session, the default value for the base radius is always the previously 

entered base radius value for any solid primitive or helix. The base radius and top 

radius cannot both be set to 0. 

 

To draw a helix: Draw > Helix   Command line>HELIX 

The following prompts are displayed: Number of turns = 3 (default)  Twist = CCW (default) 

1.Specify center point of base: Specify a point 

2.Specify base radius or [Diameter] <1.0000>: Specify a base radius, enter d to specify the diameter, or press ENTER to 

specify the default base radius value 

3.Specify top radius or [Diameter] <1.0000>: Specify a top radius, enter d to specify the diameter, or press ENTER to 

specify the default top radius value 

4.Specify helix height or [Axis endpoint/Turns/turn Height/tWist] <1.0000>: Specify a helix height, or enter an option 

 

 

 

 

 

 

 

 

 

 

 

 

 

Donut: Donuts are solid, filled circles or rings created as closed, wide polyline. The system variable FILLMODE controls 

whether to fill the donut or not. FILLMODE is set to 1, creates filled donuts; if FILLMODE is set to 0, creates without filled. 

To create a donut, you specify its inside and outside diameters and its center. You can continue creating multiple copies with 

the same diameter by specifying different center points. To create solid-filled circles, just assign the same value for the inside 

radius and outside radius. 

To draw a donut: Draw > Donut   Command line>DONUT  

1.Choose Draw > Donut from the main menu.                                                    

2.Specify the inside diameter of the donut.                                                      

3.Specify the outside diameter of the donut.                                                      

4.Specify the center of the donut.                                                                     

5.Specify the center point to draw another donut, or press Enter to complete 

the command. 
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Create 3D Objects 

With 3D models, you can: View entities in three dimensions, create three-dimensional entities, edit entities in 

three-dimensional space, edit three-dimensional solids, display hidden-line and shaded views of three-dimensional entities. 

3D Thickness and Elevation: By default, the program creates new two dimensional objects with a zero elevation and thickness. 

The easiest way to create a three dimensional object is to change the elevation or thickness property of an existing two 

dimensional object. You can extrude any two dimensional object into a three dimensional object by changing the thickness of 

the object to a nonzero value. For example, a circle becomes a cylinder, a 

line becomes a three dimensional plane, and a rectangle becomes a box. 

To set the current elevation: Command line>CHANGE  

1.Type CHANGE on the command line, and then press Enter after selecting  

the two dimensional object(s).                                       

2.Enter P (Properties) and press Enter.                                                           

3.Enter E (Elev) and press Enter.                                                               

4.Specify a new elevation, and then press Enter. 

To set the current thickness:                                                                                

Command line>CHANGE 

1.Type CHANGE on the command line, and then press   

Enter after selecting the two dimensional object(s).                                       

2.Enter P (Properties) and press Enter.                                                           

3.Enter T (Thickness) and press Enter.                                                               

4.Specify a new Thickness, and then press Enter. 

 

3D Faces: You can create a three dimensional 

face, which consists of a section of a plane in 

three dimensional space. After you specify the 

fourth point, the program continues to prompt 

you for additional faces by alternating prompts 

for the third point and fourth point to allow you 

to build a complex three dimensional object. 

To create a three dimensional face: Draw > Modeling>Meshes>3D Face   Command line>3DFACE 

1.Type 3Dface on the command line.                                                           

2.Specify the first point of the three-dimensional face.                                                  

3.Specify the second, third, and fourth points.                                                    

4.Specify the third and fourth points for additional faces.                                                

5.To complete the command, press Enter. 
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Ruled Surfaces: You can create a ruled surface, which is a three-dimensional body that approximates the surface between two 

existing entities. You select the two entities that define the ruled surface. These entities can be arcs, circles, lines, points, or 

polylines. 

To create a ruled surface:                                                                      

Draw > Modeling>Meshes>Ruled Mesh   Command line>RULESURF 

1.Type RULESURF on the command line.                                                           

2.Select the first defining object.                                                                 

3.Select the second defining object. 

 

Tabulated Surface: Tabulated surface meshes are used as a serial of paralleled polygon on specified path, you should draw 

direction vector and original object before creating a tabulated surface. The objects like a line, arc, circle, ellipse, or 2D or 3D 

polyline can be used as outline curves for defining polygons. 

To create an extruded surface mesh:                                                                            

Draw > Modeling>Meshes>Tabulated Mesh    Command line>TABSURF 

1.Type TABSURF on the command line.                                                         

2.Select the object to extrude.                                                                   

3.Select the extrusion path. 

 

Revolved Surface: Use REVSURF command to create a surface of revolution by rotating a profile of the object about an axis. The 

object to be revolved can be a line, arc, circle, ellipse, elliptical arc, closed polyline, polygon, closed spline or torus. REVSURF 

is useful for surfaces with rotational symmetry. 

To create a revolved surface mesh: Draw > Modeling>Meshes>Revolved Mesh    Command line>REVSURF 

1.Type REVSURF on the command line.                                                          

2.Select the object to revolve.                                                                  

3.Select the object to be used as the axis of revolution.                                               

4.Specify the starting angle.                                                                  

5.Specify the number of degrees to revolve the object. 
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Solid Box: A solid box consists of six rectangular surface planes. The base of the box is always parallel with the xy plane of the 

current UCS. The length of the box is mapping to X axis of current UCS, and its width maps to Y axis, and height maps to Z axis. 

RECTANG or PLINE command creates a rectangle or closed polyline from which you can create a box using EXTRUDE. 

 

To create a box:                                                                             

Draw > Modeling>Box  Command line>BOX 

1.Choose Draw > Modeling > Box from the main menu.                                              

2.Specify the first corner of the base.                                                           

3.Specify the opposite corner of the base.                                                            

4.Specify the height.  

 

Solid Cone: By default, the cone's bottom lies on the XY plane of the current UCS. The cone height is parallel to the Z axis. The 

apex determines the height and orientation of the cone. You can draw a 2D circle and then use EXTRUDE to taper the circle at 

an angle along the Z axis to create a solid cone. To complete the truncation, you can subtract a box from the tip of the cone with 

the SUBTRACT command. 

To create a cone:                                                                           

Draw > Modeling>Cone   Command line>CONE 

1.Choose Draw > Modeling > Cone from the main menu.                                             

2.Specify the center of the base of the cone.                                                      

3.Specify the radius or diameter.                                                                   

4.Specify the height. 

 

Solid Cylinder: You can create cylinders defined by a circular base. The base of a cylinder is always parallel with the xy plane of 

the current UCS; the height of a cylinder is always parallel with the z axis. You can draw a circle and then use EXTRUDE to 

create a solid cylinder. 

To create a cylinder:                                                                                           

Draw > Modeling>Cylinder   Command line>CYLINDER 

1.Choose Draw > Modeling > Cylinder from the main menu.                                           

2.Specify the center of the base of the cylinder.                                                         

3.Specify the radius or diameter.                                                                             

4.Specify the height. 
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Sphere: The latitude lines of a sphere are always parallel with the xy plane of the current UCS; the central axis is always parallel 

with the z axis. You determine the size of a sphere by specifying either its radius or its diameter. 

To create a sphere: Draw > Modeling>Sphere  Command line>SPHERE 

1.Choose Draw > Modeling > Sphere from the main menu.                                            

2.Specify the center of the sphere.                                                            

3.Specify the radius or diameter. 

 

Torus: A torus is constructed by revolving a circle about a line drawn in the plane of the circle and parallel with the z axis of the 

current UCS. You determine the size of a torus by specifying its overall diameter or radius and the diameter or radius of the tube 

(the circle being revolved). 

To create a torus: Draw > Modeling>Torus  Command line>TORUS 

1.Choose Draw > Modeling > Torus from the main menu.                                             

2.Specify the center of the whole torus.                                                         

3.Specify the radius or diameter of the whole torus.                                                   

4.Specify the radius or diameter of the body of the torus. 

 

Pyramid: You can create a tetrahedron (three-sided pyramid) or a four-sided pyramid. The base of the pyramid is always 

parallel to the xy plane of the current UCS. You determine the size of the pyramid by specifying the base points and either the 

apex, the corners of the top surface, or the endpoints of the ridge. 

To create a pyramid: Draw > Modeling>Pyramid  Command line>PYRAMID 

1. Choose Draw > Modeling > Pyramid from the main menu.                                              

2. Specify the first point for the base of the pyramid.  

3. Specify the second and third points.  

4. In the prompt box, choose Tetrahedron.  

5. Specify the apex of the tetrahedron. 

 

Wedge: You can create three dimensional wedges consisting of five surface planes. You determine the size of the wedge by 

either specifying a second corner and the height; defining the wedge based on a cube having a given length; or specifying the 

length, width, and height. 

To create a wedge: Draw > Modeling>Wedge  Command line>WEDGE 

1.Choose Draw > Modeling > Wedge from the main menu.                                                  

2.Specify the first corner of the base.                                                          

3.Specify the opposite corner of the base.                                                           

4.Specify the height. 
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Solids Extrude: EXTRUDE command, extrudes the profiles of the selected object along the chosen path to create solids. The 

entities you can extrude are planar 3D faces, closed polylines, polygons, circles, ellipses, closed splines, donuts, and regions. 

You cannot extrude objects contained within a block or polylines that have crossing or self-intersecting segments. 

To create an extruded solid:                                                                      

Draw > Modeling>Extrude   Command line>EXTRUDE 

1.Choose Draw >Modeling >Extrude from the main menu.                                                

2.Select the object to extrude.                                                                 

3.Select the extrusion path, or specify the height. 

 

Solids Revolve: REVOLVE command revolves a 2D object to the specified certain angle to form solids. The revolving axis can 

be X, Y axis of current UCS as well as lines, polylines. Objects can be revolved are closed polylines, polygons, rectangles, 

circles, ellipses, regions and so on. 

To create a revolved solid: Draw > Modeling>Revolve   Command line>REVOLVE 

1.Choose Draw > Modeling > Revolve from the main menu.                                             

2.Select the object to revolve.                                                                               

3.Do one of the following to define the axis of revolution:                                              

-Specify a start point and an end point.                                                           

-Type o and press Enter to select an object.                                                        

-Type x and press Enter to select the x axis.                                                                    

-Type y and press Enter to select the y axis.                                                                 

4.Specify the angle of revolution. 

 

Creating Composite Solids: You can create composite three-dimensional solids by combining, subtracting, and finding the 

intersection of two or more solids. With UNION command, you can combine the total volume of two or more solids or two or 

more regions into a composite object. 

To combine solids:                                                                             

Modify> Solid Editing>Union   Command line>UNION 

1.Choose Modify>Solid Editing> Union from the main menu.                                         

2.Select the objects to combine. 

To subtract solids:                                                                                        

Modify>Solid Editing>Subtract   Command line>SUBTRACT 

1.Choose Modify>Solid Editing>Subtract from the main menu.                                      2.Select 

the objects to subtract from one another. 
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To intersect solids: Modify> Solid Editing>Intersect   Command line>INTERSECT 

1.Choose Modify >Solids Editing >Intersect from the main menu.                                        

2.Select the objects to intersect. 

 

Create Regions: You can convert a closed object into a two dimensional region. After you create a region, you can modify it 

using the various three dimensional tools. You can create regions from closed objects, such as polylines, polygons, circles, 

ellipses, closed splines, and donuts. 

To create a region: Draw> Region  Command line>REGION 

1.Choose Draw > Region from the main menu.                                                    

2.Select the objects to create the region and press Enter. 

Create Revision Cloud:  REVCLOUD command, creates a polyline of sequential arcs to form a cloud-shaped object. You can 

convert objects, such as a circle, ellipse, polyline, or spline, to a revision cloud. You can set the minimum and maximum 

default values for the arc lengths of a revision cloud.  

To create a revision cloud: Command line>REVCLOUD 

1.After type REVCLOUD command, specify the first point.                                                                                  

2.Guide crosshairs along cloud path.                                                                         

3.Revision cloud finished (the device point is near to first point). 

 

Create Break Line: Creates a polyline and inserts the breakline symbol. To use your own block for the breakline symbol, make 

sure that the block contains two point objects on the Defpoints layer.                                                

To create a revision cloud: Command line>BREAKLINE 

1.Type BREAKLINE on the command line.                                                         

2.Specify first and second point for breakline.                                                                 

3.Specify location for break symbol. 

                                                                                                                          

Create Wipeout: Wipeouts are created using existing polygons, closed zero-width polylines made up of only line segments, or 

new polylines that you draw while using the WIPEOUT command. 

To draw a wipeout: Draw>Wipeout  Command line>WIPEOUT 

1.Choose Draw > Wipeout from the main menu.                                                   

2.Specify the start point and endpoint of each segment.                                                

3.After specifying the last endpoint, press Enter. 
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Modify Objects 

You can easily modify the size, shape, and location of objects. You can either, enter a command first and then select the 

objects to modify, or you can select the objects first and then enter a command to modify them. 

Remove Objects: You can use ERASE command to delete objects, whatever the methods you use to select objects. To restore 

the deleted objects, use UNDO command. You can remove objects using one of the following methods: Delete objects with 

ERASE command, cut the selected objects to the clipboard, or press DELETE to remove the selected objects. 

 

Copy Objects:  You can duplicate objects within the current drawing. The default method is to create a selection set and then 

specify a base point, and a displacement point, for the copy. To copy objects at the specified distance, you can specify the 

distance directly when the Ortho Mode or Polar Tracking is on. 

Create only one copy of object one time: 

1.Choose Modify > Copy from the main menu.                                                    

2.Select the objects, and then press Enter.                                                          

3.On the command line, type O (mOde).                                                           

4.On the command line, type S (Single).                                                              

5.Specify the base and displacement point. 

Create multiple copies for selected object one time: 

1.Choose Modify > Copy from the main menu.                                                    

2.Select the objects, and then press Enter.                                                          

3.On the command line, type O (mOde).                                                           

4.On the command line, type M (Multiple).                                                              

5.Specify the base and displacement point of the first copy.                                              

6.Specify the displacement point of the next copy.                                                         

7.To complete the command, press Enter. 

 

Mirror Objects: You can specify a baseline to create a mirror image using MIRROR command. The mirror image is symmetrical 

with the original one. So if you want to create a symmetrical objects, you only need to draw a half one, then create a full one 

using MIRROR command. 

To mirror objects: 

1.Choose Modify > Mirror from the main menu.                                                          

2.Select the object, and then press Enter.                                                             

3.Specify the first and second point of the mirror line.                                                   

4.On the command line, if you want to retain the original objects, type N; if you want to delete the original objects, type Y. 
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Offset an Object: You can use the offset to copy selected objects and align them offset to the original objects at a specified 

distance. You can make offset objects using arcs, circles, ellipses, elliptical arcs, lines, two dimensional polylines, rays, and 

infinite lines. 

To make an offset copy by specifying the distance: 

1.Choose Modify > Offset from the main menu.                                                    

2.Specify the distance (select two points or enter a distance).                                           

3.Select the object to offset.                                                                 

4.Specify on which side of the object to place the parallel copy.                                          

5.Press Enter to complete the command.  

To make an offset copy passing through a point: 

1.Choose Modify > Offset from the main menu.                                                      

2.On the command line, type T (Through).                                                             

3.Select the object to offset.                                                                 

4.Specify the point for the object to pass through.                                                          

5.Press Enter to complete the command. 

 

Create an Array of Objects: You can create copies of objects that array in rectangular or polar pattern. For rectangular arrays, you 

can specify the number of rows and columns as well as the interval; for polar arrays, you can specify the number of copies of 

the objects and determine whether the copies are 

rotated. 

To create a rectangular array:  

1.Choose Modify > Array from the main menu.                                                       

2.In the Array dialog box, click Rectangular Array.                                                    

3.Click the Select Objects button, and then select 

objects to array in your drawing.                                

4.In the Array dialog box, specify the row and column 

offset distance and angle of offset.                                

5.Click OK. 

                                                     

To create a polar array: 

1.Choose Modify > Array from the main menu.                                                       

2.In the Array tab, click Polar Array.                                                              

3.Click the Select Objects button, and then select 

objects to array in your drawing.                              
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4.In the Array dialog box, choose Method and values you desired and click OK. 

Move Objects: You can move objects to a new place without changing the objects. You can perform MOVE command and then 

select object (1) to move; specify a base point (2) and Displacement point (3). The object is moved from point 2 to the point 3. 

To move entities: 

1.Choose Modify > Move from the main menu.                                                   

2.Select the objects, and then press Enter.                                                         

3.Specify the base and displacement point. 

To move an object using grips:  

1.Select the object.                                                                         

2.Click a grip to select it.                                                                     

3.Drag the object to where you want to relocate it and press Click to release. 

                                                                                                                          

Rotate Objects: You can rotate the selected objects around a specified point. You can specify the rotated angle by specifying a 

point on the drawing or entering the angle value directly. The direction that objects rotate depends on the value you enter is 

positive or negative. 

To rotate objects: 

1.Choose Modify > Rotate from the main menu.                                                   

2.Select the objects, and then press Enter.                                                       

3.Specify the base point and rotation angle. 

To rotate a selection set in reference to an Absolute Angle: 

1.Choose Modify > Rotate from the main menu.                                                    

2.Select the objects, and then press Enter.                                                        

3.Specify the base point.                                                                      

4.On the command line, type R (Reference).                                                      

5.Specify the reference and new angle. 

                                                                                           

Align Objects: You can align objects with another through move or rotation with ALIGN command. 

To align and object to other as reference: 

1.Choose Modify > Align from the main menu.                                                    

2.Select the object, and then press Enter.                                                        

3.Specify the first source point.                                                                      

4.Specify the destination point.                                                                 

5.Press Enter to finish the command.  



Chapter 7_ Modify Objects 

64 

 

Scale Objects: You can use SCALE command to scale the proportionality of the selected objects. You can type a scale factor or 

specify a base point and distance to zoom objects. A scale factor that is greater than 1 enlarges the object; and a scale factor 

that is smaller than 1 shrinks the object. 

To scale a selection set by a scale factor: 

1.Choose Modify > Scale from the main menu.                                                 

2.Select the objects, and then press Enter.                                                       

3.Specify the base point.                                                                    

4.Specify the scale factor. 

                                                                                                 

Lengthen Objects: You can change the length of entities or the included angle of arcs. The results are similar to extending and 

trimming. This command does not affect the closed entities. 

To change the length of an object by dragging: 

1.On the command line type LENGTHEN.                                                            

2.On the command line, type DY (DYnamic).                                                      

3.Select the object you want to change.                                                         

4.Specify the new endpoint or included angle. 

 

Stretch Objects: When stretching objects, you have to specify a base point and displacement point. You should use crossing 

selection to select the desired objects. With using grip edition, you can also stretch objects. 

To stretch an object: 

1.Choose Modify > Stretch from the main menu.                                                  

2.Select the objects using either a crossing window   

or a crossing polygon, and then press Enter.                     

3.Specify the base point.                                                                    

4.Specify the second point of displacement. 

To stretch an object using grips: 

1.Select the object.                                                                         

2.Click a grip to activate it.                                                                            

3.Drag the grip.                                                                                 

4.Click to release. 
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Trim Objects:  You can clip, or trim, objects so they end at one or more implied cutting edges defined by other objects. You 

can trim arcs, circles, lines, unclosed polylines, and rays. 

To trim an object: 

1.Choose Modify > Trim from the main menu.                                                     

2.Select one or more cutting edges, and then press Enter.                                                  

3.Select the object to trim.                                                                   

4.Press Enter to complete the command.  

To trim several objects using the fence selection method: 

1.Choose Modify > Trim from the main menu.                                                     

2.Select one or more cutting edges, and then press Enter.                                               

3.On the command line, type F (Fence).                                                           

4.Specify the first point of the fence.                                                             

5.Specify the second point of the fence.                                                                       

6.Press Enter to complete the command. 

                                                                                                                                          

Extend Objects: You can extend objects so that they end at a boundary defined by other objects. You can extend arcs, lines, 

two-dimensional polylines, and rays. Arcs, circles, ellipses, lines, splines, polylines, rays, infinite lines, and viewports on a 

Layout tab can act as boundary edges. 

To extend an object: 

1.Choose Modify > Extend from the main menu.                                                    

2.Select one or more objects as boundary edges, and then press Enter.                                     

3.Select the object to extend, and press Enter to finish the command. 

To extend an object to an implied boundary: 

1.Choose Modify > Extend from the main menu.                                                     

2.Select one or more boundary edges, and then press Enter.                                                

3.On the command line, type E (Edge).                                                                         

4.On the command line, type E (Extend).                                                                         

5.Select the object to extend, and press Enter to finish.  

To extend several objects using the fence selection method:  

1.Choose Modify > Extend from the main menu.                                                                  

2.Select one or more boundary edges, and then press Enter.                                             

3.On the command line, type F (Fence).                                                         

4.Specify the first and second point of the fence.                                                            

5.Press Enter to complete the command. 
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Create Breaks: You can break arcs, circles, ellipses, lines, polylines, rays, and infinite lines. When breaking entities, you must 

specify two points for the break. By default, the point you use to select the entity becomes the first break point; however, you 

can use the first break point option to select a break point different from the one that selects the entity. 

To break an object: 

1.Choose Modify > Break from the main menu.                                                    

2.Select the object.                                                                          

3.Specify the second break point. 

To select an object and then specify the two break points: 

1.Choose Modify > Break from the main menu.                                                   

2.Select the object.                                                                          

3.On the command line, type F (First point).                                                      

4.Specify the first and second break point. 

                                                                                        

Create Chamfers: You can connect two nonparallel objects by extending or trimming them and then joining them with a line to 

create a beveled edge. You can chamfer lines, polylines, rays, and infinite lines. When creating a chamfer, you can specify how 

far to trim the objects back from their intersection (distance distance method), or you can specify the length of the chamfer and 

the angle it forms along the first object (distance angle method). 

When chamfering a polyline, you can chamfer multiple segments between two selected polyline segments, or you can chamfer 

the entire polyline. 

To chamfer two objects using the distance-distance method: 

1.Choose Modify > Chamfer from the main menu.                                                     

2.On the command line, type D (Distance).                                                        

3.Specify the first chamfer distance.                                                                       

4.Specify the second chamfer distance.                                                                     

5.Select the first object to chamfer.                                                                          

6.Select the second object to chamfer.  

To chamfer two objects using the distance-angle method: 

1.Choose Modify > Chamfer from the main menu.                                                     

2.On the command line, type A (Angle).                                                        

3.Specify chamfer length on the first line.                                                          

4.Specify chamfer angle from the first line.                                                       

5.Select the first object to chamfer.                                                              

6.Select the second object to chamfer. 
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To chamfer selected vertices in a polyline: 

1.Choose Modify > Chamfer from the main menu.                                                       

2.Select one polyline segment where you want to 

begin the chamfer.                                   

3.Select the other polyline segment where you want 

to end the chamfer. 

To chamfer all vertices in a polyline: 

1.Choose Modify > Chamfer from the main menu.                                                           

2.On the command line, type P (Polyline).                                                                    

3.Select the polyline. 

 

Create Fillets: You can create a fillet using FILLET command. This command can apply to the objects such as arcs, circles, 

ellipses, lines, polylines, rays, splines or construction lines. A fillet is an arc that connects two objects smoothly and has a 

specified radius. An inside corner is called a fillet; an outside corner is called a round. Before creating fillets, you should 

ensure the distance between each vertex is long enough to accommodate the fillet radius in order to insert a fillet arc. When the 

fillet radius is set to 0, no fillet arcs are inserted. If two polyline segments are separated by one arc segments, system deletes 

this arc segment and extends the lines to intersect with each other. 

To fillet two objects: 

1.Choose Modify > Fillet from the main menu.                                                      

2.On the command line, type R (Radius).                                                            

3.Specify the fillet radius.                                                                               

4.Select the first and second object.  

                                                                                         

To fillet an entire polyline: 

1.Choose Modify > Fillet from the main menu.                                                      

2.On the command line, type P (Polyline).                                                        

3.Select the polyline. 

                                                                                                                                      

To fillet selected vertices in a polyline: 

1.Choose Modify > Fillet from the main menu.                                                     

2.Select one polyline segment where you want to 

begin the fillet.                                       

3.Select the other polyline segment where you want 

to end the fillet. 
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Trim and Extend Filleted Objects: While performing fillet, you can select Trim 

option to decide whether the selected edges are extended to the endpoints of 

fillet arcs. By default, all objects except of circles, ellipses, closed polylines 

and splines are trimmed or extended when performing filleting. 

                                                                                                                           

Fillet Line and Polyline Combinations: If the objects to fillet are a line and a 

polyline, the line or its extension must be intersecting with one of the polyline 

segments. With Trim option on, the filleted objects join with the filleted arc to 

form a new polyline. 

                                                                                                   

Fillet Parallel Lines: You can fillet parallel lines, rays, and infinite lines. The first 

entity must be a line or ray, the second entity can be a line, ray, or infinite line.  

The diameter of the fillet arc is always equal to the distance between the parallel 

entities. The current fillet radius is ignored. 

Disassociate Compound Objects: You can convert a complex entity, such as a block or polyline, from a single entity into its 

component parts. Exploding a polyline, rectangle, donut, polygon, dimension, or leader reduces it to a collection of individual 

line and arc entities that you can then modify individually. Blocks are converted to the individual entities, possibly including 

other, nested blocks that composed the original entity.  

 

 

 

 

 

 

 

 

 

With the following exceptions, exploding an entity usually has no visible effect on a drawing: 

-If the original polyline had a width, the width information is lost when you explode it.                                        

-If you explode a block containing attributes, the attributes are lost, but the original attribute definitions are retained.                    

-Colors, linetypes, lineweights, and print styles assigned BYBLOCK may be different after exploding an entity, because they will 

adopt the default color, linetype, lineweight, and print style until inserted into another block. 
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Modify Polylines: Objects such as rectangles, polygons, and donuts, as well as three dimensional objects such as pyramids, 

cylinders, and spheres, are all editable polylines. To modify a polyline, perform PEDIT command. The available options vary 

depending on whether the selected polyline is a two dimensional or three dimensional object. If the selected object is not a 

polyline, the Edit Polyline tool provides the option of turning it into one. You can convert only arcs and lines into polylines. If 

several arcs or lines are joined endpoint to endpoint, they can all be selected and turned into one polyline. 

 

 

 

 

 

 

 

 

 

Modify Multilines: You can use the methods such as common editing commands, a multiline editing command and multiline 

styles to edit multilines or their elements. You can use MLEDIT command to add or delete vertices for a multiline, to control the 

way two multilines intersected (cross and T shape that can be closed, open or merged), to add multiline style or set multilines 

from the existing multiline style, such as the number of elements, color, linetype, lineweight and the offset of each element.  
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Notes and Labels 

Create Text 

Create text, multiline text (mtext) and text that includes one or more leader lines. 

Single-Line Text: You can use TEXT command to create a single or multiline text. Each line text is an independent object which 

can be modified. Before typing text, you can specify the text style and the way to align at the prompt of creating text. 

Press ENTER if you have typed some characters, and then the command line prompts to input characters for the next row of text. 

While creating single line text, you are also enabled to extend or compress certain single line text object in specified space to 

meet with your need by means of selecting Align or Fit option from the TEXT command line prompt. 

To create text: 

1.Choose Draw > Text > Single Line Text from the main menu.                                          

2.Specify the start point for the text.                                                                

3.Specify the height of the text.                                                                 

4.Specify the text rotation angle.                                                                            

5.Type the text, and then press Enter at the end of each new line.                                            

6.To complete the command, press Enter again. 

To specify the line text alignment:  

1.Choose Draw > Text > Single Line Text from the main menu.                                           

2.On the command line, type J (Justify) and press ENTER.                                               

3.Type an alignment option BR to align text at its bottom-right corner.                                        

4.Type the text, and then press Enter at the end of each new line.                                           

5.To complete the command, press Enter again. 

 

Multiline Text: Multiline text consists of one or more lines of text or paragraphs that fit within a boundary width that you specify. 

When you create multiline text, you first determine the paragraph's boundary width by specifying the opposite corners of a 

rectangle. The multiline text automatically wraps so that it fits within this rectangle. After defining the text frame, the system 

opens the In-Place Text Editor, which is comprised of a text frame and the Text Formatting toolbar. You can type text in the text 

frame and change the style from the Text Formatting toolbar. 

To create multiline text: 

1.Choose Draw > Text > Multiline Text from the main menu.                                               

2.Select the first and second corner of the text area.                                                     

3.In the Multiline Text window, type the text you want.                                                       

4.To create paragraphs, press Enter and continue typing.  
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On the toolbar, make format changes as follows: 

1.To change the font of the selected text, select a font  

from the list.                                         

2.To change the height of the selected text, enter a new 

value in the Height box.                                

3.To apply color to the selected text, choose a color   

from the Color list.                                       

4.Click OK on the toolbar or Press <Ctrl + Enter> 

                                                         

Justify Multiline Text: You can specify the attachment point at the top left, top 

center, top right, middle left, middle center, middle right, bottom left, bottom 

center, or bottom right. The multiline text can flow left to right, right to left, top  

to bottom, or bottom to top. 

                                                       

Format Characters within Multiline Text: During creating multiline text, you can 

assign a new value to the selected objects to overlap the default setting. You can 

specify underlines, bold, color and fonts for a single or multiple characters, or 

different text height.  

                                                       

Indent Multiline Text and Use Tabs: You can control the appearance of text objects 

and create a list by specifying the tap stops and indenting text. The arrowheads 

on the ruler are used to define the indent of text (first line and paragraph). 

                                                                                       

Specify the Line Spacing: The line spacing of multiline texts is the distance 

between the baseline of one line of text and the baseline of the next line of text. 

You can right-click in the textbox and choose Paragraph to specify the desired 

line space when the cursor stays on the text frame.  

                                                                                                                                                  

Create Stacked Characters: Stacked text is text or fraction applied to mark tolerance or measure units. Before creating stacked 

text, you have to use special characters to indicate the stacked place for the selected text. The following contents present the 

special characters and illustrate how to create stacked text: 

-Slash (/): Stacks text vertically and separates them with a horizontal line.                                  

-Pound sign (#): Stacks text diagonally and separates them with a diagonal line.                                       

-Carat (^): Creates a tolerance stack, which is stacked vertically as well as not 

separated by a line. You can also use Stack button on the toolbar to create 

stacked text. 
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Work with Text Styles: The text style is applied to the text objects. You can use text style to control the text font, size, angle, 

direction and other features. By default, the current text style is STANDARD, and you have to make other text styles current when 

you want to apply them. The STANDARD text style has the following default properties: 

Setting Description 

Style name Name with up to 255 characters 

Font name File associated with font 

Big Font Special shape definition file  

Height Character height 

Width factor Expansion/compression characters 

Oblique angle Slant of the characters 

Backwards Backwards text 

Upside down Upside-down text 

Vertical Vertical/horizontal text 

To create a text style:   

1.Choose Format > Text Style from the main menu.                                                  

2.Click New, type a new text style name, and then click OK.                                             

3.Under Text Measurements, specify the Text Height, Width 

Factor, and Oblique Angle.                           

4.Under Text Font, select the name, style, you want to use.                              

5. Click Apply, and then click OK. 

 

Create Leader 

Leaders: A leader is a line or spline with arrowhead at one end, and annotations (Mtext, blocks as well as tolerance) at the other 

end. Generally, you place an arrowhead at the first point. An annotation, created as dimension text, is placed immediately 

adjacent to the last point. 

To create a leader and an annotation: 

1.Choose Dimension > Leader from the main menu.                                                

2.Specify the starting point of the leader.                                                                   

3.Specify the endpoint of the leader line segment.                                                                  

4.Specify additional leader line segment endpoints.                                                        

5.After you specify the last endpoint, press Enter.                                                         

6.Type the annotation, and press Enter to enter the next line of 

annotation text.                                             

7.Press ENTER to complete the command. 
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Modify Text 

Change Text: All of text objects can be moved, rotated, deleted and copied, just as like other objects. You can change the 

properties at the Properties panel. You have two methods to modify single-line text: 

-To modify only the content of text, use DDEDIT command.                                                

-To change text style, location, size and content, use PROPERTIES command to open Properties palette, from which, you can 

make the relevant settings. 

To edit single or multiline text: 

1.Type DDEDIT and then press Enter.                                                            

2.Select the single line or multiline text.                                                                      

3.If select the single line text, the Edit Text box will pop up, edit the text and then press Enter.                                     

4. If select the multiline text, the In-Place Text Editor will pop, edit the text according as you need.  

 

  

 

 

 

To change single or multiline text properties: 

1.Select a single line or multiline text object.                                                     

2.Right-click the selected object and then click Properties on the shortcut menu.                                      

3.In the Properties palette, enter any new text in the Text Contents, and then change 

formatting and other properties as needed.                                           

4.You can also do double-click on the multiline text to open the In-Place Text Editor, from 

which, you can modify the contents and formats of text.  
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Dimensions and Tolerances 

Dimensions indicate the measurement values of objects (e.g. length or width), 

distance or angles among objects, or the distance between feature point and the 

specified origin. You can create five basic types of dimensions: linear, angular, radial, 

diametral and ordinate. Dimensions have several distinct elements: dimension text, 

dimension lines, arrowheads, and extension lines. 

1.Dimension text: A character string that usually indicates the measurement value, 

includes prefixes, suffixes, tolerances, etc.                                                          

2.Dimension line: Indicates the direction and extent of a dimension. For linear dimensions, it displays as a line, for angular 

dimensions, it displays as an arc segment.                                                               

3.Arrowhead: Usually displayed at both end of the dimension line. You can specify various sizes and shapes for arrowheads or 

tick marks.                                                                               

4.Extension lines: Extend from the object to the dimension line, in order to define dimension ranges.  

 

Create Dimensions 

You can create dimensions by selecting the entity to dimension and specifying the dimension line location, or by specifying the 

extension line origins and the dimension line location. 

Horizontal and Vertical Dimensions: As you create linear dimensions, the system automatically applies a horizontal or vertical 

dimension depending on the specified extension line origins or the location where you select an object. However, you can 

create a dimension by specifying it be horizontal or vertical. 

To create a horizontal or vertical dimension: 

1.Choose Dimension > Linear from the main menu.                                                 

2.Press Enter, and then select the object to dimension. Or, you can specify  the 

first and second extension line origins.                                                                           

3.Specify the dimension line location. 

                                                                                          

Create Aligned Dimensions: In the aligned dimensions, the dimension line is parallel to the line passing through the extension 

line origins. The aligned dimension is also parallel to the objects you specify. The system creates the extension lines 

automatically.  

To create an aligned dimension: 

1.Choose Dimension > Aligned from the main menu.                                                

2.Press Enter, and then select the object to dimension. Or, you can specify 

the first and second extension line origins.                                                                      

3.Specify the dimension line location. 
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Create Baseline and Continued Dimensions: Both baseline and continued dimensions are multiple linear dimensions. Baseline 

dimensions are measured from the dame baseline and continued dimensions are placed end to end. Before creating either 

baseline or continued dimension, you have to create a linear, aligned, or angular dimension.                                  

To create a linear baseline dimension: 

1.Choose Dimension > Baseline from the main menu.                                              

2.Specify a second extension line origin                                                               

3.Select the next extension line origin.                                                         

4.Continue selecting extension line origins as required.                                                             

5.To end the command, press Enter twice. 

To create a linear continued dimension: 

1.Choose Dimension > Continue from the main menu.                                                 

2.To select a starting dimension, press Enter.                                                     

3.Select the next extension line origin, and then press Enter. Or press Enter, and 

then select an existing dimension to continue.                                     

5.To add continued dimensions, continue selecting extension line origins.                                     

6.To end the command, press Enter twice.  

 

Create Rotated Dimensions: You can create rotated dimensions at a rotated angle you 

specify using DIMLINEAR Rotated option. An example of a rotated dimension is shown 

in the following illustration. In this illustration, the specified angle of the rotated 

dimension is equal to the angle of the slot. 

 

Create Angular Dimensions: Angular dimensions are used to measure the angle between lines or three points. You can 

dimension objects including circles, arcs, and lines. When you create the angular dimension, you can modify the text contend 

and alignment before placing the dimension line.  

To dimension an angle between two lines: 

1.Choose Dimension > Angular from the main menu.                                                 

2.Select one line.                                                                         

3.Select the other line.                                                                     

4.Specify the dimension line location.  

To dimension an angle encompassed by an arc: 

1.Choose Dimension > Angular from the main menu.                                                    

2.Select the arc.                                                                           

3.Specify the dimension arc location. 
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Create Radial Dimensions: You can create radial dimensions for circles or arcs to measure 

their radial. The radial dimension is a line with an arrowhead that points to a circle or arc. 

To create a radial dimension: 

1.Choose Dimension > Radius from the main menu.                                                 

2.Select the arc or circle.                                                                   

3.Specify the dimension line location.  

                                                                                         

Jogged Dimension: Jogged dimension is namely jogged radius dimension, which is also called "scaled radius dimension". 

User can specify center position to place the origin of dimension for replacing center point of circle or arc within radius 

dimension. DIMJOGGED command is useful for creating dimensions in case that the center of circle or arc to be dimensioned 

is located outside the layout and can't be displayed in its actual position either. 

To create a jogged radius dimension: 

1.Choose Dimension > Jogged from the main menu.                                                 

2.Select a circle or an arc.                                                                   

3.Select center position as the dimension origin.                                                    

4.Specify a point to position the jog symbol. 

 

Create Diameter Dimensions: You can create diameter dimensions for circles or arcs to measure their diameters. Creating 

diameter dimensions resembles creating radial dimensions. You can create various diameter dimensions based on the location 

and size of circles or arc, and the settings of the dimension style. 

To create a diameter dimension: 

1.Choose Dimension > Diameter from the main menu.                                                   

2.Select the arc or circle.                                                                    

3.Specify the dimension line location.  

 

Create Ordinate Dimensions: Ordinate dimensions are used to measure the perpendicular distance from an origin point called 

the datum to a feature, such as a hole in a part. Ordinate dimensions are comprised of a leader line with an X or Y value, and 

leaders are drawn along the orthographic direction at the current UCS. 

To create an ordinate dimension: 

1.Choose Dimension > Ordinate from the main menu.                                               

2.Select the point for an ordinate dimension.                                                      

3.Specify the ordinate leader endpoint.   
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Create Quick Dimension: Creates or edits a series of dimensions quickly by typing QDIM command. 

To create a quick dimension: 

1.Choose Dimension > Quick Dimension from the main menu.                                                      

2.Select the geometry to dimension, and then press Enter.                                                      

3.On the command line, it will display "Specify dimension line position, 

or[Continuous/Staggered/Baseline/Ordinate/Radius/Diameter/datumPoint

/Edit/seTtings] <Continuous>:". You can perform the operation as 

desired. The default is Continuous. 

                                                                                                                                    

Create Arc Length Dimension: Arc length dimension is available for measuring the arc length of arc or polyline arc segment. 

GstarCAD creates arc length dimension by specifying extension line position directly after selecting arc by default. And use an 

arc symbol as arc length dimension, which is differing from linear dimension and angular dimension. 

To create an arc length dimension: 

1.Choose Dimension > Arc Length from the main menu.                                             

2.Select an arc or polyline arc segment.                                                        

3.Specify a point to position the arc length dimension.  

 

Use Dimension Styles 

You can control the appearance of dimensions by changing settings to help maintain dimensioning standards, you can store 

these settings in dimension styles. 

Dimension Styles: You can create, save, restore, and delete named dimension styles. Dimension styles provide a way for you to 

change various settings that control the appearance of dimensions. You can change the following settings:               

-Extension lines, dimension lines, arrowheads, center marks or lines, and the offsets between them.                          

-The positioning of the parts of the dimension in relation to one another and the orientation of the dimension text.          

-The content and appearance of the dimension text and units of the dimension value. 

To create a dimension style: 

1.Choose Dimension > Style from the main menu.               

2.In the Dimension Style Manager dialog box, click New.          

3.Type the name of the new dimension style, and choose which style 

started with and what kind of dimension used for. Then click Continue.                                        

5.In the New Dimension Style dialog box, change the dimension 

settings as necessary. Repeat this step for each tab, as needed.             

6.To end the command, click OK. 
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To rename a dimension style:  

1.Choose Dimension > Style from the main menu.                                                     

2.In the Styles list do one of the following:                                                                   

-Double click the required style.                                                                 

-Right click on the required style name, and then choose Rename.                                                

3.Type the new name.                                                                             

4.Click Close to exit. 

 

To delete a named dimension style: 

1.Choose Dimension > Style from the main menu.                                                     

2.In the Styles list, right click on the required style name, and then 

choose Delete.                                           

3.Click Close to close. 

 

To display information about the current style: 

1.Choose Dimension > Style from the main menu.                                                     

2.In the Dimension Style Manager dialog box, click Compare.                                             

3.In the Compare Dimension Style dialog box, choose the same dimension style 

from the Compare and With pulldown list. All properties for specified dimension 

style will be displayed.                                                

4.If you want to know the different information between two styles, choose one 

style in the Compare box, choose the other in the With box, and then you will see 

difference in the following tab.                                                      

5.Click Close to close. 
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Modify Dimension Lines: On the Line tab of the Modify Dimension 

Style dialog box, you can set the color of dimension lines, 

lineweight, ticks beyond extend line, baseline spacing, and visibility. 

Modify Extension Lines: Extension lines have the following properties: 

color, lineweight, distance beyond extension lines, offset from start 

of extension lines, and visibility. You can set these properties on the 

Line tab of the Modify Dimension Style box:                                                                                      

-The distance beyond extension lines means that how far the 

extension lines extend beyond the dimension line.                      

-Start offset is the distance between the extension line origin and the 

start of the extension line, also called extension origin offset. 

 

Choose Dimension Arrowheads: You can control the appearance and size of arrowheads or hook marks placed at the ends of 

dimension lines. You can specify different arrowheads for both ends 

of a dimension or leader lines. The First arrow is toward the first 

extension line; The Second arrow is toward the second extension line. 

To choose an arrowhead: 

1.Choose Dimension > Style from the main menu.                                                        

2.In the Dimension Style Manager dialog box, select the style you 

want to change and click Modify button.                   

3.In the Modify Dimension Style dialog box, click the Symbols and 

Arrows tab.                                              

4.Make your selections under the Arrowheads.                                                           

5.Click OK and then choose CLOSE to exit. 

                                                                                                                                  

Fit Dimension Text within Extension Lines: When there is no enough space between extension lines to accept both of dimension 

text and arrowheads, you have to adjust one or both of their placement. By default, the system fits them best depending on the 

available space. You can specify other methods to place them on the 

Adjust tab of the Modify Dimension Style dialog box.  

To format dimensions: 

1.Choose Dimension > Style.                                                                   

2.In the Dimension Style Manager dialog box, select the style you wish 

to change and choose Modify.                                

3.In the Modify Dimension Style dialog box, click the Adjust tab.                                           

4.Under Fit Options and Text Placement, select an option.         

5.Click OK and choose Close to exit. 
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Fit Diameter Dimension Text: You can create various diameter dimensions based on text placement, fit options and the selection 

of "Always keep text between ext lines" option on the Adjust tab. 

 

 

 

 

 

                                                                                                                           

Align Dimension Text: Whether the text is inside or outside the extension line, it has no effect on the justification of dimension 

text. You can choose whether the text is align with the 

dimension lines or remains horizontal. 

To align dimension text with the dimension line: 

1.Choose Dimension > Style.                                                                   

2.In the Dimension Style Manager dialog box, select 

the style you wish to change and choose Modify.                                

3.In the Modify Dimension Style dialog box, click the 

Text tab.                                                                                           

4.Make your selections.                                                                                   

5.Click OK and choose Close to exit. 

 

Position Dimension Text Vertically:               

The vertical text placement is the position of the 

text relative to the dimension. You can place text 

above, below, or centered within the dimension 

line, or use the JIS dimensions. 

 

Position Dimension Text Horizontally:             

The position of text along the horizon is relation 

to the extension lines. The settings include 

Centered, At Ext Line 1, At Ext Line 2, Over Ext 

Line1, and Over Ext Line2.  
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Dimension Units: You can determine the appearance and format of the primary and alternate dimension units. You can set the 

primary units for linear and angular dimensions, including unit format, numeric precision and so on. These settings control the 

display of dimension values. 

To round off dimensions: 

1.Choose Dimension > Style from the main menu.                                                    

2.In the Dimension Style Manager dialog box, select 

the style you wish to change and choose Modify.                  

3.In the Modify Dimension Style dialog box, click the 

Primary Units tab.                                      

4.In the Linear Dimensions and Angular Dimensions 

fields, type or select the nearest value to which you 

want to round off dimensions.                                                                                  

5.Click OK and choose Close to exit. 

 

Alternate Units: You can create a dimension in two systems of measurement simultaneously in a drawing. This feature is helpful 

when you want to add feet and inches dimensions in a drawing created using metric units. The alternative units appear in a 

square brackets ([]) in the dimension text. Alternative units can be applied to linear dimensions only. The precision for alternate 

units determines the number of decimal places. 

To create an alternate dimension: 

1.Choose Dimension > Style.                                                                      

2.In the Dimension Style Manager dialog 

box, select the style you wish to change and 

choose Modify.                             

3.In the Modify Dimension Style dialog box, 

click the Alternate Units tab.                                   

4.Click the Display Alternate Units check 

box.                                                       

5.Make your selections.                                                                              

6.Click OK and choose Close to exit. 

 

Display Lateral Tolerances: Lateral tolerance represents a value that the amount a measured distance can vary. You can control 

the degree of accuracy needed for a future by specifying tolerances in manufacturing. These dimension tolerances indicate the 

largest and smallest permissible size. You can also apply geometric tolerances to indicate deviations of form, profile, location, 

orientation, and runout. 
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Deviation tolerances represent with the plus and minus values that are appended to the dimension values. If the deviation 

tolerances are equal, the ± signs precede them and they are known as symmetrical. Otherwise, the plus value locates above 

the minus value.  

The vertical placement of tolerance values that is relative to the main dimension text can be specified. For example, you can 

align the tolerances with the top, middle, or bottom of the dimension text. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Set the Scale for Dimensions: Setting dimension scale depends on the method you use to lay out and plot drawings. Dimension 

scale has effects on the size of dimension geometry relative to the objects in the drawing. In addition to text height and 

arrowhead size, dimension scale affects offsets in dimension as well, such as the extension line origin offset. When you create 

dimensions, it's recommended to set the size and offset to values that represent their actual plotted size. However, the 

tolerances, measured lengths, coordinates, and angles cannot be applied to the overall scale factor. The method of creating 

dimensions in a drawing layout is shown as follows: 

-Dimension in model space for plotting in model space. If you want to create dimensions that are scaled correctly for plotting, 

you have to set the system variable DIMSCALE to the inverse of the desired plot scale. For example, if the plot scale is 1/4, you 

have to set DIMSCALE to 4. 

-Dimension in model space for plotting in paper space. If you want to create dimensions that are scaled automatically for 

display in a paper space layout, you have to set the DIMSCALE to 0. This method is useful when you encounter the following 

situations: the dimensions in a drawing need to be referenced by other drawings (xrefs); when you create isometric dimensions 

in 3D isometric views. To prevent the dimensions in one layout viewport from being displayed in other layout viewports, it's 

recommended to create a dimensioning layer for each layout viewport that is frozen in all other layout viewports. 

-Dimension in layouts. You can create dimensions in paper space by selecting model space objects or by specifying object 

snap locations on model space objects. The dimensions created in a paper space layout do not need additional scaling: there is 

no need to change the default value of DIMLFAC and DIMSCALE. 
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Modify Existing Dimensions 

You can modify all components of the existing dimension objects in a drawing either individually or by using dimension styles. 

 

Modify Dimension Style:        

You can modify all of properties of 

the existing dimension objects in a 

drawing using dimension styles. 

You can also create a dimension 

style override to temporarily 

change a dimensioning system 

variable without changing the 

current dimension style. If a 

dimension style is changed, the 

dimension associated with that 

dimension style updates 

automatically. 

 

Make Dimensions Oblique: Extension lines are normally created at a perpendicular 

angle to the dimension line. You can change the angle of the extension lines, 

however, so that they tilt relative to the dimension line. 

To make oblique extension lines: 

1.Choose Dimension > Oblique from the main menu.                                                

2.Select the linear dimension, and then press Enter.                                                             

3.Type the obliquing angle, and then press Enter. 

Remark: To align the oblique angle if you don't know the exact measurement, use 

snaps to pick two points on the entity. 

Dimension Jogged Linear: The DIMJOGLINE command is available for 

adding or removing jog symbol for linear dimensions. The jog symbol is 

default to be placed at the center point between first extension line and 

text. To relocate jog symbol, you can adjust the position of dimension 

text or specify new position to locate jog after reselecting dimension. 

To add a jog to linear dimension: 

1.Choose Dimension > Jogged Linear from the main menu.                                             

2.Select a linear dimension.                                                                    

3.Specify a point on the dimension line to determine the jog symbol, or 

press ENTER directly to position the jog symbol in default place. 
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Dimension Inspection: Dimension inspection is created to transmit the frequency of inspecting the part being dimensioned, the 

dimension value and parts tolerance are ensured to be within specified range. Dimension inspection is composed by a frame 

and internal text and contains utmost three kinds of information field: inspection tag, dimension value and inspection rate. 

Inspection tag, used for mark the text of dimension inspection is located at the left side within the inspection frame.                   

Dimension value is the value before adding dimension inspection, which is located at the central part of the inspection 

dimension including tolerance, text and measurement value.                                                 

Inspection rate is expressed by percentage, which is located at the right side within the inspection frame, indicates required 

frequency of the part being created. 

To create an inspection dimension: 

1.Choose Dimension > Inspect from the main menu.                                                   

2.In the Inspection Dimension dialog box, click Select Dimensions button.                                  

3.Select dimensions to add dimension inspection, and then press ENTER to finish 

selection and return to the dialog box.                                                                

4.Select a shape for frame from the Shape option.                                                      

5.Click Label option to input label in the text box.                                                             

6.Click Inspection Rate option to input a value in the text box.                                                

7.Click OK. 

To remove an inspection dimension: 

1.Choose Dimension > Inspect from the main menu.                                                   

2.In the Inspection Dimension dialog box, click Select Dimensions button.                                    

3.Select dimensions to remove dimension inspection, and then press ENTER to 

finish selection and return to the dialog box. 4.Click Remove Inspection button.                                                                 

5.Click OK. 

 

Adjust Dimension Space: Once you have created multiple paralleled linear dimensions or angular dimensions, you can adjust 

the space among these paralleled lines with an equal value either default or specified. DIMSPACE command adjust the space 

among paralleled linear or 

angular dimensions or 

overlapped dimensions 

automatically in case that the 

original space is not equal 

values. If you set the space 

value to 0 when adjusting space 

among dimensions, you can 

align selected dimensions at the 

dimension line as well. 
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Add Geometric Tolerances 

Geometric tolerances show acceptable deviations of form, profile, orientation, location, and runout of a feature. You add 

geometric tolerances in feature control frames. These frames contain all the tolerance information for a single dimension. 

Geometric tolerances can be created with or without leader lines, you can create them with TOLERANCE or LEADER 

command. 

A feature control frame consists of two or more components. The 

first feature control frame contains a symbol that represents the 

geometric characteristic to which a tolerance is being applied, for 

example, location, profile, form, orientation, or runout. Form 

tolerances control straightness, flatness, circularity and 

cylindricity; profiles control line and surface. In the illustration, 

the characteristic is position. 

 

 

  

Geometric Tolerance Dialog Box: Specifies the symbols and values for a feature control frame. 

 

1. Geometric Characteristics symbol (menu) 

2. Tolerance Zone form (toggle) 

3. Tolerance zone value 

4. Material condition symbol (menu) 

5. Datum reference 1 of 3 

6. Datum reference 2 of 3 

7. Projected tolerance zone symbol (toogle) 

8. Projected tolerance zone value 

9. Datum identifier 

 

 

Geometric Tolerance Symbols: The geometric tolerance symbols and their characteristics are shown in the following. 

 

1. Position (Location) 

2. Concentricity or Coaxiality (Location) 

3. Symmetry (Location) 

4. Parallelism (Orientation) 

5. Perpendicularity (Orientation) 

6. Angularity (Orientation) 

7. Cylindricity (Orientation) 

8. Flatness (Orientation) 

9. Circularity or roundness (Form) 

10. Straightness (Form) 

11. Profile of a surface (Profile) 

12. Profile of a line (Profile) 

13. Circular runout (Runout) 

14. Total runout (Runout) 
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Material Conditions: Depending on control type, you can add a diameter symbol prior to the tolerance value, and specify a 

material condition symbol behind this value. You can apply material conditions to features that can vary in size.  

Datum Reference Frames: A datum reference consists of values and modifying symbols. A datum is a theoretically exact 

geometric reference that measures and verifies a theoretically exact point, axis, or plane. The system provides up to three datum 

reference letters and relative symbols followed by the tolerance value. 

Projected Tolerance Zones: Projected tolerance zones control the height of the fixed perpendicular part of the extension area, 

and control tolerance accuracy by positional tolerances. Before you set the symbol to projected tolerance zones, you set a 

height value to specify the minimum projected tolerance zone. 

Composite Tolerances: A composite tolerance consists of two tolerances that applied to the same geometric characteristic of a 

feature or for features that have different datum requirements. Before you create a dimension and add a composite tolerance for 

a drawing, you have to specify the first line of a feature control frame and then choose the same geometric characteristic 

symbol for the second line of the feature control frame. The specified geometric symbol compartment is extended over both 

lines. Then you can create a second line of tolerance symbols. 

To add a geometric tolerance: 

1.Choose Dimension > Tolerance from the main menu.                                                             

2.In the Geometric Tolerance dialog box, click the first square under Sym and select a symbol to insert.                    

3.Under Tolerance 1, click the first black box to insert a diameter symbol.                                     

4.In the Text box, type the first tolerance value.                                                        

5.To add a material condition, click the second black box and click a symbol to insert it.                                                                                

6.Under Tolerance 2, repeat steps 3 through 5 to add a second tolerance value.                                  

7.Under Datum 1, Datum 2 and Datum 3, enter the datum reference letter.                                         

8.Click the black box to insert a material condition symbol for each datum reference.                                 

9.In the Height box, type a projected tolerance zone height value, if appropriate.                                  

10.To insert a projected tolerance zone symbol, click the Projected Tolerance Zone box.                            

11.In the Datum Identifier box, add a datum value and then click OK.                                             

12.In the drawing, specify the location of the feature frame. 
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Blocks, Attribute and Xrefs 

Create and Insert Blocks 

Usually, blocks are several objects combined into one that you can insert into a drawing and manipulate as a single object. 

Blocks can help you better organize your work, quickly create and revise drawings, and reduce drawing file size. 

Create Blocks: Usually, blocks are several objects combined into one that you can insert into a drawing and manipulate as a 

single object. A block can consist of visible objects such as lines, arcs, and circles, as well as visible or invisible data called 

attributes. Blocks are stored as part of the drawing file. You can use several methods to create blocks: 

-Combine objects to create a block definition in your current 

drawing.                                        

-Create a drawing file and later insert it as a block in other 

drawings. 

To create a block for use within a current drawing: 

1.Choose Draw>Block> Make from the main menu.                

2.In the Block Definition dialog box, enter a block name in the 

Name box.                                               

3.Click Pick point button to specify the insertion point for the    

block in the drawing area.                               

4.Click Select objects button to select the objects for the block,    

then press Enter after selection. Then click OK button.  

 

                                                                                                     

Create Nested Blocks: You can define blocks and other blocks as nested blocks so as to simplify the organization of 

complicated blocks. With nested blocks, you can build a single block out of several components. But you should notice that 

blocks that reference themselves cannot be inserted. 
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Create Drawing Files for Use as Blocks: You can create a block as a separate drawing file that you can insert into other 

drawings. 

To save a block as a separate drawing file: 

1.On the command line, type WBLOCK.                          

2. Under Source area, choose one of the following: 

-Block: Saves existing block object to a separate drawing file.                         

-Entire drawing: Saves the entire drawing to a separate drawing file.                              

-Objects: Saves those objects you select to a separate drawing file. 

3. Under Destination area, type the name of the drawing file you want to 

create and choose the saved path, click OK to save. 

                                                                                            

Change the Base Point of Drawings to Be Used as Blocks: When inserting a drawing file into another drawing as a block, by 

default, system uses the origin (0,0,0) of WCS as the base insertion point. To specify different insertion point, you can use 

BASE command. Next time you insert the same block, system uses the new insertion point by default. 

Update Changes in the Original Drawing: Once the drawing file has been inserted into another drawing as a block, the original 

drawing changes as well. But the block having been inserted will not change. If the block happens to change along with the 

original drawing, you should attach it as external reference but not as a block. 

Use Paper Space Objects in Blocks: Objects created in paper space are not contained in the block when it is being inserted into 

the drawing. You can convert the objects in paper space as block or save as an individual drawing file before inserting into 

other drawings. 

Insert Blocks: You can insert blocks and other drawings into the current drawing. When you insert a block, it is treated as a 

single object. When you insert a drawing, it is added to the current drawing as a block. You can then insert multiple instances 

of the block without reloading the original drawing file. If you change the original drawing file, those changes have no effect on 

the current drawing unless you redefine the block by reinserting the changed drawing. 

To insert a block: 

1.Choose Insert > Block from the main menu.                                                                

2.In the Insert Block dialog box, under Insert, click Block 

Name.                                    

3.In the Name box, select the name of the block you want 

to insert.                                        

4.If you want to use the pointing device to specify the 

insertion point, scale, and rotation, select Specify 

On-Screen. Otherwise, enter values in the Insertion Point, 

Scale, and Rotation boxes.                                                                                   

5. Click OK to insert.  
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To insert an entire drawing into the current drawing: 

1.Choose Insert > Block from the main menu.               

2.Click Browse to specify the file from the Insert Block dialog 

box.                                            

3.You can use the default insertion point, scale, and rotation 

or select Specify On-Screen and enter values in the Insertion 

Point, Scale, and Rotation boxes.                       

4.If you want the objects in the block to be inserted as 

individual objects instead of as a single block, select Explode. 

Precondition is the block you created is allowed to explode.                                 

5.Click OK to insert. 

 

Modify a Block Definition: You can redefine all instances of a block within the current drawing. To redefine a block that was 

created in the current drawing, you create a new block using the same name. You can update all the blocks in the current 

drawing by redefining the block. If the block was inserted from a separate drawing file that was subsequently updated, reinsert 

that block to update all other instances in the current drawing. 

To redefine a block in the current drawing:  

1.Choose Draw > Block > Make from the main menu.     

2.In the Block Definition dialog box, type the name of the block 

you want to redefine in the Name box.                      

3.Click Pick point button to specify a point as the insertion 

point for the block in the drawing area.                         

4.Click Select objects button to select the objects for the block, 

and then press Enter after selection.                      

5.Click OK.                                          

6.Click Yes in the prompt box that displays to redefine the 

block in the current drawing.  

                                                                                       

Remove Block Definitions: Too many block definitions in a 

drawing file may affect the drawing size. To reduce the size 

of a drawing, you can remove unused block definitions. 

Erasing a block reference from a drawing may delete the 

block reference but retain the block definitions in the block 

definition table. Using PURGE command can help 

removing unused block references from your drawing in 

order to reduce the drawing size. You should erase all 

references from a block before you can purge the block 

definition. 
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Define and Use Block Attributes: An attribute is a particular object that you can save as part of a block definition. Attributes 

consist of text-based data. You can use attributes to track such things as part numbers and prices. Attribute values are either 

fixed or variable. 

To define an attribute: 

1.Choose Draw>Block> Define Attributes from the main menu.      

2.Under the Attribute, type the tag, prompt, and default text. 

3.Under Insertion Point, specify the location of the attribute, or 

click Specify on-screen to select a point in the drawing.            

4.Under Mode, select the optional attribute modes.              

5.Under Text Settings, specify the text characteristics.                   

6.To add the attribute to the drawing, do one of the following:                      

-Click Define to add the attribute and keep the dialog box active 

so you can define another attribute.                                 

-Click Define and Exit to add the attribute and end the command. 

To edit an attribute definition: 

1.On the command line, type DDEDIT.                     

2.Select the attribute definition text to edit.                       

3.Modify the attribute tag, prompt and default in the Edit Attribute 

Definition that displays.                                              

4.Click OK. 

 

Modify Block Attributes: You can use the Block Attribute Manager 

to modify attributes in block definitions. For example, you can 

modify the following items:  

-Attributes of blocks can be displayed after modification.                                               

-Text properties that define how attribute text is displayed in the 

drawing.                                             

-Properties that define the layer that the attribute is on and the 

attribute line's color, weight, and type 

                                                                                                  

To edit an attribute attached to a block: 

1.On the command line, type DDATTE.                                                            

2.Select the block to edit. The Edit Attributes dialog box displays all the 

attributes attached to the block you select.                    

3.Edit the attribute values as necessary. Then click OK. 
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Extract Block Attribute Data: Enter EATTEXT to start Attribute Extraction if the blocks 

in the drawing contain attributes. You can extract block information according to 

the wizard prompt and generate list so as to overview the attributes information of 

the blocks. You can get guide information from the wizard until you accomplish 

selecting drawings, blocks and block attributes. 

With the extract block attribute data function, you can easily create list using 

drawing data through extracting attribute information and export to external files.  

 

Reference Other Drawing Files (Xrefs) 

External references provide additional capabilities not available when you insert a drawing as a block. When you attach an 

external reference, however, any changes you make to the original drawing file are reflected in the drawings that reference it. 

External references are useful for assembling master drawings from component drawings. Use external references to coordinate 

your work with others in a group. External references help reduce the drawing file size and ensure that you are always working 

with the most recent version of a drawing. 

Attach External References: When a drawing is attached to current drawing as external reference, it will be linked to the drawing, 

any changes to the referenced drawing may affect the external reference in current drawing. External references are inserted into 

the drawing as block definitions and used as single objects, but you should distinguish the external references and blocks. 

To attach an external reference: 

1.Choose Insert>External References from the main menu.                                                     

2.Click the DWG icon at the top left of the window.                                                      

3.In the Select Reference File dialog box, specify the drawing file to attach and then click Open.                                                              

4.In the External Reference dialog box, under Reference Type, choose how you want to insert the drawing:                                                    

-Attachment: Inserts a copy of the drawing and includes any other drawings references.                                                                                          

-Overlay: Lays a copy of a drawing over your original drawing                                                            

5.Make any additional selections and then click OK.                                                                                 

6.If you marked Specify On-screen for any items, follow the prompts to attach the external reference. 
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Control the Properties of Referenced Layers:                                                                      

You can control the visibility, color, 

linetype, and other properties of an xref's 

layers and make these changes temporary 

or permanent. If the VISRETAIN variable 

is set to 0, these changes apply only to 

the current drawing session. You can also 

control the fade display 

through XDWGFADECTL variable. In 

addition you can control Xref layer 

properties directly into the Layer Manager 

Properties dialog box. 

                                                                                            

Xref Clipping Boundaries: You can control whether to display clipping boundary of xref through setting system variable 

XCLIPFRAME. Also you can Clip Xrefs by selecting the option on the menu bar: Modify>Clip>Xref 

 

 

 

 

 

 

                                                                                          

Nest and Overlay External References: Xrefs can be nested in another xref and attached to current drawing. In the process of 

attaching, you can select insertion position, scaling factor and rotation angle for xrefs. 

                                                                        

Binding an Xref to a Drawing: To provide a copy of a drawing containing external 

references to someone else, you must also provide all the external reference files. 

Binding the external references makes them a permanent 

part of the drawing, which is similar to inserting a separate 

drawing as a block. You can bind external references by 

doing right click to the selected Xref file. 

                                                                        

Refresh Xrefs: You can refresh the Xref by clicking the refresh button located at the top of 

the External Reference Dialog Box.  
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Hatches and Raster Images 

Hatches 

Define Hatch Boundary: To create a hatch, you should define hatch boundaries first by means of selecting objects to be hatched 

or picking a point inside the desired object. A hatch boundary can be any combination of objects, such as lines, arcs, circles, 

and polylines that forms an enclosed area. 

Control the Hatching in Islands: You can specify methods of hatching objects in outermost boundary as normal, outer and 

ignore. Normal is the default hatch pattern, besides, you can view hatching results of different types in the Islands area on Hatch 

tab of the Hatch and Gradient dialog box. 

Normal: Hatch the pattern from the outer boundary to 

inside. Hatching process will be stopped when encounter 

inner crossing points, and continue hatching until second 

inner crossing point appears. 

Outer: Hatch from the outer most layer of configuration, 

and keep the internal blank.  

Ignore: Ignore internal objects, only hatches outer 

objects.  

                                                                                              

To select objects for hatching: 

1.Choose Draw > Hatch from the main menu.                                                         

2.From the Hatch and Gradient dialog box, click the Island detection option, and then choose one of the following islands: 

Normal, Outer, Ignore: 

 

 

 

 

 

3.To keep any new objects that are created for drawing the boundary hatch, select the Retain Boundaries check box under Other 

options. Existing objects are always retained.                                                          

4.In the Boundaries, click Select Objects button.                                                      

5.In the drawing, click the objects to be hatched individually, and then press Enter when done.                            

6.In the Hatch and Gradient dialog box, click OK. 
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Select an area for hatching: 

1.Choose Draw > Hatch from the main menu.                                                          

2.From the Hatch and Gradient dialog box, click the Island detection option, and then choose one of the following islands: 

Normal, Outer or Ignore. 

 

 

 

3.To keep any new objects that are created for drawing the boundary hatch, select the Retain Boundaries check box under Other 

options. Existing objects are always retained.                                                            

4.In the Boundaries, click Pick Points button.                                                           

5.In the drawing, click inside the closed perimeter of a boundary. If desired, continue clicking inside additional closed 

perimeters.                                                                                            

6.To complete the selection, press Enter. Then click OK button. 

 

Choose and Define Hatch Patterns: Hatch pattern consists of a repeating 

pattern of lines, dashes, and dots. You can select a hatch pattern from a set 

of predefined patterns, or you can define a pattern of your own. The hatch 

pattern you used most recently is the default pattern the next time you add 

hatching. The program supplies predefined standard hatch patterns, which 

are stored in the ICAD.pat and ICADISO.pat hatch pattern library files. 

To specify a predefined hatch pattern: 

1.Choose Draw > Hatch from the main menu.                                                                      

2.In the Hatch and Gradient dialog box, click the Hatch tab.                                                          

3.Beside Type, click Predefined to apply a scale factor to make the pattern 

larger or smaller than the default size.                                                                                                

4.Enter the scale factor as a percentage of the default.                                                              

5.Enter the angle in degrees (1-360). The default angle is 

clockwise, you can change the angle of any hatch pattern by 

entering a numerical value.                                                                                        

6.Enter the ISO pen width. This option is only available if you 

select existing ISO hatch pattern in the Pattern option.                                                                                             

7.To copy the pattern properties from an existing hatch, 

choose Inherit Properties.                                           

8.To associate the hatch pattern to its boundary objects, under Other options, select the Associative check box. An associative 

hatch updates automatically if you move any of its boundaries.                                                   

9.To continue, add a hatch by selecting objects or picking points to selected area or boundary you want to hatch. 
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To specify a user-defined hatch pattern: 

1.Choose Draw > Hatch from the main menu.                                                                

2.From the Hatch and Gradient dialog box, click the Hatch tab.                                                       

3.Beside Type, in the Type list, click User Defined.                                                      

4.For Spacing, enter the line spacing for the pattern.                                                                 

5.To copy the pattern properties from an existing hatch, choose Inherit 

Properties, and select a hatch pattern from a hatched object in the drawing.                                                                                        

6.To associate the hatch pattern to its boundary objects, under Other options, 

select the Associative check box. An associative hatch updates automatically 

if you move any of its boundaries.                                                            

7. To continue, add a hatch by selecting objects or picking points to selected 

area or boundary you want to hatch. 

                                                                                         

To use a predefined library pattern: 

1.Choose Draw > Hatch from the main menu.                                                           

2.Click the Hatch tab.                                                 

3.Select a Predefined type.                                                                          

4.To select a predefined pattern, do one of the following:                                                        

-In the Pattern list, click the pattern name.                                                                       

-Click the graphical representation of the hatch pattern.                                                             

5. To continue, add a hatch by selecting objects or picking 

points to selected area or boundary you want to hatch. 

 

 

 

                                                                                           

Solid: With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled with a solid color. The default 

method is to specify the corners of the plane. After you specify the first two corners, the plane is displayed as you specify the 

remaining corners. The program 

prompts you for the third point and 

then the fourth point. 

To draw a quadrilateral plane: 

1.Choose Draw > Modeling > 

Meshes> 2D Solid                                                 

2.Specify the first, second, third and 

fourth point.                                                                                  

6.Finish the command, press Enter. 
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Work with Raster Images 

You can view and manipulate raster images and associated file paths in your drawings. 

                                               

Attach, Scale, and Detach Raster Images:                

Raster images consist of a rectangular grid of small 

squares or dots known as pixels. Raster images can 

be copied, moved, or clipped as well as a normal 

object in the drawing. You can also adjust the 

contrast, transparency, image quality and image 

frame visibility. Additionally, when inserting raster 

images, the file format depends on the content of 

the file rather than the extension name. The 

following table display all the image file formats 

supported: 

 

Attach Raster Images: Use IMAGEATTACH command to select and attach raster images, or bitonal, 8-bit gray, 8-bit color, or 

24-bit color image files to a drawing. The image file can be inserted as blocks as many times as you like once attached to the 

current drawing, you can clip the attached raster image and setup its lightness, contrast, fading and transparency. 

To attach a raster image: 

1.Choose Insert > Raster Image from the main menu.                                              

2.Specify a file to attach, and then click OK.                                                             

3.In the Image dialog box, in the Insertion point and Scale, click 

Specify on-screen. Specify an angle value in Rotation, and then 

click OK.                                                                                       

4.Specify an insertion point.                                                                               

5.Specify a scale. 

                                                            

Scale Raster Images: You can specify scale factor in the Image dialog box, otherwise to 

attach it by its original size. The raster image will be scaled by the specified factor, the 

scale factor is used without unit by default. 

Detach Raster Images: Raster images can be detached if it no longer needs to use in 

the drawing, a specified image detached from the drawing together with its multiple 

copies, links and definitions, but the original image file will not be influenced. 

                                                                                                     

Modify and Manage Raster Images: Controls the properties such as displaying and clipping boundary of raster images. You can 

view and manipulate attached raster image and change its saving path in Image Manager. Users can turn on/off image boundary 

in current view using IMAGEFRAME command and setting up the values 0 (off) 1(on). 

Type:  Description and versions: Extension: 

BMP Windows and OS/2 bitmap format .bmp 

ECW Enhanced Compression Wavelet .ecw 

JFIF or JPEG  Joint Photographics Expert Group .jpg or .jpeg 

PCX Picture PC Paintbrush Picture .pcx 

PNG Portable Network Graphic .png 

TGA True Vision Raster-Based Data Format .tga 

TIFF Tagged Image File Format .tif or .tiff 

GIF Graphic Interchange Format .gif 
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To turn image frames on or off for all images: 

1.Choose Modify>Object> Image> Frame                                        

2.Do one of the following to toggle frames off and on:                                                  

-Type value 1 to display and print frames for all images 

in a drawing.                                               

-Type value 0 to hide all frames on the screen and 

during printing. 

To clip an image in the shape of a rectangle and polygon: 

1.Choose Modify>Clip> Image                                                                        

2.Select the edge of the image you want to clip.                                                       

3.Type N (New boundary) to create a new clipping boundary.                                                  

4.If you choose Rectangular:                                                                         

-Define the first corner of the clipping rectangle.                                                          

-Define the second corner of the clipping rectangle. The selected 

image is clipped so that only the interior of the rectangle is visible.                                                                                    

5.If you choose Polygon:                                                                                      

-Select the points for the polygon, and then press Enter when the 

polygon is complete. The selected image is clipped so only the 

interior of the polygon is visible. 

 

Change Raster Image Brightness, Contrast, and Fade: Use IMAGEADJUST to adjust displaying result and lightness, contrast and 

fade that are related to the display and plot effect when plotting drawings. IMAGEADJUST does not affect the original raster 

image as well as other instances of the image.  

 

 

 

 

                                                                                               

Improve the Display Speed of Raster Images: You can adjust the display speed by setting the raster image quality. The image 

quality is sorted into high and draft levels, If the quality is set to draft, the image will be displayed with some granular materials, 

however with faster display speed. 
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Layout, Plot and Publish Drawings 

Create Multiple-View Drawing Layouts 

Overview of Layout: A layout represents a plotted page on which one or more model views are displayed. GstarCAD provides 

two collateral working environments as Model and Layout tab. You can create thematic models on Model tab. Multiple slides of 

the model can be set in Layout tab. Use these general steps to prepare your drawing for printing multiple layouts: 

1. On the Model tab, create your drawing.                                                             

2. Create a new layout. You can use an existing Layout1 or Layout2 tab, or you can create a new Layout tab.                                                     

3. Create at least one layout viewport on the Layout tab. Use each viewport to help control 

which portion of the drawing prints and at what scale.                                                                                           

4. Specify additional settings for the layout, such as the scale of the drawing, print area, print 

style tables, and more.                                                   

5. Print or plot your drawing. 

You can right click on Layout tab and select "New layout" to create a new layout, and also 

import layout from template. Options on Shortcut menu are listed: 

 

Work with Model Space and Paper Space: Model space is generally 

used for creating and editing drawings. Preparations for plotting are 

usually working on paper space for the drawings on layouts are close 

to the plotting effects. 

Model space is an area in which you create two dimensional and 

three dimensional objects based on either the World Coordinate 

System (WCS) or a user coordinate system (UCS). The contents of 

paper space represent the paper layout of your drawing. In this work 

area, you can create and arrange different views of your model similar to the way you arrange detail drawings or orthogonal 

views of a model on a sheet of paper. 

Layout tab is enabled to make relevant plot settings. Paper space is 

provided in each layout option, and you are allowed to create 

viewports and specify page setup such as paper size, orientation 

and location that can be saved together with the layout. 

You can save and name the page setup and apply it to other layouts 

when setting pages. You can also create new layouts using existing 

layout template file (DWT or DWG). 

Click on the Model tab, you can view and edit objects in model 

space.  
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Specify Layout Settings: Once created a drawing in Model tab, you can 

toggle to Layout tab and setup the layout for plotting, such as paper size, 

drawing orientation and so on. You can right click on the Layout tab to 

create new layouts or import from template files, and then click Modify 

button on the Page Setup Manager dialog box to set the page.  

Select a Paper Size for a Layout:  The paper size here refers to the size 

of the drawing. When you start Plot dialog box in Layout tab, you can 

assign the paper type from pull down list of the Paper Size text box. The 

Paper size is directly previewed from the sketch with its size and units. 

The available paper types provided in the pull down list are decided by 

the current configuration. If you want to configure plotters to export raster 

images, you must specify output size by pixels. The paper size can be 

customized in the Plotter Configuration Editor. 

Determine the Drawing Orientation of a Layout:     

The drawing orientation is sorted into Landscape and 

Portrait, which decide the plotting orientation of the 

drawing to be seen on a paper. Once specified the 

drawing orientation, you can control whether to plot the 

top or the bottom of the drawing by selecting Plot 

Upsize-down option. The changes setup in Page Setup 

dialog box are still saved in layouts. Certain page 

settings can be replaced by customized plot settings, 

but the settings will not be saved in the layout unless 

you click Apply to Layout option. 

 

Adjust the Plot Offset of a Layout: You can offset the geometry on the paper by entering a positive or negative value in the X and 

Y Offset boxes. Changing the plotting origin may change the position of drawing on papers. The plot origin locates at the left 

lower corner of plotting area with offset value of 0 relative to X and Y direction. Select Center on Paper if the specified plot area 

is part of the drawing rather than the whole layout, which changes the position of plot origin.   

 

 

 

 

 

 

Plot with origin (10,10) Plot with origin (0,0) 
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Set the Plot Area of a Layout: You can set the area to be plotted in Plot dialog box. When creating new layouts, the default plot 

option is drawing limits which means plotting all the objects within the drawing paper. The plot origin is (0,0), located at the 

left lower corner of the page. Do the following methods to select a 

plot area:  

-Layout: Plots all the objects within the drawing paper.                                                            

-Window: Set the Plot Scale for a Layout, Plots any portion of the 

drawing you specify within the rectangle window. Click the Window 

button to use a pointing device to specify opposite corners of the 

area to be plotted, and then return to the Plot dialog box.                                                                                          

-Extents: Plots the portion of the current space of the drawing that 

contains objects.                                          

-Display: Plots the contents displayed in current view. 

                                                                                         

Set the Plot and Lineweight Scale for a Layout: When you specify a scale to output your drawing, you can choose Fit to Paper to 

scale the drawing to fit onto the selected paper size. Usually, the objects in model space are displayed at the scale set in layout 

viewports. To plot the objects in model space with the scale specified in layouts, you assign the scale to 1:1. Even if plot scale 

of layouts is assigned, it's enabled to scale the lineweight at a certain scale. Scaling the lineweight is nothing to do with the 

plot scale when plotting drawings, which is mainly used for the lines included in the objects to be plotted.  

Move and Copy Layouts: You can right click on the 

Layout tab to select Move or Copy option, on the 

Move or Copy dialog box, you can select a layout 

which you want to place after the current layout. To 

Create a Copy of current layout, you can select a 

layout and check Create a Copy, the copied layout 

will place before the layout you selected. You should 

notice that Model tab can't be moved or copied.  

                                                                                         

Create Layout from Template: Right click on the Layout tab to select from template option to import DWG or DWT file directly, 

using information of existing template to create new layouts. System provides template file with extension name as .dwt. Layout 

templates from any drawing templates can be imported into the current drawing. 

To create a new layout from an existing file: 

1. Choose Insert>Layout>Layout from 

Template                                                 

2. In the dialog box, select the desired 

template file, and then click Open.                         

In the Insert Layout(s) dialog box, select the 

layout(s) you want to insert, and then click 

OK. You can choose multiple layouts by holding down Ctrl while selecting layout names. 



Chapter 12_ Layout, Plot and Publish Drawing 

101 

 

Create and Modify Layout Viewports: On a Layout tab, you must create at least one layout viewport to see your model. Each 

layout viewport is created as a separate entity that you can move, copy, or delete. Any changes you make in one layout viewport 

are immediately visible in the other viewports (if the other layout viewports are displaying that portion of the drawing). Zooming 

or panning in the current viewport affects only that viewport. 

Create layout viewports: 

1. On the command line, type MVIEW.                                                                  

2. Type F (Fit), or create 2, 3 or 4 viewports by entering 2, 3 or 

4 separately, or specify two opposing corners to create a 

custom viewport.                                                                               

3. Choose the viewport arrangement, typing H (Horizontal) or V 

(Vertical).                                                   

4. Do one of the following:                                                                                     

-To arrange the viewports to fill the current graphic area, type F 

(Fit)。                                                

-To fit the viewports within a bounding rectangle, specify the 

corners of a rectangle.  

You can create a single layout viewport, or you can divide the graphic area into many viewports arranged  

[Horizontal/Vertical/Above/Below/Left/Right].   

 

To modify layout viewport properties: 

                                                                                            

1. Click the border of the layout viewport whose 

properties you want to modify.  

2. Open the Properties palette through the menu option 

"Tools >Palettes>Properties" or "Modify > Properties". 

3. In the Properties palette, select Standard Scale, and 

then select a new scale from the list. The scale you 

choose is applied to the viewport. 

                                                                                         

Turn Layout Viewports On or Off: 

1.Click the desired Layout tab. 

2. Type MVIEW and then press Enter. 

3. Type ON or OFF. 

4. Select the edge of the layout viewport to turn on or off, then press Enter. 

 

Create Non-rectangular layout viewports: 

Use Object and Polygonal options of MVIEW to create irregular viewports,  

Select Object option to convert objects created in paper space to viewports. While selecting 

Polygonal option to draw irregular polylines including arcs and lines which are enabled to 

either intersect or three vertexes at least, the polyline will be closed automatically. 
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Plot Drawings 

When a drawing is completed, you can output it using several methods. You can plot the drawing on paper or create a file for 

use with another application. 

Plot Settings: When you create a drawing, you do most of your 

work on the Model tab. At any time you can print your drawing to 

see how it looks on paper. It's easy to startup printing, and then 

later create layouts and custom print settings to enhance your 

printed output. 

To start printing: 

 

1. Choose File > Plot from the main menu. 

2. Set the printer and relevant parameters, and then click OK.  

 

Set Paper Size: You can assign the paper type from pull down list of the Paper Size text box. If you want to setup paper size, you 

should configure plotters first, all the available plotters are both system plotters of Windows configured and non-system driven. 

To select a printer or plotter: 

 

1. Choose File > Plot from the main menu. 

2. From the Name list in Printer/Plotter area, select a 

printer or plotter you want to use, and then click OK. 

 

                                                 

Position the Drawing on the Paper: You can adjust the position of the drawing to be plotted on a paper before plotting. 

To specify the print area origin: 

1. If necessary, click the desired Layout tab or the Model tab.                                                

2. Choose File > Plot from the main menu.                                                                

3. Do one of the following in the Plot Offset area:                                                       

-To center the specified print area on the printed 

page, select Center the Plot check box.                                                                   

-To specify an origin for the print area, type the X and Y coordinates.                                                 

4. Select OK, and then click Apply to Layout. 
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Set Drawing Orientation: The drawing orientation determines whether to plot a drawing 

portrait or landscape. If you select Landscape, plots the drawing using the length edge as 

horizontal. While selecting Portrait to plot the drawing using its minor edge as horizontal 

Changing, the drawing orientation just like rotating the paper under the drawing. 

Meanwhile, selecting Plot upsize-down to control whether to locate the drawing 

upsize-down on paper. 

                                                                                                                

Set Plot Scale: Plot scale of the drawing can be specified directly from the Scale 

pull-down list in Plot Scale area of Plot dialog box. You can also choose 

User define to set desired plot scale, or choose Fit to Paper to scale the 

drawing to fit onto the selected paper size. The plot scale together with plot 

unit and drawing unit must be specified before plotting. For example, if you 

select the paper size to mm, entering 1 under mm and 10 under Units 

blank produces a plotted drawing with each plotted unit represents 10 

actual millimeters. 

To automatically scale the drawing for printing: 

1. If necessary, click the desired Layout tab or the Model tab.                                                           

2. Choose File > Plot from the main menu.                                                                    

3. To scale the drawing to fit on one printed page, in Plot Scale, click Fit to Paper.                                                

4. Select Apply to Layout and click OK. 

 

Set Plot Options: The following options show plot patterns with instructions on how to plot objects. 

-Plot in Background. Specifies that the plot is processed in background.                                      

-Plot Object Lineweights. Specifies that lineweights assigned to objects and 

layers are plotted.                                                

-Plot with Plot Styles. Plots a drawing with specified plot styles. Plots 

lineweights automatically once selecting this option automatically. If you do not 

select this option, objects are plotted with their assigned properties and not 

with the plot style overrides.                                                                                    

-Plot Paperspace Last. Plots model space geometry first. Paper space geometry 

is usually plotted before model space geometry.                                                                                            

-Hide Paperspace Objects. Suppresses the plotting of objects that are located 

behind other objects regardless of how it's displayed on screen. This option is 

only available in the Layout tabs.                                                    

-Plot Stamp on. Horizontally or vertically placed the plot stamp information on a specified corner of drawing. The plot stamp 

settings can be saved to log file, also cannot be saved.                                                 

-Save Changes to Layout. All the changes you make in the Plot dialog box will be saved to the layout if you click OK. 
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Specify the Area to Plot: To specify a portion of the drawing to print, if necessary, click the desired Layout tab or the Model tab. 

1. Choose File > Plot from the main menu.                                                              

2. Under Print Area, click one of the following:                                                             

-Display – Plots the current view on the screen.                                                     

-Extents – Plots the contents within the specified drawing extents.                                                

-Limits/Layout – Plots the contents within the specified drawing 

limits or entities in the printable area.                            

-Window – Plots the portion of the drawing contained in the 

specified window. Click the Window button to use a pointing device 

to specify opposite corners of the area to be plotted, and then return 

to the Plot dialog box.                                 

3. Select Apply to Layout and click OK. 

                                                                                     

Preview a Plot: Viewing a drawing before printing gives you a 

preview of what your drawing will look like when it is printed. 

To preview a drawing before printing: 

1. If necessary, click the desired Layout tab or the Model tab.                                               

2. Choose File > Plot Preview from the main menu.                                                                  

3. Do one of the following:                                                                      

-To print the drawing, click preview and click Plot on the top left 

corner of print preview.                                                         

-To return to the drawing, click the off button or press Esc. 

                                                                                            

Use Plot Styles: Plot styles help you control what your drawing looks like when it is printed. Because plot styles are saved in 

plot style tables, which are files located on your computer, you can reuse them to help eliminate the need to reconfigure your 

print settings each time you print a drawing. A drawing can use one type of plot style table at a time. There are two types of plot 

style tables:                                                                                    

-Color-dependent plot style tables (CTB) contain a collection of plot styles based on each of the 255 index colors available in a 

drawing.                                                                                                                   

-Named plot style tables (STB) contain a collection of plot styles that you define. They can vary regardless of color. 

To assign plot style tables: 

1. If necessary, click the desired Layout tab, or click the Model tab.                                                    

2. Choose File > Plot from the main menu.                                                             

3. Under Plot Style Table (pen assignments), select a plot style table in the one of the following:                                   

-None: Applies no plot style table. Objects plot according to their own properties.                                         

-Monochrome: Plots all colors as black.                                                                      

-New: Creates a new plot style table.                                                                        

4. Select Save Changes to Layout, and then click Apply to Layout. 
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To Modify plot style tables: 

1. Choose File > Plot from the main menu.                                                            

2. Under Plot Style Table (pen assignments), click the plot style table you want 

to modify, and then click the button to display “Plot Style Table Editor”.                        

3. Click the General tab on Plot Style Table Editor, and then do any of the 

following:                                                            

-Enter a new plot style description.                                   

-Select Apply global scale factor to non-ISO linetypes to apply the scale factor 

-Enter a scale factor to apply to non-ISO linetypes used for any plot style in the 

current plot style table.                                               

4. Click the Form View tab, and then do any of the following:                       

-Make changes to a color-dependent plot style by selecting it in the Plot list, 

and then make color, linetype, or lineweight changes for the plot style in 

Properties area. Your changes are saved automatically for the selected plot 

style.                                                           

-Make changes to a named plot style by selecting it in the Plot list, and then 

make color, linetype, or lineweight changes for the plot style in Properties area. 

Your changes are saved automatically for the selected plot style.                                                 

-Add a new plot style by clicking Add Style. Enter a new name, and then click 

OK. Select the options for the plot style. (Available for named plot styles only.)                                                                          

-Delete a plot style by selecting it in the Plot list, and then click Delete Style. 

(Available for named plot styles only.)                 

5. Click OK.  

 

Plot Files to Other Formats: Plot files have various formats. You can output drawings in any image formats with unique plotter 

driver. 
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Publish Drawings: Specifies drawing sheets that you can assemble, reorder, rename, copy, and save for publishing as a 

multi-sheet drawing set. You can publish the drawing set to a DWF, DWFx, or PDF file or send it to the plotter named in the 

page setup for hardcopy output or as a plot file. The following options are displayed in the Publish Dialog Box: 

 

1. Load Sheet List Button: Displays 

the Load Sheet List dialog box, in 

which you can select a DSD file or a 

BP3 (Batch Plot) file to load.                                                      

2. Save Sheet List Button: Displays 

the Save List As dialog box, in which 

you can save the current list of 

drawings as a DSD file.                                                             

3. Sheet List: Displays the current 

drawing set (DSD) or batch plot (BP3) 

file. 

4. Publish to: Defines how to publish 

the list of sheets. You can publish to 

either a multi-sheet DWF, DWFx, or 

PDF file. 

5. Automatically load all open 

drawings: When selected, the 

contents of all open documents are 

automatically loaded in the publish 

list.                        

6. Add Sheets Button: Displays the 

Select Drawings dialog box, in which 

you can select drawings to add to the 

list of drawing sheets.                                                              

7. Remove Sheets Button: Deletes the 

selected drawing sheets from the list 

of sheets.                                               

8. Move Sheet Up Button: Moves the 

selected drawing sheets up one 

position in the list.                                

9. Move Sheet Down Button: Moves 

the selected drawing sheets down one 

position in the list.                                     

10. Preview Button: Displays the 

drawing as it will appear when plotted 

on paper by executing 

the PREVIEW command.          

11. Sheet Name: Combines the 

drawing name and the layout name 

with a dash (-).              

12. Page Setup/3D DWF: Displays 

the named page setup for the sheet. 

You can change the page setup by 

clicking the page setup name and 

selecting another page setup from 

the list                                          

13. Status: Displays the status of the 

sheet when it is loaded to the list of 

sheets. 

14/15. Show and select sheet details: 

Displays and hides the Selected 

Sheet Information and Selected 

Page Setup Information areas.                                                                           

16. Publish Options: Opens 

the Publish Options dialog box, in 

which you can specify options for 

publishing.                        

17. Number of Copies: Specifies the 

number of copies to publish.                                                

18. Precision: Optimizes the dpi of 

DWF, DWFx, and PDF files for your 

field: manufacturing, architecture or 

civil engineering.                                                                            

19. Include Plot Stamp: Places a plot 

stamp on a specified corner of each 

drawing and logs it to a file.                        

20. Plot Stamp Settings: Displays 

the Plot Stamp Dialog BoxPlot 

Stamp Settings Dialog Box, in which 

you can specify the information, 

such as drawing name and plot 

scale that you want applied to the 

plot stamp.                          

21. Publish in Background: Toggles 

background publishing for the 

selected sheets.                                         

22. Send the Sheets to the Plotter in 

Reverse Order: When selected, sends 

sheets to the plotter in reverse of 

default order. This option is 

available only if the Plotter Named 

in Page Setup option is selected.                                        

23. Open in Viewer when Done: When 

publishing completes, the DWF, 

DWFx or PDF file will open in a 

viewer application. 
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Create and Edit Dynamic Blocks 

In GstarCAD8, you can create and edit Dynamic Blocks. Dynamic block references contain grips or custom properties that 

change the way the reference is displayed in the drawing after it is inserted. Dynamic blocks allow you to insert one block that 

can change shape, size, or configuration, instead of inserting one of many static block definitions. 

Some dynamic blocks are defined so that geometry within the block can only be edited to certain sizes specified in the block 

definition. When you use a grip to edit the block reference, tick marks are displayed at the locations of valid values for the block 

reference. If you change a block property value to a value other than one specified in the definition, the parameter will adjust to 

the closest valid value. 

Dynamic Block Editor: You can access the Block Editor by typing the edit command or by double-clicking the block without 

attribute. The Block Editor ribbon interface will show as below, the black arrows mark the stand for parameters, while the yellow 

lighting is the symbol for action. It will pop-up toolbars in a classic interface. 

 

 

  

 

 

 

 

 

 

 

                                                                                              

Dynamic Block Editor Tool Panels: Using the tools in this Tool Panel to define, edit and modify dynamic blocks definitions , 

makes it very convenient and fast. 

Manage 

Save or Save as the default block; Create or edit another 

block. 

 

Tool 

Define, edit or update the block attribute. 
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Parameter 

You can add parameters for Dynamic Blocks on this panel. 

 

Action 

You can add actions for Dynamic Blocks on this panel. 

 

Parameter Sets 

You can add the parameter set on this panel. 

 

 

Visibility 

This panel is specially used for Visibility editing. 

 

Close 

It is used to exit the Block Editor. Before exiting, some 

commands like save or open etc. might not work. 

 

                                                                                    

Parameters: Define custom properties for the dynamic block by specifying positions, distances, and angles for geometry in the 

block. You add parameters to a dynamic block definition in the Block Editor. In the Block Editor, parameters have an appearance 

similar to dimensions. Parameters define custom properties for the block. Parameters also specify positions, distances, and 

angles for geometry in the block reference. When you add a parameter to a dynamic block definition, the parameter defines one 

or more custom properties for the block. 

A dynamic block definition must contain at least one parameter. When a parameter is added to a dynamic block definition, grips 

associated with key points of the parameter are automatically added. You must then add an action to the block definition and 

associate the action with a parameter. 

Parameters also define and constrain values that affect the dynamic block reference's behavior in a drawing. Some parameters 

can have a fixed set of values, minimum and maximum values, or increment values. For example, a linear parameter used in a 

window block may have the following fixed set of values: 10, 20, 30, and 40. When the block reference is inserted in a drawing, 

you can only change the window to one of these values. Adding a value set to a parameter allows you to limit how the block 

reference is manipulated in a drawing. 

Point Parameter 

Icon:  

Command: BParameter→O 

Defines an X and Y location in the drawing. A point 

parameter can be associated with a move or stretch action. 

Linear Parameter 

Icon:  

Command: BParameter→L 

Shows the distance between two anchor points. Constrains 

grip movement along a preset angle. A linear parameter can 

be associated with a move, stretch, scale or array action. 
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Polar Parameter 

Icon:  

Command: BParameter→P 

Shows the distance between two anchor points and displays 

an angle value. You can use both grips and the Properties 

palette to change both the distance value and the angle. A 

polar parameter can be associated with a move, scale, 

stretch, polar stretch, or array action. 

XY Parameter 

Icon:  

Command: BParameter→X 

Shows the X and Y distances from the base point of the 

parameter. It can be associated with a move, scale, stretch, 

or array action. 

Rotation Parameter 

Icon:  

Command: BParameter→R 

Defines an angle. The rotation angle can be in any value, or 

be defined in a range or a specified value. 

Alignment Parameter 

Icon:  

Command: BParameter→A 

Defines an X and Y location and an angle. An alignment 

parameter always applies to the entire block and needs no 

action associated with it. An alignment parameter allows the 

block reference to automatically rotate around a point to 

align with another object in the drawing. An alignment 

parameter affects the rotation property of the block.  

Flip Parameter 

Icon:  

Command: BParameter→F 

A flip parameter flips objects. You can associate a flip 

parameter with a flip action. 

Visibility Parameter 

Icon:  

Command: BParameter→V 

Controls the visibility of objects in the block. A visibility 

parameter always applies to the entire block and needs no 

action associated with it. In a drawing, you click the grip to 

display a list of visibility states available for the block 

reference. 

Lookup Parameter 

Icon:  

Command: BParameter→K 

Defines a custom property that you can specify or set to 

evaluate a value from a list or table you define. It can be 

associated with a single lookup grip. In the block reference, 

you click the grip to display a list of available values. You 

can associate a lookup parameter with a lookup action. 

Base Point Parameter 

Icon:  

Command: BParameter→B 

Defines a base point for the dynamic block reference relative 

to the geometry in the block. Cannot be associated with any 

actions, but can belong to an action's selection set. 
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Actions: Actions define how the geometry of a dynamic block reference will move or change when the custom properties of the 

block reference are manipulated in a drawing. 

Move  

ICommand: BActionTool→M 

A move action causes objects to move a specified distance 

and angle such as a point, a linear, a polar, an XY parameter, 

etc, moves all objects in a selection set in a/any direction. 

Scale  

Command: BActionTool→S 

A scale action such as a linear, a polar, an XY parameter, and 

so on, scales the selected objects in the direction of the 

parameter. Users can manipulate the grips in different way 

by changing the properties and values in the Properties 

palette. 

Stretch  

Command: BActionTool→T                                                               

A stretch action causes objects to move and stretch a 

specified distance in a specified location. A stretch action 

associated with a point, a linear, a polar, an XY parameter, 

etc.  

Polar Stretch  

Command: BParameter→PIn                      

A polar stretch action rotates, moves, and stretches objects a 

specified angle and distance when the key point on the 

associated polar parameter is changed through a grip or the 

Properties palette. A polar stretch action can only be applied 

to a polar parameter. 

Rotate 

Command: BActionTool→P 

A rotate action is always associated with a rotate parameter. 

Selected objects can be rotated freely, or the way the grips 

are manipulated is different in the Properties palette.  

Flip 

Command: BActionTool→F 

A flip action is always associated with a flip parameter.  

Array  

Command: BActionTool→A 

An array action is associated with a linear, a polar, an XY 

parameter, etc, copies and arrays selected objects in 

different way.  

Lookup  

Command: BActionTool→L 

A lookup action can only be associated with a lookup 

parameter.  

 

The General Steps of Creating a Dynamic Block Definition: In order to get a Dynamic Block Definition, improve block editing 

efficiency and avoid repeating modifications, we can create Dynamic Block by the following steps. 

Step1: Planning 

Before creating Dynamic Block, it is 

essential to plan Dynamic Block, plan 

the functions, appearance, the method 

of drawing and required Parameter(s) 

and Action(s) which are needed to 

achieve prospective functions. 

Step2: Draw geometric figure 

The included basic pixel during 

Dynamic drawing, of course, you can 

draw these pixel in Block Editor. 

Step3: Add Parameter and Action 

This is the most pivotal step when 

creating Dynamic Block. When editing 

the Parameter and Action, you not 

only consider the achievement of 

Parameter and Action, but also 

consider the readability of Dynamic 

Block and the convenience of 

Modification, let the action point of 

the Parameter attach on the 

corresponding pixel as far as possible, 

and put the Action near to its relevant 

parameter, if there are more 

Parameters and Actions, they still 

need to be renamed for understanding, 

editing and Modification. 

Step4: Test Dynamic Block 

Save and Exit Block Editor, start the 

Dynamic Block test to check if it 

reaches to the prospective effect. 
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Dynamic Blocks Creation Samples 

See what you are able to do within the Dynamic Block Editor, and get the most out of your design. See the follow samples:  

Base Point Parameter: Although the majority of parameters only taken into effect when operations are matched with actions, 

there are exceptions, base point parameter is one of them. 

1. Define blocks: Define block and draw a circle in the block editor, as shown. 

 

2. Add base point: Click "base point" parameter on the parameter panel, put the parameter on 

the center of the circle according to system prompt, as shown in the below illustration. 

 

 

 

 

3. Insert block: Save and exit block editor, insert the block in the model. You 

can realize, base point becomes the insert point of the block after adding the 

base point parameter. Please note, if you set an insert point via the block define 

dialog box, and add a base point parameter as well, the base point is the default 

insert point. 

 

Visibility: Using the Visibility Parameter function, you can control the display and hide a certain view in Dynamic Block. 

1. Prepare view: Prepare a three cars view and define as block. 
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2. Add Parameter of Visibility: Enter into Block Editor by Double-clicking the clock or right- click the menu, click the button 

Visibility of Parameter in the Parameter panel, appoint the position of the Parameter according to the system prompt, as shown 

below. 

 

 

 

 

 

 

3. Edit the states of Visibility: Double click the button Visibility, the 

Visibility States dialog box will be displayed. In the dialog box, you can 

rename, new and remove the Visibility States. In order to control the 

visibility of the three cars view in this example, we click on new for the 

three Visibility States as shown in the following picture. 

Click the following button as shown in the picture and choose roadster 

in the pull down menu. 

 

Click the “Invisibility” button in the Visibility tool panel, select truck and car, make them 

invisible in the “roadster” state, as shown in the following picture, after selecting, press 

enter to confirm. For the state of “Car” and “Truck”, set them in the same way. 

 

4. Move and Adjust: After finishing the editing of the Visibility States, move the three cars 

view to make them overlap as shown in the picture bellow. 
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5. Test Dynamic Block: Insert the edited Dynamic Block into a drawing, select Dynamic Block and click the grip of Visibility 

Parameter, choose one item in the pop-up pull-down list, Dynamic Block will change the display state automatically, as shown 

in the following picture. 

 

 

 

 

 

 

 

 

Alignment: Alignment Parameter can give dynamic blocks the function of alignment automatically, which can save the step of 

rotating the blocks. 

1. Add an alignment parameter for a roughness symbol: Draw a roughness symbol in the Block Editor. 

Select the icon of the alignment parameter. Specify the location and the aligned orientation of the 

parameter following what the computer asked as shown in the picture, the dotted line is the align 

orientation. 

 

2. Test the dynamic block: Insert the roughness dynamic 

blocks, move the align grips, the symbol will align with the 

interface of the dimensions, as shown pin the picture 

below. 

 

 

Flip: When you use the "roughness symbol block" to label the spare parts, the symbol is sometimes already in the right position, 

however, the characters' direction is not right. We need to add the "character flip" function to receive the correct label. 

1. Add flip parameter: Click the "flip" parameter button, add the flip parameter 

according to prompt, as shown in the picture. 
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2. Add flip action: Click the flip action button on the action panel, match parameter and object for the action. Herein, we choose 

"roughness" as the object, and position the action button, as shown in below picture. 

 

 

Use the same method to add a 

pair of flip parameter and action 

of the vertical direction, as 

shown: 

 

 

 

 

Point Movement: 

  

1. Draw a drawing: Draw a drawing and define it as a block. 

 

 

 

2. Add point parameter: Click point parameter on the tool bar, define the parameter 

position according to prompt, as shown in the picture. 

  

 

 

 

3. Add move action: Click move action button on action 

panel, match parameter and object for the action, and 

define the position. The position of action label does not 

affect the effect of the dynamic block, however, for the 

sake of beauty& convenience, try to put the label near the 

related parameter. 

 

 

 

 

 

 

4. Test dynamic block: Insert the dynamic block, drag the blue grip, then move the 

keyway to the right accordingly, as shown in below picture. Obviously, the dynamic 

block can achieve the expected results. Please pay attention, if it is not run with ortho 

constraint, the keyway can move towards every direction because the direction of the 

point parameter is random, the 

characteristic of the parameter 

decides the characteristic of action. 
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Linear Movement: Actually, limited to the demand of the material mechanics characteristics, keyway is only allowed to be 

placed on the central line. So, a horizontal movement is enough for keyway and the movement to other direction is not 

meaningful. Next we will take advantage of the linear parameter to define the keyway’s movement direction on the central line of 

the step shaft.  

 

1. Draw: Draw the follow drawing and define it as a block.   

 

 

 

2. Add linear parameter: The way of adding a linear parameter is similar to 

dimension, both try to put the absorption point of the parameter on the central 

line of the step shaft.  

 

 

3. Add Move Action: Different from the point move, after specifying the 

parameter, the system will prompt: Specify parameter that is related to 

movement. Select right grip of parameter as “Related parameter point”, as 

shown in the following picture. 

 

The parameter point we mentioned corresponds to the operate point of Move. 

After exiting Block Editor you can drag this point to make dynamic block 

change correspondingly. After selecting the related parameter point you can 

specify the move objects for action, as shown in the following picture. Place 

action label, save and exit dynamic block. 

 

4 .Testing Dynamic Block: Select dynamic block and drag the right grip of the 

parameter. Meanwhile, no matter how the cursor moves, the keyway is limited to 

the central line of the step shaft. That is to say with the limitation of the linear 

parameter, the dynamic block can only move along the direction specified by the 

linear parameter. 

 

 

Number of Grips: In the Block Editor, select the linear 

parameters, change the number of grips to “1” in the 

properties panel. 

 

 

   

 

 

Save and exit the Block Editor, choose the Dynamic Block, you will 

find that one grip has disappeared. In fact, after changing the number 

of grips from “2” to “1”, the first thing that disappeared was the basic 

grip of parameters, namely the first point when adding parameters. 
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Angle Offset: Open Block Editor, choose the Angle offset 

from 0°to 30°in the action property, save and exit the block 

editor 

 

 

 

 

Select the Dynamic Block and then move the right side grip. You will find it 

can only move in the direction of 30°as it is shown in the follow picture. The 

direction of action can change according to the Angle Offset. 

 

 

 

 

Linear Stretch: During a mechanical design, we often need to change the position as well as the dimension of the keyway. In 

this section, we will add Linear Tensile function for the keyway on the step shaft. 

 

1. Add linear parameter: 

 

  

 

2. Add stretch action: Click the stretch action button on the action 

panel, choose parameter according to prompt and define right 

grip as key parameter point, as shown in below picture. The black 

object is the operational object of the action, the broken line 

frame is the stretch frame, objects intersect with stretch frame will 

be stretched, objects which will be selected by the stretch frame 

will move. 

 

3. Test dynamic block: Exit from block editor, drag stretch grip to stretch 

the keyway, as shown in the picture. 

 

 

Parameter Value Set: For mechanical designs, we often need to stretch the keyway to a certain length. Now, let us see how to 

realize an accurate stretch. Pick linear parameter in block editor, click entry frame which is on the right side of" distance type" 

on the Properties panel, a drop-down menu will pop up. 

 

Therein, none is the default option, which means it 

can stretch optionally. With the other two options, 

you can define the maximum and minimum number 

respectively. 
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"Increment" means stretch increasingly, a Value set appears as shown 

below after selecting increment. If you choose "list", a Value set appears 

as shown in below picture, the dynamic block can only be stretched 

according to the number in the list. 

 

Click the text frame which is on the right side of the 

"distance value list", one button with ellipsis on it will 

appear. Click this button, a "Add distance" dialog box will 

be displayed. Add three numbers “1”.“1.5”.“2” in the 

dialogue box, as shown in below picture. 

 

Exit from block editor and stretch the right grip, you will 

see several gray lines appearing on the right side of the 

keyway, and the keyway can only be stretched to the gray 

line position, as shown in below picture. Obviously, by value list, you can define certain numbers of the stretch, to realize an 

accurate stretch. 

 

 

 

 

 

Symmetrical Stretch: There is an easy way to realize the two-way stretch which is adding two actions of stretch. Though it can 

realize a two-way stretch, the action of stretch is independent. The parameter needs some additional setup to realize the 

two-way symmetrical stretch.  

 

-First, add two stretch actions for parameter, and select the two grips 

of the two parameters as the relevant point of each action. 

-Second, in the misc, modify the base location from "Start Point" to 

"Mid Point", like shown in the picture below. Save and exit the block 

editor. 

 

For the convenience of watching the effect, we drew a vertical center line in the middle of 

the keyway, and then stretched the grip to the left side of the keyway or the right side, as 

shown in the picture below. As the grips are moving, the two-way symmetrical stretch is 

realized. 

 

 

 

Distance Multiplier: Take the step shaft as an example, if we stretch the left part of the 

step shaft and the keyway still is at the center point of the smaller diameter shaft after 

stretching. Then, we use the “Distance Multiplier” property of action to achieve the aim. 

 

 

 



Chapter 13_ Create and Edit Dynamic Blocks 

118 

 

1. Add linear parameter and stretch action for step shaft:  

Hide the right grip of the parameter point, the action stretch 

box is as in the following picture, the bolded object is the 

action operation object. 

 

 

 

 

2. Add Move Action for keyway: Select the left grip of the linear 

parameter when moving, stretching the related parameter points. 

Move the objects of action and select the whole keyway, as in 

the following picture. 

 

 

 

 

3. Modify distance multiplier of action: Select Move 

Action and modify the default value from 1 to 0.5 in the 

property of the distance multiplier, save and exit the block 

editor. 

 

 

4.Test Dynamic Block: Stretch leftwards grip and with the grip moving leftwards, 

the smaller diameter shaft will appear with a stretch effect, the keyway will also 

move leftwards accordingly, meanwhile, the keyway is in the center of the 

smaller diameter shaft of the step shaft all the time. Although Stretch and Move 

have a common parameter, when the Distance Multiplier of Move is modified to 

0.5, the displacement of Move can only stretch 0.5 times of the displacement.  

 

 

Chain Action: If you want to realize a symmetric stretch without changing the keyway center and the length of smaller diameter 

shaft changes with the stretch at the same time, how can you realize that? 

 

1. Add stretch for Step Shaft: Add stretch parameter and action for step 

shaft as the following picture shows. There into, the bolded objects 

indicate the operation object of action. Because the follow-up operation 

will not stretch the step shaft by grips of this linear parameter, the grip’s 

number of the linear parameter can be modified to “0”. 

 

 

2. Add linear parameter for keyways: Set the base point 

position of the line parameter as “Center” in order to 

realize the symmetric stretch function. 
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3.Add the stretch rightwards action for the keyway and realize chain action: Select the “Distance” linear parameter and modify 

the chain action of prosperity from “NO” to “Yes” as the following picture shows: 

 

 

 

 

 

 

 

 

 

Add the Stretch Leftwards action for keyway as the following picture shows. 

Special Note: Do elect “Distance” for the linear parameter to stretch 

leftwards the operation objects set. This is a necessary procedure of the 

chain operation. 

 

 

4.Test Dynamic Block: After dragging the left grip, not only the keyway will 

stretch bi-directionally and symmetrically but also the smaller diameter shaft of 

the step shaft will stretch automatically. This is a chain action. The realization of 

a chain action has two important procedures: First, modify the property value of 

the parameter that need to happen as linkage and modify the property of “chain 

action” from “NO” to “YES”. Second, elect the parameter of objects that are 

elected to linkage action to set. 

 

 

Scale Action: Scale Action can be matched with the Linear Parameter, Polar and XY Parameter to achieve various Dynamic 

effects. 

 

Linear Scale 

 

1. Draw: Finish drawing an access hole in a model space and define it as a block, as shown in the 

following picture. 

 

                                                                                          

2. Add Linear Parameter: Enter into Block Editor to add a 

linear parameter. The start point of the Linear Parameter is 

the center of the circle, and choose the number of grip as 

“1”as shown in the following picture.  
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3. Add Action: Click the Scale icon on the Action Panel, appoint 

parameter for Action and box the whole access hole as Action Object, 

as shown in the following picture. 

 

 

 

   

4. Test Dynamic Block: Exit from Block Editor and insert the Dynamic block, 

after pitching up the Dynamic Block, drag the triangle grip, the objects (nuts) 

will scale with it. 

 

 

Polar Scale 

                                                                                                         

When we move the Scale Grip of the Access Hole on the left of circle center, namely move the 

base point of the Linear Parameter to the left of the circle center, we will find that the block does 

not have a corresponding Scale, as shown in the following picture. 

 

 

The reason for this is that the Endpoint of the Linear Parameter cannot cross its base point, so 

we change the Linear Parameter to be a Polar Parameter, we do not change any other 

operations, as shown in the following picture. 

 

Exit from Block Editor, Drag the grips of the Access hole Block again, 

you can see, that after the change from Linear Parameter to Polar 

Parameter, we can drag the grip to scale the dynamic block in any 

direction. 

 

 

Scale Character: In this section, we will explain some Scale characters using XY Parameter and Scale Action in a paired 

example. 

1. Drawing graphics: Draw the graphics which need a dynamic block and define them as a block as below: 
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2. Add XY Parameter: Entry Block Editor, add XY Parameter. Parameter adding is similar to Linear Parameter. Pick the first point 

of the parameter from the left bottom corner of the rectangle as the base point, the second point from the top right corner and 

change the Number of Grips to “1”. Then add Scale Action, as shown below. 

 

 

 

 

 

 

 

 

 

 

 

 

3. Test the Dynamic Block: After exiting the Block Editor, drag the grip of the top right 

corner of the rectangle, you can see the whole dynamic block is scaling as the grip is 

moving. It is easy to find that both the circle and the rectangle scale by the base point 

of the XY Parameter. 

 

 

5. Modify Action Base: Modify Base type: go back to Editor, select Scale Action and change the default “Dependent” to 

“Independent”. 

 

 

 

 

 

 

 

 

Specify new base: Single click the right input box of “Base-X” and 

“Base-Y”, you can manually input the coordinate value or you can 

single click the small button with ellipsis dots on the right of the 

input box and snap the base point, as shown: 

 

 

 

Specify the base point by crosshair and the circle center as base point. After 

exiting Block Editor, scale the dynamic block. After modifying Base type and 

position, the scale center of the dynamic block changes from the XY Parameter 

base point to the new specified base point (center of the circle).  
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6. Scale Type: There is “Scale Type” in the Scale Action 

Properties. The default value is “XY Scale”. If you choose 

“XY Scale”, the dynamic block scales whenever the scale 

grip moves to X axis or Y axis. If you choose “X Scale”, it 

scales only when the grip of the scale moves to X axis. 

Same, when you choose “Y Scale”. 

 

 

Rotation: In this section, we are going to use a rotation parameter and rotate action to add a dynamic rotate function to view 

index symbols (English system) which are frequently used in architectural drawings. 

 

1. Draw a drawing: Draw a view index symbol and define as a block, as shown in below picture. Please 

define view number and drawing number as attribute text, so as to revise whenever you want. 

 

                                                                                          

2. Add rotation parameter: Pick the center of the circle as the first point of the parameter, system default it as the rotation point, 

set angle type as "increment", and define its number as 15 degree, as shown below. 

 

 

 

 

 

 

 

 

 

                                                                                                  

3. Add rotate action: Click the rotation action 

button on the action panel, match parameter, 

object and position for the action and select the 

whole index symbol as the object of the action. 

 

 

4. Test dynamic block: Exit from block editor and insert the block, drag 

rotation grip to reach the effect of rotation, as shown in below picture. 

 

 

Polar Stretch: We use the Polar Stretch function of Dynamic Blocks to draw the section symbol in this section.  

 

1. Draw, Mirror and Define as a Block: The follow drawing includes the attribute text which can be modified as you need. Then 

mirror this drawing and define the mirrored object as a block. 
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2. Add action and parameter for the attribute text: Add Point 

Parameter and Move Action for text and change the Chain 

Action to “Yes” .It is ready for next step to create Chain 

Action for Polar Stretch Action. 

 

 

 

3. Add Polar Parameter and Action: Add Polar Parameter whose first point 

should be the center of the section symbol. This point will be the rotation center 

of the Polar Parameter. Follow the instructions below: 

 

 

1. Pick the right grip of the Polar Parameter as an associated parameter point and specify the Stretch box (Fig. 3.1). 

2. Select objects to stretch and the “position” Point Parameter together, which can accomplish that the text and section symbol 

are moving together (Fig. 3.2). 

3. Specify objects which rotate only for Polar Stretch Action (Fig 3.3). 

4. Specify Action symbol location (Fig 3.4) 

5. Repeat the above steps to add the same parameter and action order for the left part. 

 

 

 

 

 

 

     

     Fig 3.1          Fig 3.2 

 

 

 

 

 

 

Fig 3.3           Fig 3.4 

 

                                                                                                      

It is better if you hide the grips which are not associated with the Polar Stretch Parameter as below: 
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4. Test Dynamic Block:  

                                                                                                 

Open the graphic which needs to be dimensioned 

and insert the completed dynamic block (Fig 4.1). 

Drag the grip of the dynamic block, the section 

symbol can be stretched outward and rotated 

around the center, and you finish the section 

symbol mark (Fig 4.2). 

        

           Fig 4.1       Fig 4.2 

 

 

Polar Stretch Action Characteristics: Modify the grips’ number of the polar parameter 

in the section symbol dynamic block in the last example to display both of the two 

grips of the polar parameter. From the following picture we can see that the central 

grip is clearly different before and after. Before modifying, the central point was 

actually the base point of the block, and this was the insert point. But after modifying, 

the center point of block is the base point of the polar parameter. 

 

Clicking central grip can move the grip to any direction. Meanwhile, the dark blue insert point of block will appear again, as 

shown in the following picture. Obviously, the insert point is only covered by the base point of the polar parameter. The base 

point of the polar parameter can move arbitrarily, but for the block it seems that no 

change is happening. But is it true? 

 

  

In order to confirm if the block changes or not, we move the grips on 

both terminals and we can find that the section symbol does not center 

on the dark blue base point when changing but it takes the base point of 

the polar parameter as a rotate center, as shown in the following picture. 

 

Enter block editor, move up the parameter and the other settings do not change. 

 

 

  

 

 

 

 

Exit block editor, move the right grip and you can see that rotate center moves up along with the parameter. From the examples 

above it is difficult to understand that the polar parameter cannot move arbitrarily like the point parameter and linear parameter, 

the reason is that the base point of the polar parameter 

specifies the rotate center of the object, once the parameter is 

moved, the rotate center will move accordingly. That the rotate 

parameter cannot move arbitrarily has the same reason. 
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Array: For the Array function of Dynamic Block we need to use Array Action, we use Array Action to match with Linear Parameter, 

Polar Parameter, XY Parameter to achieve various Arrays. 

 

Linear Array 

 

1. Draw: Draw a parts list and define it as a block. 

 

2. Add Linear Parameter: After adding Array Action, we can drag the two grips of the Parameter to make a list array, but 

obviously, we hope just to achieve an up array of the blank bar, not a down array, so to avoid a mistakes, we should hide the 

grip under the Parameter, as in the following picture. 

 

 

 

 

                                                                                              

3. Add Array Action: During the add Array Action, the system will require to appoint space between columns. The space 

between columns is the distance between the objects that the array created. Here, the line width is 7mm, for the line between 

the lines a close up array can be chosen, we appoint that the space between the columns is 7mm. 

 

 

 

  

 

                                                                                                

4. Test Dynamic Block: Insert Dynamic Block, drag the top right corner grip upwards, the line number of the part list will be 

added automatically, as in the following picture. 

 

 

 

 

  

 

 

 

 

 

 

 

 

XY Array   

Compared with Linear Array, XY Array 

has a vertical direction Array.  
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Polar Array 

We see a Dynamic Block example as follows, after 

dragging grip, the effect will be as in the following 

picture. You can see, not only can we stretch the fence, 

but we can also rotate the direction casually, this is the 

effect combining Polar Stretch with Polar Array. 

 

  

Enter into Block Editor, Stretch, the ways of adding Array 

Action as in the following picture, the bold object expresses 

the relevance with the selected action. The Polar Parameter 

determines the way of Array directly, the Polar Array will regard 

the direction of the Polar Parameter as Array direction, 

achieving Array functions in any direction. 
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